Steam for Linux

Steam for Linux

Can't add WINE games into game library
I would like to have the steam overlay on my WINE-based games, unfortunately adding the shortcut to Steam doesn't work properly. Does anybody know a workaround or fix for this issue? Thanks :)
< >
Näytetään 1-9 / 9 kommentista
I don't know how to use the overlay on non-steam games, but I am able to add wine games and other non-steam games.

First method: On the first time I tried to add a non steam game I created a .desktop file for the game:
[Desktop Entry]

Saved as xonotic.desktop. Now go to "Add a non-steam game to my library", select browse and navigate to the file. I am not sure if I really need to keep the file in the same directory as the game but I did it.

The second method worked for wine:
Just add anything using the "add a game" window. Then just right click on the game or app you added and go to properties. Now do something like this:

wine "~/.wine/drive_c/Program Files (x86)/StarCraft/StarCraft.exe"
Start in:
wine "~/.wine/drive_c/Program Files (x86)/StarCraft/"

This method probably works for linux native non-steam games too.
medv4380 29.1.2013 kello 13.03 
Method 1 doesn't work under Ubuntu 12.10 64bit. Method 2 has some weird leak. First game I added was Sims 3 Under Wine using and environment flag to choose the wine Install. Worked Fine. Added Diablo 3 which has a different wine install, but when launching it Sims 3 comes up. Added Neverwinter Nights which is the Native Linux Client, and Sims 3 comes up. There is some sort of leak that Method 2 trips over, and is probably why method 1 doesn't work. However, when it works the Overlay does not work for me. I suspect because I'm in Unity and Cannot use a Virtual Desktop and not have the Unity Bar force itself to the top when the game goes full screen.
Doggybag 10.2.2013 kello 17.59 
Thanks, I was able to get method #2 to work for me under Fedora 17 / KDE4 (which was probably a bad choice for setting up games, but I never want to see Ubuntu's Unity desktop again). I was trying out a wine install on an external drive so I have something like:

Starcraft II

WINEPREFIX=/media/usb-mydrivewinedows /usr/bin/wine C:\\games\\Starcraft\ II\\Starcraft\ II.exe

Start in:
/media/usb-mydrive/games/Starcraft\ II

Method #1 didn't work for me. KDE/plasma doesn't seem to use the ~/Desktop in a way that allowed me to do that correctly and I didn't bother playing around with it under the gnome desktops.
Method #2 dont work for me.
Is there any log to watch out the errors?
Schotty 4.12.2015 kello 1.26 
I create .desktop files for each title and plop them into  ~/.local/share/applications
Now they show up in GNOME3 and in steam. I can fire up any PlayOnLinux or Crossover Linux (CX plops them into the aforementioned folder automatically) Title as well as Java apps like Minecraft or FeedTheBeast.
Spidey 17.7.2017 kello 21.16 
Since the Steam Store no longer opens on wine Steam, I found a work around for free games that do not sicky in your library, and do not have an online feature, like Fallen Earth.
1) Install any game in your library or you can view servers, look for Team Fortress (TF2, it is free) and click on connect. This will not launch the game but install it. If your game is in this list, you're done!
2) Right click on that game and create a desktop shortcut.
3) Using your favorite browser (not steam) login to the steam store.
4) Find a free to play game that only runs on windows (needs wine steam) and right click/copy the Play Now button.
5) Find the desktop shortcut (wine steam creates two files, the shortcut and a .url, ignore the .url) and right click/edit.
6) now, in you favorite text editor, paste the link from the browser. It will look like this: steam://run/113420
(that's for Fallen Earth!)
7) replace the number in the desktop shortcut with the one from the link. save it, and double click the link.
8) mark it as executable on the next window, and steam will launch and install your new free to play game!
Schotty 18.7.2017 kello 17.20 
Spidey lähetti viestin:
Since the Steam Store no longer opens on wine Steam,

That has been fixed in Crossover. I am sure that the next release of wine will have that patch applied. Last week Codeweavers dropped an update specifically for this issue.
This is what I did to get a windows build of GZDoom to launch from my linux steam

wine ~/.wine/drive_c/Games/GZDoom/gzdoom.exe

Start in:
wine ~/.wine/drive_c/Games/GZDoom/

do not use quotations when adding the shortcut. this not only launches the game but it also properly allows the overlay.
If you have Steam games that run only on Win32 you will need to install the Windows version of Steam under Wine then install the games on that instance of Steam.
< >
Näytetään 1-9 / 9 kommentista
Sivua kohden: 15 30 50