Steam for Linux

Steam for Linux

Hizeph 10. Dez. 2012 um 10:33 Uhr
[Solved] Fatal Error: Failed to load
I'm trying to run Steam on Fedora 17 x86_64, but during the installation, i get this:
Installing breakpad exception handler for appid(steam)/version(1354925460_client)
Installing breakpad exception handler for appid(steam)/version(1354925460_client)
and the link on /home/myuser/.steam/bin64 is broken because de .local/share/Steam/ubuntu12_64 doesn't exist.
Someone got any ideas?
Zuletzt bearbeitet von Hizeph; 11. Dez. 2012 um 16:18 Uhr
< >
Beiträge 111 von 11
eliteSchaf 10. Dez. 2012 um 11:31 Uhr 
Are the 32bit libraries installed? On Ubuntu i had to install "ia32-libs" to make it work.
Seems like they missed a dependency
Zuletzt bearbeitet von eliteSchaf; 10. Dez. 2012 um 11:31 Uhr
Hizeph 11. Dez. 2012 um 16:18 Uhr 
I just got a repo for Fedora, and it installed those 32 bits libs as a dependencies, guess it was the problem! Thanks
DNStorage 18. Dez. 2012 um 13:18 Uhr 
Thanks for the solution. installing "ia32-libs" worked for me. Xubuntu 12.04.1.
Quantum 22. Dez. 2012 um 11:03 Uhr 
Hey if it's not to much trouble what was the repo that you used for Fedora?
Hizeph 22. Dez. 2012 um 14:01 Uhr 
Create a file like "steam.repo" with this content:

# Place this file in your /etc/yum.repos.d/ directory

name=Steam RPM packages (and dependencies) for Fedora
jyoung546 26. Dez. 2012 um 14:40 Uhr 
I have Ubuntu 12.10 installed on an HP dv6-7014 with a GT-650m Optimus (bumblebee installed). To fix this error I followed the instructions in this thread.
cde 28. Dez. 2012 um 23:51 Uhr 
I fixed this error on Debian Wheezy (amd64) with export LD_PRELOAD=${HOME}/.local/share/Steam/ubuntu12_32/ before running steam

EDIT: fix is incorrect, the proper solution is to upgrade /usr/lib32/ so the symbol gdk_window_get_screen is present (this was due to my ia32-libs-gtk package being from squeeze, and thus too old)
Zuletzt bearbeitet von cde; 29. Dez. 2012 um 0:15 Uhr
Quantum 2. Jan. 2013 um 12:46 Uhr 
Yeah but fedora is different , it lacks a lot of the libraries that Debian has. Plus it's not a noob distro like Ubuntu you have to compile the steam beta from source.
blackout24 2. Jan. 2013 um 13:00 Uhr 
There is no source available for the Steam Client. Repackagin a deb file is far from "compiling it from source" it's more like extracting a zip file and repackaging it as a rar file so it can be registered in the local package manager...
Quantum 3. Jan. 2013 um 12:17 Uhr 
Have you looked around? I'm not talking about a deb file. That's like a bit rpm
Quantum 3. Jan. 2013 um 12:23 Uhr 
P.S the repos that are stated in this discussion are out dated and don't work anymore.
< >
Beiträge 111 von 11
Pro Seite: 15 30 50

Geschrieben am: 10. Dez. 2012 um 10:33 Uhr
Beiträge: 11