Steam for Linux

Steam for Linux

Team Fortress 2 crashes when starting online game, and how I solved some other crashes
I run archlinux with xmonad, and the latest nvidia proprietary drivers.

Here are a couple of problems I've already fixed, but the game still crashes when I try to join an online game. (Training works great!)

Problem I have NOT SOLVED:
1.Segfault when joining online game.
It gets past the regular client stuff and segfaults right before the map loads. Single player stuff like training works fine.

Here are the logs:

I have already checked to make sure the filename locations and cases are correct.

2. My mouse cursor is backwards when I launch steam.

Problems I've SOLVED, and how I solved them:

No Sound
put this in your ~/.pam_environment:

if you use pulse: SDL_AUDIODRIVER=pulseaudio

then restart your desktop manager.

Alternatively (and this is what I prefer) you can just throw

export SDL_AUDIODRIVER="alsa"

into your ~/.xinitrc if you use a custom session or no DM

Game crashes after intro video, before main menu:
sudo modprobe -r joydev

This disables joysticks, but allows TF2 to run.
To reenable joysticks:
sudo modprobe joydev
Dernière modification de x2a; 6 déc. 2012 à 14h50