Steam for Linux

Steam for Linux

Sua_Mãe Apr 19, 2014 @ 4:34pm
Extremely slow download on OpenSUSE 13.1
Hi there, folks. I just installed OpenSUSE 13.1, installed Steam following the instructions on OpenSUSE`s wiki. Steam launched and apparently works ok, but I am having extremely slow downloads speed as I am trying to download DotA2, for example. Speeds around 0KB/s to 20KB/s. I have a 10Mbps connection, wich is working at good speed (just checked it, several times). I already tried to change the download location on settings, but it doesn`t work. Maybe someone is experiencing similar problems, or have some idea to help me?
< >
Showing 1-15 of 21 comments
Wisetrem Apr 19, 2014 @ 4:41pm 
Have the same on Gentoo with KDE. But have no solution =(
The speed varies from 0 to 70 kb/sec(the bandwidth is 100 Mbps originally).
TheCrabPeople Apr 19, 2014 @ 5:03pm 
I fixed slow and intermittent internet connections in a few distros. By disabling IPv6 in network settings
Sua_Mãe Apr 19, 2014 @ 5:04pm 
So strange. Thought it could be some problem with wi-fi, despite other downloads being made on full speed, but it wasnt. Same problem using the cable. Tried disabling the OpenSUSE firewall also didnt solve the problem. Have no idea what is wrong. For the record, I am also using KDE, on OpenSUSE 13.1, a fresh install.
instabilis Apr 19, 2014 @ 5:10pm 
DOTA2 can be slow as it's so popular, I remember having to queue for it. Could try changing the region server, and making sure the download limit isn't capped in settings.
Last edited by instabilis; Apr 19, 2014 @ 5:12pm
Sua_Mãe Apr 19, 2014 @ 5:16pm 
Already changed download server (tried many different regions), no download limit, and it is slow with any game, not only DotA2. Im gonna try to disable ipv6, as suggested. Gonna post the result in some minutes.
Wisetrem Apr 19, 2014 @ 5:36pm 
Disabling ipv6 on the interfaces didn't work fo me.
Last edited by Wisetrem; Apr 19, 2014 @ 5:37pm
phillippi2 Apr 19, 2014 @ 5:46pm 
I had the same problem until I changed over to a wired connection. If you can, try a different adaptor, whether or not it's wired.
Sua_Mãe Apr 19, 2014 @ 6:22pm 
Disabling ipv6 also did not work. Changing adaptor, as I said before, didnt work. Maybe it has got something to do with the shared libraries steam uses, Ill try to enforce the use of the system libraries, and not the ones shipped with the steam software.
Sua_Mãe Apr 19, 2014 @ 6:58pm 
Or maybe it has got something to do with p2p. Steam client downloads the game files using p2p, also, doesnt it?
Sua_Mãe Apr 20, 2014 @ 2:00am 
Well it got something to do with OpenSUSE, or KDE. Tried Same version of OpenSUSE on my desktop, the same ♥♥♥♥ happened. Removed OpenSUSE from the desktop and replaced it with Ubuntu (14.04, last version), and the download speed is normal...
Well I will download my games in Ubuntu, and move them to the OpenSUSE install through the network. But anyway, if the client`s developers want any data on the problem, I am here to help :P
instabilis Apr 20, 2014 @ 3:48am 
Hmm maybe OpenSUSE has some kind of network throttle enabled by default?
Flyhigh Apr 20, 2014 @ 12:40pm 
What says 'tail -f /var/log/messages' while downloading?

Do you have the problem only on steam? How many download speed do you get on an web speedtest?

I never got such problem on openSUSE 13.1 (64Bit) + KDE
Last edited by Flyhigh; Apr 20, 2014 @ 12:41pm
Sunr' ever Apr 21, 2014 @ 2:44pm 
I'm running OpenSUSE 13.1 + Cinnamon for a while and I never had this problem. It's probably Steam related, I guess.
night5ky Apr 22, 2014 @ 12:31am 
Originally posted by instabilis:
Hmm maybe OpenSUSE has some kind of network throttle enabled by default?

Would be strange, I'm using it with KDE and have no problems, wired connection though.
arc| Gps Apr 23, 2014 @ 1:23pm 
no problem for me either,openSUSE 13.1 kde

< >
Showing 1-15 of 21 comments
Per page: 15 30 50

Date Posted: Apr 19, 2014 @ 4:34pm
Posts: 21