Steam for Linux

Steam for Linux

Noname Jan 26, 2014 @ 9:26pm
FEZ won't start after recent updates (Lib problem?)
Suddenly Fez stopped working. I've unable to solve this issue.

When is starts is says=
ERROR: object '/opt/steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded: ignored. CGameStreamThread: Added instance ID 23186 for appid 224760 CGameStreamThread: Added instance ID 23187 for appid 224760 CGameStreamThread: Added instance ID 23188 for appid 224760 Focused window is now 0, 0 CGameStreamThread: Added instance ID 23189 for appid 224760 CGameStreamThread: Added instance ID 23190 for appid 224760 OnFocusWindowChanged to window type: k_EWindowTypeNonSteamDesktop, 0 (18:39:34.133) [OpenAL] Context created (18:39:34.147) [OpenAL] Available mono sources : 255 (18:39:34.151) [OpenAL] Sound manager initialized! Stacktrace: at (wrapper managed-to-native) FezSteam.Steam.Initialize () <0xffffffff> at FezGame.Fez..ctor () <0x001d7> at FezGame.Program.MainInternal () <0x00033> at Common.Logger.Try (System.Action) <0x0001b> at FezGame.Program.Main (string[]) <0x008d3> at (wrapper runtime-invoke) <Module>.runtime_invoke_void_object (object,intptr,intptr,intptr) <0xffffffff> Native stacktrace: /opt/steam/steam/SteamApps/common/FEZ/lib64/ [0x7f215f9ca388] /opt/steam/steam/SteamApps/common/FEZ/lib64/ [0x7f215fa2058f] /opt/steam/steam/SteamApps/common/FEZ/lib64/ [0x7f215f94e65b] /lib/x86_64-linux-gnu/ [0x7f215f008210] /opt/steam/linux64/ [0x7f2146d42655] /opt/steam/linux64/ [0x7f21465d343d]
Any ideas?
< >
Showing 1-6 of 6 comments
Noname Jan 26, 2014 @ 9:42pm 
Solved! Problem was that I opted for steam beta participation to get in-home streaming! I switched back to non-beta steam and now it works again.
There are currently several games not starting. Including Reus, Ticket to Ride and others. All since the last beta update of the Steam for Linux client.

Toki Tori 2 seems to be affected as well.
Noname Jan 26, 2014 @ 10:43pm 
Ok, thx. I'll subscribe to that thread too.
Last edited by Noname; Jan 26, 2014 @ 10:44pm
leeps Jan 27, 2014 @ 6:27am 
Confirmed for 64bit Linux.
Reus stack trace suggests that Steamworks Library had some changes that are not working properly:

#5 <signal handler called> #6 0x00007feffcb9e655 in ?? () from /home/leeps/Steam/linux64/ #7 0x00007feffc42f43d in ?? () from /home/leeps/Steam/linux64/ [...] #17 0x00007feffd5ca758 in ?? () from /home/leeps/Steam/SteamApps/common/Reus/lib64/ #18 0x00007feffd5cae7d in SteamAPI_Init () from /home/leeps/Steam/SteamApps/common/Reus/lib64/ #19 0x00007feffd7d8b38 in Initialize (managedOverlayDelegate=0x41b66430, managedUserStatsReceivedDelegate=0x41b664a0, managedUserStatsStoredDelegate=0x41b66510, managedTextInputDismissedDelegate=0x41b66580, managedLeaderboardFoundDelegate=0x41b66600, managedLeaderboardInitializedDelegate=0x41b66650, managedLeaderboardFriendScoresDownloadedDelegate=0x41b666b0, managedLeaderboardCompletedFriendScoresDownloadDelegate=0x41b66700) at /home/flibitijibibo/Programming/csProjects/Steamworks#/native/SteamworksNative.cpp:207
#5 is the handler for the SEGV, so it happens in #6. get loaded from in #17, which should be a subroutine called from SteamAPI_Init() in the same library, which is already part of the Reus game libraries.
The newest beta-client seems to be fixed now - all games that I could try (including FEZ and Reus) work again :) Thanks, devs!
leeps Jan 27, 2014 @ 3:03pm 
confirmed, thanks from me, too.
< >
Showing 1-6 of 6 comments
Per page: 15 30 50

Date Posted: Jan 26, 2014 @ 9:26pm
Posts: 6