Age of Empires II: HD Edition

Age of Empires II: HD Edition

View Stats:
мrsтevie May 3, 2013 @ 6:26pm
Game crashes when I start a game

I have a problem where the game would launch fine and I can navigate around the menu fine. But whenever I start a game (Campaign, Single Player or Multiplayer), the game would load but then it would crash with no error message. For example, I would see my Town Centre and villagers and the game would crash. Sometimes I can get an action or two in before the game would crash.

This happens a lot but sometimes does not happen and I would play the game fine. Sometimes I would turn my computer on and try and play but this problem will happen. I walk away come back in a few hours and then try again and I would be able to play fine. I'm pretty sure nothing has happened to my PC during that time.

Can anyone help me with this problem?

Thanks in advance. :)
< >
Showing 1-15 of 18 comments
Netoberg May 3, 2013 @ 11:09pm 
Yeah you must be another win xp user.

This game does not work for win xp and will prolly never do...

Ask for a refund or get win 7. devs are ignoring this issue since game launch.

Welcome to real world of profit and lack of quality...
мrsтevie May 4, 2013 @ 12:03am 
But I actually do have Windows 7. :(

I should mention my specifications:
OS: Windows 7 64-Bit
CPU: Intel Core i7-2700K @ 3.50GHz

I've also installed all the recent drivers so it should be working fine and I'm pretty sure my PC would be more than enough to run AoE2. :(
Tausret May 4, 2013 @ 4:40am 
This is not a XP Problem, I have Win8 and it crashes when I start any campaign or Single Player Game.
мrsтevie May 4, 2013 @ 9:57am 
Tausret, do you find that sometimes the game would work fine?
Tausret May 4, 2013 @ 1:18pm 
No! The resolution is bad, i think I have an old game, not HD. Sometimes I have black boxes instead of Text. I'm not satisfied.
Lord Ekard May 4, 2013 @ 1:23pm 
also I am having problems, when i start the icon the client crashes and don't see any initial menu to play
cdf888 May 5, 2013 @ 2:02am 
What I feel is more than enough all of you,that the game could be run,suddenly my computer crashed with large noise to fear,the only thing shall I dare to do was to reboot my pitiful computer.
мrsтevie May 8, 2013 @ 5:46pm 
Tausret, I can understand your frustration. I also expect for a 13 year old game to not have these trivial problems either. :(

Lord Ekard, I am able to launch the game and the menu will appear. However, when I try to start a match, the game will crash for me. It sounds like your problem might be a different issue. Although the cause of our problems may potentially have the same root cause.

cdf888, I don't hear any loud noises and rebooting my computer doesn't do anything either.

I hate these sometimes occuring issues that its hard to determine the cause. :(
мrsтevie May 16, 2013 @ 7:01am 
I opened up the dump file that is produced every time the game crashes. Woud anyone know what this means?


Microsoft (R) Windows Debugger Version 6.2.9200.20512 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Users\mrstevie\Desktop\aok hd_12211234_crash_2013_5_16T11_37_10C0.mdmp]
Comment: ''
User Mini Dump File: Only registers, stack and portions of memory are available

Symbol search path is: *** Invalid ***
* Symbol loading may be unreliable without a symbol search path. *
* Use .symfix to have the debugger choose a symbol path. *
* After setting your symbol path, use .reload to refresh symbol locations. *
Executable search path is:
Windows 7 Version 7601 (Service Pack 1) MP (8 procs) Free x86 compatible
Product: WinNt, suite: SingleUserTS
Machine Name:
Debug session time: Thu May 16 21:37:10.000 2013 (UTC + 10:00)
System Uptime: not available
Process Uptime: 0 days 0:00:15.000
This dump file has an exception of interest stored in it.
The stored exception information can be accessed via .ecxr.
(1764.1d0c): Access violation - code c0000005 (first/second chance not available)
*** ERROR: Symbol file could not be found. Defaulted to export symbols for ntdll.dll -
eax=00000000 ebx=00000000 ecx=013d58f0 edx=0026dd4c esi=000005ac edi=30281049
eip=77cd0c22 esp=0026b9c4 ebp=0026b9d4 iopl=0 nv up ei pl zr na pe nc
cs=0023 ss=002b ds=002b es=002b fs=0053 gs=002b efl=00000246
77cd0c22 83c404 add esp,4
Cheese_Wire Dec 28, 2013 @ 4:05pm 
Hi guys, I'm really sorry if this wastes your time, as I know this discussion is many months old, but have any of you solved this issue? I've now come across it. I swear AOE II HD was fine when I first got it, but since installing the new expansion, The Forgotten, over Christmas, after receiving it as a gift from my brother, I'm now getting the same error you all get. It is really frustrating as I desperately want to play the new campaigns, but no maps will open, with the "Age of Empires II HD has stopped working" message cropping up. Sorry if this is the wrong place to ask this question. I'm new here.
P.S. I'm not using a beta version or anything like that.
Thank you so much for any help you can provide. :)
мrsтevie Dec 28, 2013 @ 7:24pm 
I found a weird work-around for this issue that worked for me. I would change my computer's time and date to a previous date I know where it would run the game. For example, if I knew that game would work at midday from the previous day, I would change the time and date of my computer to that time and it would work. This is pretty annoying to do and I would have to launch a game and change the time every time until I could find a time where the game would work. Also, if I have been playing for a few hours and the time ticks to a time where the game wouldn't work, it would just crash. So I figured that this was a software problem...

However, I have recently formatted my computer and installed my Steam game files onto a different drive and it seems to have fixed the problem. So it might be a hardware problem...

In conclusion, I have no idea what the issue was. :(

Hope this helps.
Cheese_Wire Dec 29, 2013 @ 4:20am 
Thank you, I'll try these out. Thanks for responding! :)
Cheese_Wire Dec 29, 2013 @ 7:13am 
мrsтevie, I just wanted to say thank you. I installed the game on an external hard drive, which means I can only use Steam when it's plugged in, which kinda sucks. But the main point is that it is mostly working now. So your advice about installing Steam elsewhere has been very helpful. Thank you so much!
Have you got it working yet? the same thing is happening to me
Cheese_Wire Jun 28, 2014 @ 2:04pm 
Sorry it took me a while to respond, I rarely check Steam. I assumed that the problem for me was something to do with the version/patch at the time, because whilst the alternate drive solution worked for me, when I came back to the game months later there must have been some sort of update, because since then I haven't needed my external harddrive, my normal PC's one can run it just fine.

So I am surprised that this issue still exists, and am sorry to say short of trying the alternate drive solution мrsтevie suggested, I don't know what to say. It need not be an external harddrive like I used, I suppose. If your PC has an extra internal drive you could install the game (and Steam) on instead, that may do. Or you could use a friend's PC to install it all, just to check and see if it works for them, or if it's just your own PC having the troubles. Tedious, I know, but I have no other ideas.

Really sorry I can't be of more help. I know this problem is really infuriating. If you find a solution, please let me know in case it happens to me or anyone else in the future.
< >
Showing 1-15 of 18 comments
Per page: 15 30 50

Date Posted: May 3, 2013 @ 6:26pm
Posts: 18