Age of Empires II: HD Edition

Age of Empires II: HD Edition

Statistieken weergeven:
Age of Empires II: HD Edition > Support > Details van topic
[Linux+Wine] Works!
Only a few minor tweaks you need to do to make it work, this is assuming you have steam running through wine already.

1. Install game
2. cd to "drive_c/Program\ Files/Steam/steamapps/common/Age2HD/"
3. Rename the "Launcher.exe" to "Launcher.bak" and "AoK HD.exe" to "Launcher.exe"
4. Inside of steam, add "-nostartup" to the launch options.
5. If your cpu automatically downclocks, disable that. For me, it was "sudo cpupower frequency-set -g performance"
6. Run the game, note that it will take several minutes to start up as the VS2012 redistributal and the directx fail to install, but it will run.
Laatst bewerkt door Sparks; 5 apr 2013 om 22:39
< >
1-15 van 119 reacties weergegeven
is this if you have windows xp?
This is if you have linux...
omg im a derp, sorry mate
I got "Unhandled exception" right after clicking on "start game" (Single player) on the first screen. Ubuntu+Wine 1.4 Does anybody also have this problem?
Game starts, navigation is displayed, but the map says black.
Origineel geplaatst door mitmischer:
Game starts, navigation is displayed, but the map says black.
Did you do step 4? That is a problem on windows as well.
I admire your effort to make this working on Linux. Honestly, even when I use Linux daily for router app etc, I'd never use Linux for gaming. It's far behind Windows, and I can't be bothered to do troubleshooting for that or even emulate (for lack of better term) with Wine.
Origineel geplaatst door zeroxxx:
I admire your effort to make this working on Linux. Honestly, even when I use Linux daily for router app etc, I'd never use Linux for gaming. It's far behind Windows, and I can't be bothered to do troubleshooting for that or even emulate (for lack of better term) with Wine.
Thanks for your opinion, but I will stick to Linux. Computers mean much more than just gaming to me.
The launcher works too, but you have to use winetricks to install vcrun2010, d3dx9_43, and xact. I had to remove some of the .vdf files that didn't install correctly to get it to start. Needs Wine 1.5.25+ for the launcher (1.5.27 works great for me).
Laatst bewerkt door Nell; 9 apr 2013 om 1:15
I didn't have any luck with the launcher(hence the renaming of the main executable). But, to be honest, I don't want a stupid launcher anyways. So it all works out :)
Yeah, the launcher is kind of just annoying. I may just try the renaming but it seems like it would break at every update.
Origineel geplaatst door Colgy:
6. Run the game, note that it will take several minutes to start up as the VS2012 redistributal and the directx fail to install, but it will run.

Delete the folder _CommonRedist and there should be no such installation attempts anymore. Should speed up the process. At least it works that way for almost all games.

Just note that this will be reacquired when validating files etc...
I tried doing this by myself with Wine on OS X… seems like I forgot step 3. Nice trick, and thanks a bunch! As a neater fix, it would be nice if there was a launch option to prevent running the launcher beforehand.

Once I got the game running, I had to "emulate a virtual desktop" in winecfg, because the game's window only covered a quarter of my screen but seemed to think I was using my native res.

I then unchecked "Full screen" to get it back into a window, then I quit the game and disabled using the virtual desktop in winecfg to get the game in a "raw" X11 window. Not sure what to do about playing in full screen though…

By the way - you can avoid having to use a virtual desktop if you can get to the "Full screen" checkbox in the Options…
Laatst bewerkt door pl; 9 apr 2013 om 6:55
This resolves the issue of the "black screen" for me, but by some reason it removes the army control area (where you tell them to patrol, defensive mode i.e). Any idea how to solve that?

Anyway, thanks for the guide =)
Origineel geplaatst door pont4:
This resolves the issue of the "black screen" for me, but by some reason it removes the army control area (where you tell them to patrol, defensive mode i.e). Any idea how to solve that?

Anyway, thanks for the guide =)

Sounds like you have it in simplified mode? There's a button near the mini-map that toggles that.
< >
1-15 van 119 reacties weergegeven
Per pagina: 15 30 50

Age of Empires II: HD Edition > Support > Details van topic