Age of Empires II: HD Edition

Age of Empires II: HD Edition

View Stats:
Neverlax Apr 5, 2013 @ 10:43am
compatible with DirectDraw?
Could not initialize graphics system. Make sure that your video car and driver are compatible with directDraw.

what is this error? can you help?

I run AMD radeon 7950
i5 3570k
16gb corsair ram
ect
< >
Showing 1-15 of 34 comments
BarbarossaBlade Apr 5, 2013 @ 10:58am 
Have you checked for driver updates?
Neverlax Apr 5, 2013 @ 12:06pm 
yes, all up to date, i hear many people are having problems so i will wait and see what happens.
azin Apr 8, 2013 @ 7:37pm 
neverlax, you could solve? my friend is having the same problem.. =(
MS Ryz0n Apr 8, 2013 @ 7:39pm 
Everything updated through windows update? We're seeing this from time to time with peopel who are on SP2 or haven't installed all of the windows updates.
Linkman806 Apr 8, 2013 @ 9:31pm 
so people on windows xp sp2 cant use Direct Draw or somthing?
MS Ryz0n Apr 8, 2013 @ 9:33pm 
Originally posted by Linkman806:
so people on windows xp sp2 cant use Direct Draw or somthing?
Service pack 2 does not contain all necessary OS updates. You'll want to use the latest SP3 to ensure you have the necessary windows components.
Neverlax Apr 11, 2013 @ 5:02pm 
I run windows 7 and I still have not found a aolution to this problem yet. Anyone else?
PUИISHED SИAKE Apr 11, 2013 @ 5:22pm 
this problem affects people on Windows 7 too.wtf.
Duke Apr 12, 2013 @ 10:39am 
Could not initialize graphics system. make sure that your video card and driver are compatible with DirectDraw.
I have this problem too.

My specifications are:

XP 64-bit, sp2 build: 3790
Directx 9.0c 4.09.0000.0904
Last edited by Duke; Apr 12, 2013 @ 10:40am
Soylent Waste Apr 12, 2013 @ 2:15pm 
just got this same error message.. i was having such a good day too :(
PUИISHED SИAKE Apr 12, 2013 @ 2:34pm 
Already got the latest drivers, I don't think this is a simple driver issue, considering all drivers these days support directdraw anyways heh.
tmillic Apr 12, 2013 @ 2:44pm 
I'm having the same problem with Windows XP 64bit. (There is no Service Pack 3 for the 64bit version.) Drivers are up to date. DirectX 9.0c is working fine. The machine has an Opteron 2347HE CPU and an Nvidia GT440 GPU. This is unacceptable on Steam's behalf. I will happily take part in a group lawsuit if neither fix nor refund are made.
Same issue here. Using XP DirectX 9.0c. I have asked around other forums and most of them think that direct draw was a very old driver used when AOE first came out. So maybe our drivers are too advanced? But then again how are other people able to play? Probably not relevant but I am able to play other games on steam without any problem.
junqueiralex Apr 13, 2013 @ 5:06pm 
i'm having the same problem, - direct draw compatability -, game doesn't load on my xp, service pack 3!
Neverlax Apr 14, 2013 @ 9:00am 
any solution?
< >
Showing 1-15 of 34 comments
Per page: 15 30 50

Date Posted: Apr 5, 2013 @ 10:43am
Posts: 34