Age of Empires II: HD Edition

Age of Empires II: HD Edition

Age of Empires II: HD Edition > Support > Подробиці теми
Error Code 41
I've been getting the Error Code 41 for ages now. It's the same one described by many other users for other games: I try to launch the game, then a Steam message pops up and says it's installing something, but the installation stops at 1% before giving me the error.

I've reinstalled the game, I've reinstalled Steam, I've redownloaded and reinstalled the game. It almost looked like it was fixed when I reinstalled both Steam and the game, meaning that I could launch the game every time directly from the .exe, but when I rebooted the computer it started giving me the error again.

I can still play the game by quitting Steam and launching the game's .exe when Steam is not on (so the game launches itself and Steam), but if Steam is already running it will give me this stupid error all the time when I try to launch AoE HD.
< >
Показані коментарі 115 із 49
-Are you on Window's XP? Also, can you post a screenshot of the error? Then we can have a better idea how to help.
I had something similar before (months ago) and disabled 'Steam Cloud synchronisation' (Properties -> Updates). This synchronisation took too much time anyway and I always play from the same computer.

I hope it helps for you.
I'm using Windows 7. I tried disabling the Cloud Sync, but it didn't work :(

Here's a screen of the two errors:
-Ah, it is a Steam error. Hmmm. What does the support page say?
The support page is this one:

I didn't find anything that seems to be the possible cause though. As I said in the first post, the game will launch regularly if Steam is closed when I launch the game. It only gives me the problem when Steam is already open when I launch the game.
-I'm sure you've tried it, but what happened when you right click on game in library->properties->local files->verify? Does the issue still persist?

-I tried looking online for the answer to this. How long have you tried waiting, like leaving on overnight?

-You can also try changing your download rejoin.
Автор останньої редакції: -Dare Devil/x/; 25 лис 2013 о 8:51
Never really tried leaving it overnight, but if Steam is not launched and I try to launch the game, and then I don't start the game (= I don't click on "Play Game"), after a short while it's like if the request expired, and attempting to start the game will result in the same bug.

Aaaanyhow, as I was trying to check the "local files verify" I launched the game from the Library itself...and it worked, even though Steam was already up and running. I created a desktop shortcut from the library, and that desktop shortcut now works every time.

Maybe the issue was just in the path I used to launch the game after all >.< I can kinda consider the problem solved now, there's just one issue left: I'd like to have the icon to launch the game in the "apps bar" (the one on the right of Start) and not on the desktop, but I can't add the Launcher created from the Library (the one that works, which is now on the Desktop) to that bar directly. So, what is the path of a game? I'm in C:\Program Files (x86)\Steam, but I can't find a folder with the .exe to launch AoE. Hopefully I can just add that .exe to that "apps bar" once I find it, and make it work again.

Thanks for the help ^^
Why can't you add the one from your desktop? Just dragging it should work.

If that somehow isn't the case, you can make a copy by holding the CTRL key while dragging.

Maybe nice to know that if you add 'nostartup' to the startup options, the intro movies will be skipped automatically.
I can't drag it either way, there's that red road-sign-like icon if I try. Maybe it's because the link is actually an "url" to steam://rungameid/221380 and not an actual file? Thanks for the info on the movie ^^
Автор останньої редакції: Tooth Fairy; 25 лис 2013 о 10:06
Weird, I tried the same thing myself with the AoE2HD-shortcut and it works.

Could it be that you need admin rights on your pc to do so?
I'm fairly sure I'm "as admin as I can be". No clues on what is the installation path of the game?
Автор останньої редакції: Tooth Fairy; 25 лис 2013 о 13:32
It installs to your Steam directory, by default C:\Program Files (x86)\Steam\steamapps\common\Age2HD, though you can change this when installing.
Found it. Both AoK HD.exe and Launcher.exe give me the usual errors when I try to launch them.

But...there's something else. I tried running both of them as Administrator...and - lol - it works >_< Lame. Now I've added AoK HD.exe to the "apps bar" (whatever it's called) and it works all the time.

Just one last issue: althought I've checked and the Properties of the .exe are set so it always runs as Administrator, every time I launch the .exe itself it will prompt me that pop-up where it asks me Ok/Cancel to launch it or not. Is there a way to tell the computer I always want to accept, and run the program? I know it's not a Steam question, but while I'm here... :D

Thanks again.
-If you are the sole user of your computer (and are responsible..), you can turn of user account control.
Yea but that's an all-or-nothing thing. I just want to authorize this program in particular, not all of them. Anyway, I did some search online and it doesn't look possible =/ Silly not to implement it.

I guess that's all. Cheers ^^
< >
Показані коментарі 115 із 49
На сторінку: 15 30 50

Age of Empires II: HD Edition > Support > Подробиці теми
Опубліковано: 24 лис 2013 о 15:04
Дописів: 49