DayZ
BattlEye Client Not Responding, Being kicked. [Solution][Fix]
Hi.
For the last 3 days i had the "BattlEye Client Not Responding" error pop-up, and it was driving me up the wall.
This is mostlikely caused by frequent micro disconnections between you and your modem/router. (It is, i doubted it too)
------------------------------------------------------
If you are failing to Initialize Battleye
That means that you do not have the BattlEye .DLL files installed.
A simple Verify Game Cache should work fix it
------------------------------------------------------
Apparently some fixes are:
- Verifying your game cache
- Re-installing
- Setting encapsulation (internet connection) to PPPoA and LLC*
- Redownloading BEClient.DLL from battleye.com
- Rebooting, Restarting router/modem
- Disabling Firewall**
- Setting Computer's IP as DMZ**

If those work for you, great good job. Go play or post what fixed your problem in peoples threads to help them out. :)
------------------------------------------------------
However if they didnt,
Make absolute sure your modem and router's firmware are up to date, some companies might
not be up to date with theyre own firmware!

Scour your computer for Bandwidth monitoring tools
- Specifically Cucusoft NetGuard (http://www.cucusoft.com/netguard.aspx) or BandGuard
Get rid of that ♥♥♥♥, it cause network problems latency and shinanigans.***

Check any programs that may interfere/monitor/interact with your connection to your network.
------------------------------------------------------
Also BattlEye are apparently working on a fix.


*(note) If your router does not support PPPoA/LLC dont worry about it.

**(note) This can and will put your computer completely outside both your computers firewall and your modem/router firewall/protection. You may get virus, run anti-virus scan before going back behind firewalls and once behind firewalls.

*** .sys files can be a pain to remove.
steps:
- open cmd.
- sc stop "(The service it says when you try and delete said .sys file)"
- sc config "(The service it says when you try and delete said .sys file)" start= disabled
- sc delete "(The service it says when you try and delete said .sys file)"
------------------------------------------------------
Link this is other threads if it works for you. Otherwise go cry yourself to sleep for frustration and lack of Dayz... i know i did :'(

Good luck :)

Edit* To Verify Game Cache:
-Right click on DayZ -> Properties -> Local Files -> Verify Integrity of Game Cache

------------------------------------------------------
Edit numero duo
15-Mar-16

There have been a few people contacted via friend request, which is great, strongly reccomended and am happy to help. But i thought i might add another step to isolate whether it is a hardware problem or not involving a router.

It's a simple ping test to verify your router is recieving/sending packets consistently, then testing your internet connection for the same.

- open cmd (1)
- ping *router ip address* - t

- open another cmd (2)
- ping 8.8.8.8 -t

Where
: *router ip address* is your internal router ip address, you should already know this is you've tried the above steps.

: 8.8.8.8 is a google server, commonly optionally used by some for DNS.

: -t is an infinite ping, just close cmd to stop it.

Both cmd's will then begin spitting out single lines, observing the "time= " line, we're looking for a consistency in numbers. If they aren't consistent, as in massive jumps up into the hundreds, then this would also explain why you have varying ping/stuttering lag in multiplayer games and probably why battlenet is Dc'ing you.

Also, cmd (1) should be <4 ms, cmd (2) will vary for each person, i get ~30 ms, so they should be around there.

Last edited by AussieKamikazi; Mar 14, 2016 @ 5:00pm
< >
Showing 1-15 of 20 comments
AussieKamikazi! Mate! Thank you so much! This issue has been impacting me playing Arma 2 DayZ mod for over a year, and now again with DayZ SA's latest patch which included Battleye. Little did I know that it was a simple free program I had installed that was stopping me from playing.
It was a program I had installed that interfered with Battleye initialising correctly. I deleted Cucusoft Net Guard (a free bandwith monitor) and now I no longer get the Battleye: Client Not Responding message and can play DayZ!!!!!!!!!!!!!!! WOOT!
AussieKamikazi Jan 11, 2014 @ 3:19am 
^.^ i do try.
Spread it around, suprisingly enough people dont know how to use a search function. -_-
Background Jan 11, 2014 @ 5:13am 
I will take a look at some of these things for my friend. It is pretty bad that their anti-cheat engine has trouble connecting to its own servers, or whatever is going on... a new game like this should not have an anti-cheat engine that feels like it's 10 years old (The BattlEye company is actually 10 years old now, huh).
NZBARRY Jan 11, 2014 @ 2:12pm 
how do you "verfiy game cache"?
AussieKamikazi Jan 12, 2014 @ 6:51pm 
Included directions in Edit within OP, for Verify Game Cache
Last edited by AussieKamikazi; Jan 12, 2014 @ 6:52pm
Seravy Jan 13, 2014 @ 4:39am 
I will give some of these a try too, i have tried most though. My brother was getting the problem when staying with me but now has gone home and is not getting the issue. So I suspect mine is router related (Boblite has come up a lot, and the pppoa fix hasnt done anything yet)
Seems like so many of us with this issue are from australia/nz.
Gonna try this...
JusticeOnTV Oct 23, 2014 @ 4:08pm 
i almost tried all of your options but it stil didnt worked.
Mob Rule Oct 23, 2014 @ 8:02pm 
I tried everything under all the forums i could find. Finally i went into Local/c/programfilesx86/steam/steamapps/common/arma2oa and i launched the Arma2OA_BE application. it updated battleye and solved the last 2 days of headaches. hope this helps.
miggz Apr 2, 2015 @ 10:51am 
It was the micro-disconnections for me. I don't know why I didn't think of that first as my router always does it. Maybe because I'm not used to the way Bohemia games lag out? Either way, thanks for the.... reminder?
tommy Dec 20, 2015 @ 10:48am 
I'm having lots of issues, I sent you a FR if you could help me
Jabarabo Jun 20, 2016 @ 2:19pm 
the BattlEye client is ok, but the drawbacks are a lot worse with how it sometimes forgets to update or cant even connect to its own servers. This shouldnt be a problem with how amazing arma 3 is
Dylan Jan 8, 2018 @ 9:00am 
would this apply to arma 3?
AussieKamikazi Jan 8, 2018 @ 10:02pm 
Arma 3 still uses BattleEye. The system would have been "improved" since then, but i can imagine this would still provide some benefit.
Not A Banana Feb 28, 2018 @ 8:32pm 
Didn't work for me :(

Arma 3 though.
Last edited by Not A Banana; Feb 28, 2018 @ 8:32pm
< >
Showing 1-15 of 20 comments
Per page: 1530 50