DayZ
DayZ > General Discussions > Topic Details
D2 Summer Dec 17, 2013 @ 7:42pm
"Error Creating Direct3D 9 Graphical Engine"
So I orignally downloaded my copy of SA a few hours ago went to play it and got this message, now I heard there were issues with this with Arma 2: OA and I never had any issues with it, i can sit here and play the mod just fine, anyone know why this is popping up? After some searching I checked and it appears my Drivers are up to date, and DirectX is correct even reinstalled it. Any help?
< >
Showing 1-15 of 51 comments
HaDoKen Games Dec 17, 2013 @ 8:15pm 
DX9??? Really? really? really? OMG. Not even DX10 or 11?

Run dxdiag and see if it's installed.
Last edited by HaDoKen Games; Dec 17, 2013 @ 8:15pm
D2 Summer Dec 18, 2013 @ 3:18am 
Thats the thing I have DX11 installed since I have Windows 7 D: and I checked dxdiag and nothing seems to be wrong :/
D2 Summer Dec 18, 2013 @ 3:41am 
If anyone can help or has any ideas I'd appreciate it.
[PV]Tempy Dec 18, 2013 @ 3:44am 
did you try installing DX9 fromt he websetup? Google DirectX Web Setup and get it from Microsoft's site. See if that helps.
D2 Summer Dec 18, 2013 @ 3:46am 
Thats the thing Sponge I did, and I get this "Installation Complete: DirectX setup has determined that a newer or equivalent version of DirectX has been installed already. No installation necessary."
[PV]Tempy Dec 18, 2013 @ 3:47am 
Tried uninstalling DayZ and redownloading it?
D2 Summer Dec 18, 2013 @ 3:49am 
Yes I have uninstalled and reinstalled DayZ twice now, this time I tried the DirectX thing, after what I said poped up, then do you wanna reinstall correctly? Came up, it was half way through then got "an internal system error occured: Please refer to DXError.log and DirectX.log in your windows directory folder."
[PV]Tempy Dec 18, 2013 @ 3:56am 
I bet if you look in that log it'll have the error I got a few weeks ago "something something has already been installed"

To solve that I had to download the full DX9 installer, not just the web setup. Should be gettable from here: http://www.microsoft.com/en-us/download/details.aspx?id=8109

Ignore the fact that it says June 2010, that is the latest.
D2 Summer Dec 18, 2013 @ 4:01am 
I know when I checked the DirectX.log that I did see a "blah blah has already been installed" Thank you I will say if it works or not, and if not I will cry lol. Almost two years for this game, Craptop don't fail me now!
D2 Summer Dec 18, 2013 @ 4:03am 
Where should I install it btw? Its asking me where I want to put the extracted files.
[PV]Tempy Dec 18, 2013 @ 4:04am 
they are just temporary files for the full installer, so anywhere you like.
D2 Summer Dec 18, 2013 @ 4:07am 
Alright the files are extracted what now? Do I try now or was something supposed to pop back up?
[PV]Tempy Dec 18, 2013 @ 10:55am 
There should be a setup file where the files were extracted.
D2 Summer Dec 18, 2013 @ 1:21pm 
Alright I have found it(sorry for taking so long btw was at school), anyways I tried it and it was still poping up. So I completely uninstalled DayZ from my laptop, restarted it. And I redownloaded the DX SDK and I am now waiting for DayZ to reinstall.
D2 Summer Dec 18, 2013 @ 4:17pm 
So I Downloaded it, got DayZ reinstalled and its still poping up the same message :/ Any other fix's?
< >
Showing 1-15 of 51 comments
Per page: 15 30 50

DayZ > General Discussions > Topic Details
Date Posted: Dec 17, 2013 @ 7:42pm
Posts: 51