Quake 4

Quake 4

DinoSmite Apr 24, 2016 @ 6:17am
Low Resolution Textures
As the thread tittle says, anyway to fix the low texture resolution bug?

I set it on Ultra high and all I get are low res textures.

Thanks!
< >
Showing 1-15 of 18 comments
Guydodge Apr 24, 2016 @ 6:38am 
just change these commands in your Doom 3 and Quake 4 autoexec.cfg file:
to these
seta image_downSize "0"
seta image_downSizeBump "0"
seta image_downSizeSpecular "0"
seta image_filter "GL_LINEAR_MIPMAP_LINEAR"
seta image_ignoreHighQuality "0"
seta image_roundDown "0"
seta image_useCompression "0"
seta image_useNormalCompression "0"
seta r_renderer "best"
Last edited by Guydodge; Feb 1 @ 12:58pm — See post history
REPLY

DinoSmite Apr 24, 2016 @ 7:19am 
Originally posted by Guydodge:
just change these commands in your Doom 3 and Quake 4 autoexec.cfg file:
to these
seta image_downSize "0"
seta image_downSizeBump "0"
seta image_downSizeSpecular "0"
seta image_filter "GL_LINEAR_MIPMAP_LINEAR"
seta image_ignoreHighQuality "0"
seta image_roundDown "0"
seta image_useCompression "0"
seta image_useNormalCompression "0"
seta r_renderer "best"
Last edited by Guydodge; Feb 1 @ 12:58pm — See post history
REPLY
Ok I will try it as soon as it downloads.
DinoSmite Apr 24, 2016 @ 2:09pm 
Originally posted by Guydodge:
just change these commands in your Doom 3 and Quake 4 autoexec.cfg file:
to these
seta image_downSize "0"
seta image_downSizeBump "0"
seta image_downSizeSpecular "0"
seta image_filter "GL_LINEAR_MIPMAP_LINEAR"
seta image_ignoreHighQuality "0"
seta image_roundDown "0"
seta image_useCompression "0"
seta image_useNormalCompression "0"
seta r_renderer "best"
Last edited by Guydodge; Feb 1 @ 12:58pm — See post history
REPLY

So I have created a autoexec.cfg file(notepad) and placed it in q4base folder and nothing, no difference.

I say created because there wasn't any in the root folder or anywhere for that matter.

Also I took the liberty of adding/replacing all the lines in Quake4Config.cfg and still nothing.
Last edited by DinoSmite; Apr 24, 2016 @ 2:19pm
In addition to the low res tectures it keeps resetting AA and multicore settings to OFF. What's going on?
DinoSmite Apr 27, 2016 @ 5:07am 
Originally posted by Revan:
https://www.youtube.com/watch?v=DYHpaMVptXc

Thanks for this!

Is there any way to build a batch file, so every time the game is started its done auto/ or a steam command
?

Or more like a mod?
Last edited by DinoSmite; Apr 27, 2016 @ 5:26am
BoneYard May 16, 2016 @ 10:28am 
hello

just to confirm this is not just a Steam Edition problem, i have just installed my disk version and its always low res textures, it is either a Windows 10 issue or an Issue with DirectX 12. It never did this in Windows 7.
Dusk of Oolacile May 16, 2016 @ 2:05pm 
The problem comes from the game not being able to detect VRAM on modern video cards, and it defaults to 64MB, and sets the texture detail limit accordingly.

You actually don't have to change all those values at all. The only thing you have to change is the sys_videoRAM cvar in your config file. Set it to 512 (higher will revert to 512, so no point in going further), and then hit autodetect in the game options. It will unlock max quality, which will persist.

This works with all editions on all non-console platforms.
Last edited by Dusk of Oolacile; May 16, 2016 @ 2:06pm
Bingo that was it. In addition to setting the variable in the config file I had to reset the AA and multicore settings too.
Muff Guzzler May 18, 2016 @ 5:11am 
Originally posted by Dusk of Oolacile:
The problem comes from the game not being able to detect VRAM on modern video cards, and it defaults to 64MB, and sets the texture detail limit accordingly.

You actually don't have to change all those values at all. The only thing you have to change is the sys_videoRAM cvar in your config file. Set it to 512 (higher will revert to 512, so no point in going further), and then hit autodetect in the game options. It will unlock max quality, which will persist.

This works with all editions on all non-console platforms.
I can't find that?
DinoSmite May 18, 2016 @ 7:02am 
Originally posted by All I've Got to Do:
Originally posted by Dusk of Oolacile:
The problem comes from the game not being able to detect VRAM on modern video cards, and it defaults to 64MB, and sets the texture detail limit accordingly.

You actually don't have to change all those values at all. The only thing you have to change is the sys_videoRAM cvar in your config file. Set it to 512 (higher will revert to 512, so no point in going further), and then hit autodetect in the game options. It will unlock max quality, which will persist.

This works with all editions on all non-console platforms.
I can't find that?

Exactly which file do I add this in?
Dusk of Oolacile May 18, 2016 @ 10:40am 
File is steamapps/common/quake 4/q4base/quake4config.cfg.

If you have UAC enabled, and the game installed into a protected area, the file may be virtualised, so look under c:/users/xxx/appdata/local/virtual store. If both exist, you have to edit the one in the virtual store area, editing the one in the game directory won't do anything.
May 22, 2016 @ 10:15pm 
Or try Q4 2016 MiniMod [Tweaks & Fixes] --> This Mod will fix the default Steam *ugly Q4 textures, Memory Limitation + Sound problems.
Basically its Upgrade Mod V4 but all extra mods are cut out. See section [5] in Q U Λ K Ξ - IV - Upgrade Mod 2016

Installation:
Just unzip the zip file and copy its content (except the Extras folder) to your Quake 4 main directory:
C:\Program Files (x86)\Steam\SteamApps\common\Quake 4
DinoSmite May 23, 2016 @ 5:00am 
Originally posted by Danti ۞ Diluvium {Tzimisce}:
Or try Q4 2016 MiniMod [Tweaks & Fixes] --> This Mod will fix the default Steam *ugly Q4 textures, Memory Limitation + Sound problems.
Basically its Upgrade Mod V4 but all extra mods are cut out. See section [5] in Q U Λ K Ξ - IV - Upgrade Mod 2016

Installation:
Just unzip the zip file and copy its content (except the Extras folder) to your Quake 4 main directory:
C:\Program Files (x86)\Steam\SteamApps\common\Quake 4


Worked Like a Charm THANKS!!!!!!!!!!!

Now, one problem... It walks now by default instead of running.
< >
Showing 1-15 of 18 comments
Per page: 1530 50

Date Posted: Apr 24, 2016 @ 6:17am
Posts: 18