Farming Simulator 2013

Farming Simulator 2013

View Stats:
Warondar May 12, 2013 @ 7:10pm
Well, finally happened to me...
Well, I guess if you play long enough you're bound to run into the dreaded cattle rustlers. My main map where I had everything running the way I wanted went ahead and got corrupted. I lost all my vehicles and all my livestock, except for that dam rooster. At least he stuck by me in this time of need, even after I threatened to roast him a few times.

I looked into the savedgames backup folder and tried a number of older saves but they just do the same thing.
Checked a few other maps but they seem fine.

So I guess I'm S.O.L. with the missing stuff? Have to buy everything again?
< >
Showing 1-11 of 11 comments
MysteriANT May 12, 2013 @ 7:54pm 
that's strange, but I read somewhere that there's a mod that causes this ...have you installed any directly prior to this happening ?
Last edited by MysteriANT; May 12, 2013 @ 9:53pm
Warondar May 12, 2013 @ 8:18pm 
Yes, I installed a few maps and vehicles today before playing, so I'll backtrack and delete them one by one and see if that's the culprit.
I do see all the vehicles in my vehicles.xml file but they just don't show when I load the map.
Daniel May 12, 2013 @ 10:03pm 
It's most likely a duplicated stat on one of your vehicles. The log file should throw an error referencing a certain line in vehicles.xml. Then you simply find that line and check the vehicle on that line for issues.
Warondar May 12, 2013 @ 10:05pm 
Thanks Voidheartd. Checking that right away.
rmckinney May 13, 2013 @ 5:35am 
Warondar,

Do you have a map set up specifically for testing mods? I lost three or four games plus spent hours recovering games before I decided to set up a mod testing map. I'm a mod junkie and this test map has proven to be very useful.

I like to test a mod and then close out and look at the log.I have found several mods I liked but the log was full of errors which for me causes lag. Isere Agriculture is the map I use to test with,
it has wheat, corn, and sugar beet already planted so you can test a variety of equipment.

RM
Warondar May 13, 2013 @ 9:30am 
Actually, probably not the greatest idea, but that main map WAS my testing map. hehe
It has lots of different crops growing all the time, and lots of money which made it easy to buy and test stuff. I should of just used a money cheat on a map I didnt' use to make a test map like you said.
As Voidheart also mentioned, I pulled up the log file and there was quite a few warnings and errors but they were all on items that worked nevertheless before.

For example, had quite a few of these types:
Warning (performance): Raw texture format (C:/Users/Cc/Documents/My Games/FarmingSimulator2013/mods/cakovec_krunjac/store.png)
Warning (compatibility): Texture width or height doesn't equal 2^n (C:/Users/Cc/Documents/My Games/FarmingSimulator2013/mods/kroneZX550GDrake_V2/store.dds)

Posted message before finishing hehe.

For that main map, this is the big error that's causing the vehicles and livestock not to show:
Error: C:/Users/Cc/Documents/My Games/FarmingSimulator2013/savegame5/vehicles.xml(635): Error parsing Element.

Last edited by Warondar; May 13, 2013 @ 9:43am
rmckinney May 13, 2013 @ 11:16am 
I've noticed that the error Texture width or height doesn't equal 2^n are usually found on mods converted from previous FS versions and when not converted properly seem to be the ones that raise the most hell with your game files.
abeyance !!! May 13, 2013 @ 12:45pm 
As far as i know that Error parsing Element is caused by a vehicle which has saved with some position and rotation information missing.

While i havent seen that error myself in 2013 i did come across it in 2011 where it can be fixed by deleting the last bought machine from the .xml file and saving again. So it could be worth trying. Open the vehicles.xml from the savegame backup and remove your last purchased item and try then.

rmskinney is right about the 2^n and raw texture errors. They all happen due to really poor mod conversions but fortunatly they can be very easily fixed.
Last edited by abeyance !!!; May 13, 2013 @ 12:45pm
Warondar May 13, 2013 @ 1:14pm 
Great info guys, much appreciated. Going to try that out also today. Still hoping to salvage that map, but not holding my breath. hehe
Daniel May 14, 2013 @ 12:24am 
As I said, that error means there's something wrong with the vehicle on line 635. Just look for duplicate stats or other oddities. Removing these will fix the problem.
Warondar May 14, 2013 @ 9:00am 
Thanks guys. And Voidheartd, huge thanks it worked.

http://steamcommunity.com/sharedfiles/filedetails/?id=145041733
http://steamcommunity.com/sharedfiles/filedetails/?id=145041621

It was the placeable chicken hatcheries, calf barn mod that was messing everything up. Once I took them all out (one by one and checking in game) the vehicles and livestock returned.
Mind you I had clicked on vehicle reset a few times hoping that alone could fix it. hehe
Last edited by Warondar; May 14, 2013 @ 9:07am
< >
Showing 1-11 of 11 comments
Per page: 15 30 50

Date Posted: May 12, 2013 @ 7:10pm
Posts: 11