Antichamber > General Discussions > Topic Details
Jay-Mission Jan 21, 2014 @ 8:43pm
Having issues with textures apparently missing
So I can't seem to get Antichamber to display some of the game textures properly. From viewing a Let's Play, I gather that when you click on any of the symbols on the wall you start staring at you ge to look at them up close and read a comment - but my game displays neither, instead only showing black boxes (see screenshot: Similarly, the map wall shows only black boxes when I roll over rooms on the map.

I've tried verifying the cache - which bizarrely says there is one item that needs to be replaced and then does so, but doesn't fix the problem - as well as uninstalling and reinstalling the game. Nothing has worked, much to my chagrin.

Any assistance would be greatly appreciated - I really want to enjoy this game in the way it was intended!
Last edited by Jay-Mission; Jan 21, 2014 @ 8:45pm
< >
Showing 1-7 of 7 comments
Californ1a Jan 21, 2014 @ 11:43pm 
Have you tried any of the fixes listed in the pinned thread?

Even though those are for game crashes, it could still solve your issue as well. (I'm mainly looking at the three fixes that involve physx)
Last edited by Californ1a; Jan 21, 2014 @ 11:43pm
Jay-Mission Jan 23, 2014 @ 10:34pm 
I tried both the PhysX solutions, updating the drivers and renaming the dll, but unfortunately neither worked. The latter stopped the game from booting entirely, though, so that was at least a change if not a good one.

Interesting to note: some people in the last few pages of the main support thread seem to be having the same missing texture problem as I am. It's reassuring to know that I'm at least not alone!
Californ1a Jan 23, 2014 @ 11:27pm 
No you're not, it seemed to be a more prevalent bug early after release though, and it appears as though there was at least some of it fixed with a patch soon after the initial release. It seems like it's still an issue for some people though. If you don't get any answers from searching around on here, making a post on the Antichamber subreddit might help, although it's not a very big community on there right now. (most the posts on these steam threads are just people whining about the game crashing on startup and them not checking the pinned threads, as well as people posting their reviews after they finish the game)
Last edited by Californ1a; Jan 23, 2014 @ 11:29pm
Jay-Mission Jan 24, 2014 @ 12:40am 
Thanks for the link, I'll definitely give that a shot!
Californ1a Jan 24, 2014 @ 2:25pm 
When you say that it required one file to be replaced when you verify game cache, do you know which file it is?
Jay-Mission Jan 24, 2014 @ 2:47pm 
Upon having Steam verfiy the game cache, it tells me that one item failed to validate and will be reacquired, but doesn't say which item. Upon perusing the local files, it seems that it redownloads both "installscript.vdf" in the game's main folder and "InstallInfo.xml" in the Binaries folder. The cache verification does this same thing every time the cache is verified after launching the game.

I'm not sure if this happens with every Steam game upon cache validation, but after doing this Steam attempts first time setup upon booting the game and the Unreal Engine asks for term agreement as well. Ignoring Steam's first time setup seems to have no effect, letting the game boot normally but still with the texture bug, but ignoring the Unreal Engine's prompt causes the game to crash and not start up.
Californ1a Jan 24, 2014 @ 8:00pm 
The sign textures are located in "%installdir%\Antichamber\UDKGame\CookedPC\Textures.tfc"

Doing a little searching around tells me that .tfc files are textures for Unreal Tournament 3 (Antichamber was originally made as a UT3 mod, so this makes sense). Apparently there is some software that can either extract or edit these textures, but you need to find the corresponding .ufc or .pcc files (the actual model that the texture is applied to). Since Antichamber doesn't have any of the ufc or pcc model files, I doubt you'll be able to open this texture file to even check if it indeed has the sign textures in it, although you could try deleting the Textures.tfc and then doing the verify game cache.

EDIT: I would also suggest installing the early beta demo of Antichamber, it will install a separate version of UDK which might fix the textures not rendering in the full game (no promises though; also note this is a demo, it is limited progression)

2EDIT: I'm also wondering whether this is occuring with all the signs or just certain specific ones? It seems like the texture shows up in the smaller version before you click on it; what about when you're walking around the map? I'd hate to just show you the route for getting all the signs (spoiling the game for you), but it would be nice to know if it happens with every single sign or just a select few. An alternative option would be for you to load a finished save or enable the console and use console commands to unlock all of them. If you'd be willing to do this, I can either send you a completed savefile or tell you hot to enable the console and what commands to use. (you can backup your save, if that is an issue)
Last edited by Californ1a; Jan 24, 2014 @ 9:27pm
< >
Showing 1-7 of 7 comments
Per page: 15 30 50

Antichamber > General Discussions > Topic Details
Date Posted: Jan 21, 2014 @ 8:43pm
Posts: 7