Divinity II: Developer's Cut

Divinity II: Developer's Cut

[Solutions] Game won't start
Hi ! I had this problem, and I will give you the solution I used. ;)

The launcher starts, but nothing hapend when you clic "launch the game" ?
It is probably cause physxloader.dll is missing !

You can download it there: http://www.dll-files.com/dllindex/dll-files.shtml?physxloader

To install physxloader.dll, just past it into these folders:
C:\Windows\System (Windows 95/98/Me)
C:\WINNT\System32 (Windows NT/2000)
C:\Windows\System32 (Windows XP, Vista, 7, win 8)
If you use a 64-bit version of Windows, you should also place the .dll in C:\Windows\SysWOW64\

Try to launch the game again, and your problem is fixed :B1: (I hope :gordon:)

If it's still not fixed, there is an other way (Thanks to DamienBlack500):

Originally posted by DamienBlack500:
1) Uninstall the PhysX from the Programs and Features under the Control Panel.
2) Go to the game folder under C:\Program Files (x86)\Steam\SteamApps\common\divinity2_dev_cut\support\PhysX and launch the installer for the PhysX and it should install it again.
3)Try to launch the game and hopefully it works for you :)

If it's still not working (:spazhorror: yea, that could be a bit annoying), there is an other solution (Again ? Yea ! :spazwinky:), and this time, a great thanks to xsys !

Originally posted by xsys:
The solution that worked for me (Win 7 x64 NVidia 560 ti) was to use DXWnd to start the D2 executable and intercept any DirectX errors, ignore them, and proceed normally. Here are the instructions (copied and modified from the "Robin Hood" forum on Steam):


1) Download the latest version of DxWnd from... http://sourceforge.net/projects/dxwnd/files/Latest%20build/
1) Unrar and inside the extracted folder run "dxwnd.exe" as administrator (if you need to). Go to "Edit->Add", in parameter "Name" set the name as Divinity II.
2) In parameter "Path" choose the .exe file of the game (in my case it looks like M:\SteamLibrary\SteamApps\common\divinity2_dev_cut\bin\Divinity2-debug.exe).
3) In the "Main" tab, under "Generic" untick "Run in Window". Also in "Main" tab, under "Position" set "Window initial position & size" to X=0 and Y=0. Set "W" and "H" to your native resolution (in my case that's W=1920 and H=1080).
4) Next in "Input" tab tick "Hide Cursor". If the cursor flickers on the main screen of the game don't worry, it works fine in-game.
5) In the "Compat" tab select "Handle Exceptions".
6) Lastly click "OK" in DXWnnd, if all is good it will show a green circle before the name of the game in DxWnd.


Now you can start D2 from either the DXWnd app or start the app and then launch from Steam :)

There is also a "Fake Version" mode (for OS) in the "Compat" section so this could be a solution for other operating systems too.

Have a nice game !! :lonestar:
Last edited by Walryck Aldelar; Aug 10, 2014 @ 7:13am
< >
Showing 1-15 of 35 comments
Raze_Larian Oct 12, 2013 @ 11:00am 
You can also try reinstalling PhysX from the installer in the game folder '..\SteamApps\common\divinity2_dev_cut\support\PhysX'.
Last edited by Raze_Larian; Oct 12, 2013 @ 11:00am
Vargas78 Oct 12, 2013 @ 5:17pm 
@Raze that just told me that the physx version already on was newer so it couldnt install it.

@MaweyaTutean, close but no cigar! I tried your advice and on loading the game it got further than before, it actually ran the intro video before going back to desktop. Before it wouldnt even do that.

Still cant play the game though :(
Nebol Oct 13, 2013 @ 7:13am 
Kind of ♥♥♥♥♥♥ that the game won't even start. Didn't anyone test it before adding it to Steam? I have the same issue. Just exits after logo intro.
SiMMENS Jul 10, 2014 @ 10:38pm 
just got the game and I'm having the same issues
Exactly the same issues.

I work in software, and I almost feel that we need a new patch for this game as physx and driver software have moved on, as have direct x, physx, all drivers etc completely upto date. This is the only game I have had issues getting to run from Steam for a very long time.

I've tried:

1. Disabling SLI
2. Setting Physx to cpu only
3. Setting everything in game profile to min in Nvidia control panel.
4. Installing AC3 Filter
5. Disabling movie startup in the xml file
6. Verifying game cache
7. Uninstalling and re-installing.
8. Checking all C++ redists are upto date.
Last edited by Dorris the Lunch Lady; Jul 11, 2014 @ 1:40pm
Tira || Chris Jul 11, 2014 @ 4:56pm 
u can run it in xp sp3 compability mode -> works perfectly for me...
just go to C:Programms/Steam/Steamapps/common/Divinity2_dev_cut and choose under properties the autorun.exe and run it.
Last edited by Tira || Chris; Jul 11, 2014 @ 4:56pm
xsys Jul 11, 2014 @ 7:25pm 
Can anyone with a Windows 7 x64 OS and all updates verify that you can run Divinity 2 as of today? My install was working perfectly (as of March 31) but will now crash just before the game menu is supposed to appear.

I tried all of the suggestions I could find to no avail, and since all of my other games work fine (including some older troublesome games) I am starting to think a recent Windows update is a problem for D2 alone.
Tira || Chris Jul 11, 2014 @ 11:04pm 
i got win 8 x64 installed and tried every compabilitymode there is by downgrading (Win 8 -> Win 7 and so on) and the first mode that worked was win xp sp3. so yeah Win 7 does not seem to work.
xsys Jul 12, 2014 @ 7:22am 
The game worked fine on Windows 7 x64 for many months with no compatibility changes, and now it is the only game in my library that does not work. This is specific to Divinity 2 and a recent Microsoft Windows update imo.
I have tried all compatibility modes. I am on win7 x64. As @xsys says, I think something has broken it. It is also the only game that will not work for me.
PugsOnParade Jul 13, 2014 @ 2:49pm 
This is odd. I just played today and I am running Windows 7 64 bit. No issues here. Just updated everything a day or two ago.
xsys Jul 13, 2014 @ 5:24pm 
I uninstalled all updates between 5/31/2014 and 7/11/2014 and it didn't fix the problem, so I don't think it was a system update that broke D2 on my pc. The only other suspect at this point is installing the MMO Tera online, which seemed to change the localization of my pc and I had to fix with a prompt command.

I did switch to WinXP (dual boot) to verify the install and hardware and D2 runs perfectly, so it is definitely something in Win7 that makes the app crash on startup.

Does anyone know the low-level requirements for D2 like audio codecs and system files? It still bugs me that this is the only game affected :/
DamienBlack500 Jul 13, 2014 @ 7:52pm 
I don't know if it'll help or not, but I am running a Windows 7 Home Premium x64, with the latest updates on everything. I tried to play the game, but it just exited with no errors after telling it to launch the game from the launcher. I tried a couple solutions listed, but none worked.

Here's what I did to fix it:
1) Uninstall the PhysX from the Programs and Features under the Control Panel.
2) Go to the game folder under C:\Program Files (x86)\Steam\SteamApps\common\divinity2_dev_cut\support\PhysX and launch the installer for the PhysX and it should install it again.
3)Try to launch the game and hopefully it works for you :)
Last edited by DamienBlack500; Jul 13, 2014 @ 7:53pm
xsys Jul 13, 2014 @ 9:07pm 
I have tried to refresh the Physx, DirectX, and VC++ installs but that's not the problem. I think the Tera install is the pivotal moment of failure, but only for D2. Regardless, I don't see why this one game is affected unless it depends on something specific...and I have no idea what that specificness is :)

I do know that Fallout 3 and Elder Scrolls Oblivion use the same engine (Gamebryo), but those run fine on my system, and they are heavily modded too. I was just playing D2 on my system a month ago, but now it's broken. There has to be some obscure dependency that the Tera install trashed.
GamerGril Jul 13, 2014 @ 9:21pm 
Same issue here and i'm highly annoyed >.< :cgpout: i tried a ton of diffrent fixes and nothing :(
Last edited by GamerGril; Jul 13, 2014 @ 9:21pm
< >
Showing 1-15 of 35 comments
Per page: 1530 50