Divinity II: Developer's Cut

Divinity II: Developer's Cut

Black Lotus Sep 12, 2015 @ 7:09am
Game Loads for ever
The game loads once for me then the second loading screen I have to go trough it will always load for ever.
And I mean loading screens when I'm already playing, so as long as I don't enter buildings or other zones the game runs fine.
Any fixes for this?

EDIT:
Guess it's fixed now
I used the Lockstep setting under advanced grapic settings and that did the trick
Thanks Raze for the info
Last edited by Black Lotus; Sep 13, 2015 @ 1:16pm
< >
Showing 1-15 of 26 comments
Raze_Larian Sep 12, 2015 @ 5:45pm 
A few people have run into this issue. Quicksaving before using doors, etc, helps a little bit. A couple people have been able to fix this by enabling Lockstep mode in the Graphics options (check off 'Show Advanced Options', and it is at the bottom of the list, just above the FPS Cap slider). A couple others didn't report back if they tried that (assuming they even saw it), after the first person reported that that and a graphics driver update fixed it for them.
Last edited by Raze_Larian; Sep 12, 2015 @ 5:47pm
Sayori Sep 12, 2015 @ 6:01pm 
the game doesn't even work for me. It instantly crashes when I click start on the menu.
Raze_Larian Sep 12, 2015 @ 7:00pm 
If you check the Event Viewer, does that give an error code or 'Faulting Module' file name that might help identify the cause of the crash?
- click Start (or WinKey-W in Win 8), then type "event viewer" (or just "ev") into the search box
- after starting the Event Viewer, expand 'Windows Logs' in the left column and select 'Application'
- in the center column, look for a recent error (maybe sort by Date and Time) for the game
- check the information under the 'General' tab below the list of events, starting with "Faulting application name..."

Are you shutting down all non-essential programs (especially anti-virus) before starting the game? Firewalls have also caused conflicts.

Try renaming the intro.wmv and loading.wmv videos in the '..\SteamApps\common\divinity2_dev_cut\Data\Video' folder. That may avoid a startup crash, and if not it should at least speed up future troubleshooting.

Try starting the game directly from the '..\divinity2_dev_cut\bin' folder: Divinity2.exe is the normal mode, while Divinity2-debug.exe has the optional 'Developer Mode' cheat menu. Right click the executable and run as administrator.

PhysX is one of the more common causes of crashing on startup; installing the latest version may help. You can also install the version that comes with the game (in the support folder); you may need to uninstall the current version and reboot first. If that gets the game to start, you should then be able to update to the latest version of PhysX.
You can also reinstall the other support packages in the install folder, MS VC and DirectX 9c (the latter does not come installed by default in Windows 7 or 8, so can be the problem on new computers).

Check for updated drivers and Windows updates.


You could try setting a lower game resolution manually by editing the file below in a text editor, and/or put the game into windowed mode (unsupported) by changing the one to a zero in Fullscreen="1".
C:\Users\<UserName>\AppData\Local\Divinity 2\Profile\graphicoptions.xml

You may need to set Windows Explorer to show hidden files and folders:
http://www.howtogeek.com/howto/windows-vista/show-hidden-files-and-folders-in-windows-vista/
(covers Vista through Win 10)


If that doesn't help, check out the suggestions and links in the discussions / topics below:

[Solution] Game won't start

Game won't start, I need help desperately

Divinity II Crashing on Startup[www.larian.com] (avoided by using DxWnd[sourceforge.net]; the problem didn't reoccur after they switched to using a monitor, rather than a TV)
Black Lotus Sep 13, 2015 @ 3:11am 
Originally posted by Squirrel:
the game doesn't even work for me. It instantly crashes when I click start on the menu.
I had that too or at least something similar.
Try running Steam, the launcher (autorun.exe) and the game (Divinity2.exe) as admin

Location of the launcher
...\Steam\steamapps\common\divinity2_dev_cut

Location of the game exe
...\Steam\steamapps\common\divinity2_dev_cut\bin
Last edited by Black Lotus; Sep 13, 2015 @ 3:11am
Black Lotus Sep 13, 2015 @ 10:00am 
Originally posted by Raze:
A few people have run into this issue. Quicksaving before using doors, etc, helps a little bit. A couple people have been able to fix this by enabling Lockstep mode in the Graphics options (check off 'Show Advanced Options', and it is at the bottom of the list, just above the FPS Cap slider). A couple others didn't report back if they tried that (assuming they even saw it), after the first person reported that that and a graphics driver update fixed it for them.

Well I did the Lockstep thing and it hasn't been stuck in the past few hours so I guess it worked
Thanks :steamhappy:
Last edited by Black Lotus; Sep 13, 2015 @ 10:01am
Chut­.Lullu Oct 7, 2015 @ 9:51pm 
I have used the 4GB Patch [/url]http://www.ntcore.com/4gb_patch.php [/url] on divinity2.exe.
Works great. No more loading forever since.
Space Cowboy Oct 21, 2015 @ 2:46am 
Originally posted by theo.schmitt:
I have used the 4GB Patch [/url]http://www.ntcore.com/4gb_patch.php [/url] on divinity2.exe.
Works great. No more loading forever since.

Lockstep mode didn't work for me but this actually did it. Thanks a lot for sharing this! :)
Nothing worked for me :/ Any tips? i have to restart the game every time to enter stuff xD
Raze_Larian Oct 27, 2015 @ 1:27am 
One person with this issue (in Windows 10) reported that LockStepMode and the 4GB Patch did not help, but they were able to fix the problem by disabling VSync and running the game in XP SP2 compatibility mode.
hmm ill try that
_Auron_ Jun 25, 2017 @ 10:38pm 
I'm also having this issue, but I have tried enabled Lockstepping, using the 4GB patch, and setting the game's exe to XP SP2 compatibility - whenever I try to leave the tavern in the first city that has a dragon sighting in the beginning, the loading screen goes forever. I can't progress in the game any because of this since my save is in the tavern. I have zero issues starting the game unlike others, though.

Using: Win10 Pro
Last edited by _Auron_; Jun 25, 2017 @ 10:39pm
Raze_Larian Jun 26, 2017 @ 2:23am 
Try loading the save in the Developer Mode version of the game, open the cheat window (F11) and use the gotocharacter function to leave (type Rhode, or Derk, etc into the text field, then click the button). After that, do other loading screens have the same problem consistently?
_Auron_ Jun 26, 2017 @ 8:38pm 
Actually tonight it had no loading screen lockups. Played just fine for a few hours and got through the beginning core of the game. Then I fought a troll and just before killing it, the game froze my laptop and completely rebooted immediately! Progress, I guess..
SnuskSocka Jun 27, 2017 @ 1:05am 
Turning off "Geometry high quality" seems to be what did it for me.

*Edit* Nevermind, worked for a while but just froze again.
*Edit2* Running it in compatibility for windows 7, running the 4gb patch on every executable I could find and turning off "Geometry high quality" fixed it for now.
Last edited by SnuskSocka; Jun 27, 2017 @ 1:41am
Windreiser Jun 27, 2017 @ 10:13am 
Win10. Infinite loading when changing locations. I use
1) optimize with win XP SP3;
2) Game setting "Use 1 processor"
And nothing do not help. Did anyone find a solution?
< >
Showing 1-15 of 26 comments
Per page: 1530 50