Beyond Divinity

Beyond Divinity

HousePet Mar 18, 2016 @ 2:10am
Rainbow Lighting Bug
After collecting the ingredients for the Imp cure in Act 2, I entered the alchemist's place to discover I had been cursed with the corrupted lighting bug that makes objects randomly transperant or rainbows.
I have tried various settings changes, new drivers and reinstalling the game, but with no success.
:(
< >
Showing 1-7 of 7 comments
Raze_Larian Mar 18, 2016 @ 2:50am 
On my newer computer, if I leave it on continuously I will eventually get this problem in DD and BD, but can fix it by rebooting. Actually, I just double checked BD, and it is fine now, despite displaying this issue the last time I tried it, and same for DD. I did close a few browser tabs, etc, but still have a bunch of stuff open, so I'm not sure if that was enough to fix the problem, or it it was something else that happened in the meantime (didn't reboot).

In any case, you can try rebooting, if that wasn't already part of the driver update or game reinstall process.


In the Beyond Divinity install folder, try editing the config.div file (in Notepad, or other text editor) and add/edit the line rgb 555 and change the number to something else, like 565. If the line isn't there, go into the graphics options and change the gamma, or something, and it should be added, or you can do so manually (just not as the last line in the file, as the game expects that line to be blank, and ignores it).
One person reported that this helped for Divine Divinity.

There are some Divine Divinity topics you could check for things you have not already tried, though not everything would be applicable to Beyond Divinity. For example, you can not change the rendering method in BD; it is Direct3D only... maybe you could try WineD3D, though.

Windows 8 slow graphics problem fixed using WineD3D[www.gog.com]

Software/Direct 3D Issues

Graphical Issue, Indoor textures turning black?[www.larian.com]

Game screen greened out

Indoor graphics issues

Rainbow Shadows and Uncooperative Interiors
HousePet Mar 18, 2016 @ 4:05pm 
Retried all of that stuff and managed to stop the rainbows. Now various indoor object are just pure black instead of rainbows. This was with compatibility Win XP and force 16 bit colour.
Raze_Larian Mar 19, 2016 @ 1:00am 
That's not much of an improvement...
Unfortunately, I'm not sure what else to suggest, other than re-trying stuff to see if something that didn't help on its own may with the game in a compatibility mode, etc.

Did you try going through your video driver settings, and seeing if anything there would make a difference? Right click an open area of the desktop to start the nvidia Control Panel or ATI Catalyst Control Center.
HousePet Mar 19, 2016 @ 5:10pm 
Will check it again.
HousePet Mar 25, 2016 @ 12:29am 
I set the alphabit to 0 and that seems to have fixed the black objects.
It looks playable again. :D
Raze_Larian Mar 25, 2016 @ 2:26am 
Glad you got it working.
HousePet Mar 25, 2016 @ 4:01pm 
It now jams occasionally, but I guess I can put up with this.
< >
Showing 1-7 of 7 comments
Per page: 15 30 50