Proteus > General Discussions > Topic Details
mcguffles Jul 11, 2013 @ 10:18pm
Wont work on Mac
Hey I just bought this and it isnt working. I had 10.6.8 and it wasnt working so I just upgraded to 10.8.4 -- still doesnt work

Im frustrated not only because of lost time and money, but because this game looks awesome and I want to play it! help!
< >
Showing 1-10 of 10 comments
mcguffles Jul 11, 2013 @ 10:19pm 
Im not sure if this helps:

Process: Proteus [454]
Path: /Users/USER/Library/Application Support/Steam/*/
Identifier: com.luckyframe.Proteus
Version: 1.0 (1)
Code Type: X86 (Native)
Parent Process: launchd [135]
User ID: 501

Date/Time: 2013-07-12 01:17:49.936 -0400
OS Version: Mac OS X 10.8.4 (12E55)
Report Version: 10

Interval Since Last Report: 2745 sec
Crashes Since Last Report: 4
Per-App Crashes Since Last Report: 4
Anonymous UUID: D6E5C07D-EBBD-2254-336B-A58500A28932

Crashed Thread: 0

Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: @executable_path/../Frameworks/libexpat.1.dylib
Referenced from: /Users/USER/Library/Application Support/Steam/*/
Reason: image not found

Binary Images:
0x1000 - 0x4fff +com.luckyframe.Proteus (1.0 - 1) <48C07AB7-4508-39B7-8115-C2F74F3F524A> /Users/USER/Library/Application Support/Steam/*/
0x9000 - 0x21ff3 +gameoverlayrenderer.dylib (1) <61984F24-7D87-36B1-B0F1-FA511BDC38BA> /Applications/app stack/
0x37000 - 0x37ffb +steamloader.dylib (0) <04FED4D9-EA7B-3389-8885-307D47EC1AF1> /Applications/app stack/
0x3a000 - 0x52feb +libatk-1.0.0.dylib (20210.1) <2F16BE4C-8E98-327B-B1EC-803D79EEB8BC> /Users/USER/Library/Application Support/Steam/*/
0x5f000 - 0x127fe3 +libcairo.2.dylib (11003.2) <ED846382-25F3-3613-8F0D-0A400A929C4B> /Users/USER/Library/Application Support/Steam/*/
0x8fe1e000 - 0x8fe50e57 dyld (210.2.3) <4D38DEED-9837-3202-B8E9-41272D01EA2C> /usr/lib/dyld
0x934f5000 - 0x934f5fff (6.7 - 19) <354094F0-F36B-36F9-BF5F-FD60590FBEB9> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa

Model: MacBookPro7,1, BootROM MBP71.0039.B0E, 2 processors, Intel Core 2 Duo, 2.4 GHz, 4 GB, SMC 1.62f7
Graphics: NVIDIA GeForce 320M, NVIDIA GeForce 320M, PCI, 256 MB
Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1067 MHz, 0x80AD, 0x484D54313235533654465238432D47372020
Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1067 MHz, 0x80AD, 0x484D54313235533654465238432D47372020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 (
Bluetooth: Version 4.1.4f2 12041, 2 service, 18 devices, 1 incoming serial ports
Network Service: AirPort, AirPort, en1
Serial ATA Device: TOSHIBA MK2555GSXF, 250.06 GB
Serial ATA Device: HL-DT-ST DVDRW GS23N
USB Device: Built-in iSight, apple_vendor_id, 0x8507, 0x24600000 / 2
USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0x26100000 / 2
USB Device: BRCM2046 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0x06600000 / 4
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8213, 0x06610000 / 6
USB Device: IR Receiver, apple_vendor_id, 0x8242, 0x06500000 / 3
USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0236, 0x06300000 / 2
jonbro Jul 12, 2013 @ 9:17am 
hey, I pushed out a beta build that should fix this issue. You can also try going to "browse local files" and running the app directly. Let me know if either of those work for you.
mcguffles Jul 12, 2013 @ 10:07am 
Im not sure how I would get the beta build (auto update? delete local files and redownload?) but running the game directly from the local files totally works! thanks!

If you could tell me how to run Proteus from Steam that would be especially awesome but Im already satisfied -- thanks again!
langdon_alger Jul 12, 2013 @ 12:33pm 
tried the local file workaround and still no luck...any other ideas? I've already deleted/re-downloaded once.

nevermind, rebooted and got it to work.
Last edited by langdon_alger; Jul 12, 2013 @ 12:55pm
jonbro Jul 12, 2013 @ 2:09pm 
you can switch to the beta stream by clicking on the name in the library list, then properties, then the beta tab. hopefully that helps.
mcguffles Jul 12, 2013 @ 2:46pm 
I tried the beta but to no avail. launching from the local files seems to work just fine though

I also tried making a non-steam game shortcut directly to the file but that doesnt work either
Marie the Bee Jul 13, 2013 @ 7:44pm 
Hi! Just purchased Proteus and am so stoked to play, but am having the same problems. Just won't seem to run on Mac.
Last edited by Marie the Bee; Jul 13, 2013 @ 7:44pm
mcguffles Jul 13, 2013 @ 8:05pm 
control click on Proteus in your library
click "Properties"
go to "Local Files"
click "Browse Local Files..."
double click Proteus app

hope that helps!
BounceHaus Jul 15, 2013 @ 4:43pm 
I tried beta and launching from local files but no luck. Any other solutions?
jonbro Jul 16, 2013 @ 9:00am 
So steam just pushed out an update to the client that fixes at least one issue. Make sure you "check for updates" on your steam client, and turn off all the betas for proteus. If you are still having issues, email me with the crash report, the proteus.log files, and the version of osx that you are running.

you can find my email address on the official proteus forums in the thread about crashing on osx.
< >
Showing 1-10 of 10 comments
Per page: 15 30 50

Proteus > General Discussions > Topic Details