Chivalry: Medieval Warfare

Chivalry: Medieval Warfare

View Stats:
Asto Nov 23, 2012 @ 9:58am
Fixed UDK.exe not working…
Hey guys,

i had the problem that the game crashed at start with the message "UDK.exe stopped working"…

All the guides in the forums didn't help, so i took a look into it on my own. I looked into the log files located at C:\Users\*Username*\Documents\My Games\Chivalry Medieval Warfare\UDKGame\Logs and i found out that the critical errors are a result of failing comparisons of the UDK ini files with their hashes.

I've deleted the named ini files located at D:\Program Files\Steam\steamapps\common\chivalrymedievalwarfare\UDKGame\Config and started the game again. It installed the redistributable stuff again and crashed as usual… but now the log files name other ini files as corrupt − what the hell…?

So i've deleted all the ini files located in this directory:
D:\Program Files\Steam\steamapps\common\chivalrymedievalwarfare\UDKGame\Config

Afterwards, i verified the game data with steam and it downloaded the deleted files as assumed. Then a click on the Play button: it worked... the game finally starts… O_O

Maybe this will work for you. I assume that there are some problems downloading the files correctly? You may have to try this a few times… let me know if that worked for your or not :-)

Good luck & greetings from Germany…
< >
Showing 1-15 of 32 comments
[EG]Banana_man223 Nov 26, 2012 @ 1:48am 
if you can remember could you possibly reply step by step on what you did, cuz i did most of the stuff you had done and it still wouldnt let me play
Asto Nov 26, 2012 @ 1:57am 
Try deleting the entire D:\Program Files\Steam\steamapps\common\chivalrymedievalwarfare\UDKGame\Config directory and redownload it. Does that help?

You may have a different problem, this solution helped a few poeple already. Hmm :/
Can you post your logfile?
[EG]Banana_man223 Nov 26, 2012 @ 2:01am 
ill try deleting and redownloading the program again
[EG]Banana_man223 Nov 26, 2012 @ 2:05am 
im trying to delete the program and it still isnt workin. it wont even show the program. i tried downloading it all over again but its saying the program has already been downloaded
Asto Nov 26, 2012 @ 5:10am 
Did you look into your log files, why the crash occurs?
[EG]Banana_man223 Nov 26, 2012 @ 5:39pm 
it wouldnt let me enter the log files for the game
miss1ng Nov 26, 2012 @ 8:19pm 
I have tried this and re downloaded it. Nothing happened. I still get the same error. In fact, I don't have any Log files. All I have is a Log folder in "Engine" with a text file called "placeholder.txt". It's a blank .txt
Asto Nov 28, 2012 @ 4:59am 
Thats weird. So i guess it is another problem and not an ini file hash issue. I don't know how the game went through the QA
obsoletist Nov 28, 2012 @ 5:44pm 
I'm getting the same error. I tried your fix, re-downloaded, no luck. UDK.exe still crashes every time. Thanks for trying to help, though!
Wresmon Dec 25, 2012 @ 3:38am 
Did not help. Why do developers do not fix?
CL8N Dec 26, 2012 @ 8:36pm 
deleting the config folder helps, but only until the next time i play. So i have to delete this every time i quit? wtf?
CL8N Dec 27, 2012 @ 6:18am 
hey guys, gonna post this on my thread i made too. I found something interesting in my event viewer. Im getting UDK.exe stopped working too. Guess where the error is? Faulting module path: C:\Program Files (x86)\Xfire\xfire_toucan_45941.dll XFIRE! So i turn off xfire and everything runs great. When they say turn off background apps, they mean it! Now i just have to figure out what this module in xfire that is causing the problem is and i should be okay.
CL8N Dec 27, 2012 @ 6:33am 
For me, its DEFINITELY xfire. I re-installed xfire to make sure the installatoin wasn't corrupt or missing files, i've had it forever after all. I run the game without xfire on, works perfectly no errors. Soon as i turn it on and run the game again, it freezes at the menu after loading up fully for like 2-3 seconds then BAM freeze crash. I get no error but from my event log its the UDK.exe has stopped working error. SOOO, i think i've proven that for myself, my issue is with xfire. Don't have a fix yet except for not running xfire while playing chivalry, but hopefully this is temporary and a REAL fix will present itself. Must be something with the in-game feature xfire has for like chat and voice like steam does now.
EliteFrench Fry Dec 27, 2012 @ 7:05am 
How do I download the deleted files?
CL8N Dec 27, 2012 @ 7:15am 
For you guys trying to do his fix...

1.)This drive letter may be different for you, its going to be where YOU INSTALLD IT >>D:\Program Files\Steam\steamapps\common\chivalrymedievalwarfare\UDKGame\Config
Just go as far as the UDKGAME folder, then youll see config, delete the whole folder.

2.) In steam, right click on your chiv game, go to local files tab, verify integrity of cache. It will verify and say about 70 some files need reacquire. Then it will re-acquire some.

3.) Hit play on your game, soon as you do it will install the other stuff you need.

4.) Profit

Also guys, check out my post if you are using x-fire! X-fire was causing my game to crash.
< >
Showing 1-15 of 32 comments
Per page: 15 30 50

Date Posted: Nov 23, 2012 @ 9:58am
Posts: 32