Droid Assault

Droid Assault

View Stats:
After update, DA doesn't launch on Mavericks [SOLVED]
A recent 0 byte update has caused a strange message to appear when launching the game. "The game must be launched through Steam and you need to be logged in to your account", though I've been launching the game through active Steam library view. After verifying file integrity I began a removal/reinstall and during the process used the app Easyfind to locate hidden files and preferences in order to avoid a mismatch when redownloading the game. Among the files found was the most recent crash log:

Picked up _JAVA_OPTIONS:
Game resource: game.steam
Sun Nov 24 07:55:57 EST 2013 Game: Droid Assault 1.92.0 [1.92]
Initialising Steam integration
Failed to initialise Steam
net.puppygames.steam.SteamException: java.lang.ClassNotFoundException: net.puppygames.steam.SteamAPI
at net.puppygames.steam.Steam.create(Steam.java:51)
at net.puppygames.steam.Steam.init(Steam.java:70)
at net.puppygames.applet.Game.initSteam(Game.java:3085)
at net.puppygames.applet.Game.init(Game.java:956)
at net.puppygames.applet.Launcher.main(Launcher.java:103)
Caused by: java.lang.ClassNotFoundException: net.puppygames.steam.SteamAPI
at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:186)
at net.puppygames.steam.Steam.create(Steam.java:44)
... 4 more*
No game info log
Couldn't write log - no filename

*There was no drop-down containing the additional four lines of info.

What I don't understand is that the game was working just fine two days ago; but apparently after the update it won't recognize Steam's coonection state. Also, according to the pop-up message will this mean that players can't play the game during Steam's Offline Mode?
Last edited by cprince; Nov 27, 2013 @ 2:07am
< >
Showing 1-4 of 4 comments
cprince  [developer] Nov 25, 2013 @ 3:00am 
Whoops a diddly, there's a file missing. I'll just add it...

... don't think any of our games have ever worked in offline mode though.
76561197991858962 Nov 25, 2013 @ 7:15am 
In addition to the above-related issue with Droid Assault, the recent Titan Attacks update is preventing the game from launching AT ALL (absolutely nothing happens). I'm following the TA boards and an doing what you recommended (reinstall and cold-reboot) but I'm not expecting an immediate fix.

I've read on the Titan Attacks forums (or Revenge of the Titans) that the auto-updater for all of your games will soon be disabled. PLEASE let this be true, as it seems that every Java-based or game code update breaks several games.
cprince  [developer] Nov 25, 2013 @ 7:18am 
Should be ok now. Only my incompetence to blame.
76561197991858962 Nov 26, 2013 @ 5:03pm 
They now work after the 11/26 update. Thanks.
< >
Showing 1-4 of 4 comments
Per page: 15 30 50