Hotline Miami

Hotline Miami

View Stats:
Dr.Dick Dec 26, 2012 @ 1:02am
*SOLVED* Failed To Initialize Drawing Surfaces
Anyone else ? Bought this yesterday, can't get into the game - get this after the splash screen.

I have seen just two or three posts about this here, some dating back a couple of month, and no answer at all on this subject.
Funny thing is, all posts have different GPUs - I'm running a ATI HD 6xxx, drivers + directx up to date.
Tried changing resolutions, playing with vsync and stuff - no dice. Running out of ideas, so if anyone has something, you'd get +1 internets
Last edited by Dr.Dick; Dec 26, 2012 @ 10:28am
< >
Showing 1-10 of 10 comments
Enraged Pixel Dec 26, 2012 @ 2:47am 
i have have the same problem myself,tryed everything;updated all drivers,clean reinstall,dissabling spooler fix, verifying the integrity of game chace, re-installing Microsoft Visual C++.nothing works.whole error message is :

failed to initialize drawing surfaces.please check that your grafics card meets the minimum requirements and that your drivers are up to date.if you graphics card has little memory,try switching your computer to a lower resolution.

you wouldnt have an alienware do you mr.♥♥♥♥ ?i have read somewhere that the light program thingy might be causing the problem.was hoping they would fix this with the patch,but no luck
Dr.Dick Dec 26, 2012 @ 5:08am 
Nothing that fancy on my system
We do have the exact same error, I'm running win7 x64 - you ?

Did some reading up on this general error message, in some veeerry obscure forums while at work (ie now) : They hinted at a Direct3d malfunction in 32bit programs and pointed at some registry keys

I'll give this one a shot when I'm back home and reply here if this actually fixes anything

Dr.Dick Dec 26, 2012 @ 9:50am 
I'm happy to report I solved the issue:

Use REGEDIT and change the "SoftwareOnly" key from "1" to "0" in the HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Direct3D\Drivers
and then reboot the system and it should work.

This is an issue with Direct3D x86 and Windows 7 - VERY VERY obscure.
I'm just sad this solution won't help many people just because it won't be seen, but hey, as long as it fixes it for one person, I'll be happy :)
Enraged Pixel Dec 26, 2012 @ 10:26am 
that indeed fixed my problem.cannot thank you enough kind sir.i have been smashing my head on my keybaord 2 weeks now,trying to find a fix for this bug.your computer wizardry skills are on another have just made my day :) happy hollidays my friend
Dr.Dick Dec 26, 2012 @ 10:27am 
glad i could help :)
Revo Apr 24, 2013 @ 11:24am 
Thanks for the help. I don't have this game, but I had this issue with Street Fighter X Mega Man, Hammerfight, and Team Fortress Arcade. For months I've been wanting a solution, but now I've found one. Thank you.
Dr.Dick Apr 25, 2013 @ 1:58am 
I'm impressed you found this post ! Happy this could help out somebody else - this problem (and finding the solution) nearly drove me insane.
Frequenter Jul 12, 2013 @ 6:15am 
Thanks for the solution!
Yvendous Apr 5, 2015 @ 7:23pm 
This has helped me today, I thank you deeply.
Skymirrh Apr 6, 2015 @ 5:01am 
Originally posted by Yvendous:
This has helped me today, I thank you deeply.
Hello, this is a very old fix from 2012 that should not be necessary today. If you were trying to run Original because Updated crashes, please open up a separate thread with details about your system and we will probably be able to find a way to run the game on Updated, which is better than Original by all accounts.
Last edited by Skymirrh; Apr 6, 2015 @ 5:01am
< >
Showing 1-10 of 10 comments
Per page: 15 30 50

Date Posted: Dec 26, 2012 @ 1:02am
Posts: 10