View Stats:
 This topic has been pinned, so it's probably important
PSA: SuperBLT (Update 199.3 - Completely Operational)
TL;DR Download SuperBLT[]

- If you're crashing on startup, please make sure you're using the latest version. Anything older than the latest will crash
EDIT - There's a new player in town called SuperBLT
It's essentially BLT 3.0, a fork of the original with a new updated .dll created and maintained by ZNixian with help from others with a number of major improvements, such as an audio API and the ability to alter any base-game XML file (completely removing the need for Bundle Modder). Long story short it's better and has many upsides, and there haven't been any reported issues/crashes, so there aren't any known downsides.

Download: (make sure you read the "Installation" text)

NOTE: Don't use "normal" BLT anymore, not only is it no longer maintained but it also has no advantage over SuperBLT.
Keeping this up for archival sake:
Old Title: PSA: BLT has been updated (LuaJIT Support - Update 153)
BLT Download:

Not be confused with Raid: WW2's BLT[]
  1. If you're a Windows 7 user, please update to BLT 2.1 (or newer)[]
  2. If it's crashing on the title screen, then your mods need updating.
  3. If you're having a 'weaponfactorymanager' (or blackmarketmanager) crash then it's probably due to a broken save file caused by a custom weapon mod. Install Rokk's Crash Fix[] and follow the instructions to rectify.
  4. To convert a 'basic' mod to BLT 2.0 simply add this line into the mod.txt:
    "blt_version" : 2
    If the mod has a json menu hooked, then you'll need to change:
    "parent_menu_id" : "lua_mod_options_menu",
    "parent_menu_id" : "blt_options",
    for it to actually work. It's located in the .txt file that's not mod.txt nor used for localisation.
    - Again, BLT is broken, use SuperBLT which makes this redudant.
  5. If your mod options is missing (and the game looks as if your vanilla) then it's an issue with your .dll not loading. Try SuperBLT[] with WSOCK32.dll
  6. >>>In-game<<< BLT Mod Options seems to be missing. See note 7 or 8 for a fix. Fixed in BLT 2.2, if problem still persists use note 6.
  7. To fix note 6 replace BLT 2.1's 'base' folder with the source code's[] one. Send all credit to Dark, it's his idea.
  8. An alternate 'fix' has been devised by BangL, follow the instructions on this thread
    BLT 2.2 fixes note 6, making note 7 & 8 unneeded, please update to BLT 2.2[]
    If somehow the in-game mod options doesn't work, try note 7.
  9. If you're a Windows 7 user and having issues with BLT 2.2, please re-install as the download has been fixed with what is probably a newer .dll file. Can also download via Paydaymods[] too, but unnecessary as their both the same versions.
  10. (Fixed in BLT 2.3) Any mod that uses BLT's Peer-to-Peer Lua networking will crash.
  11. You can try using only the IPHLPAPI.dll file from BLT 2.0 and keeping the 'mods' folder from BLT 1.08 as a cheap workaround. 'Basic' mods should work, but some mods will simply crash the game. Doubt that this is needed anymore, kept for archival sake.
  12. BLT 2.0's Updating System is having issues. Update your mods manually. Fixed

If there's anything else that's worth noting feel free to comment.
Reccomended (unofficial) 'add-on' to reduce loading times:
Last edited by Mother_Flowers; Apr 29, 2020 @ 11:19am
< >
Showing 1-15 of 747 comments
comiluv Aug 31, 2017 @ 10:54am 
Updated but the game won't even launch after updating BLT
bob Aug 31, 2017 @ 10:54am 
Thanks for the links :)
andole Aug 31, 2017 @ 10:56am 
Originally posted by madimp:
Updated but the game won't even launch after updating BLT
Same here. Infinite 'running' state.
NewPJzuza Aug 31, 2017 @ 10:57am 
Originally posted by andole:
Originally posted by madimp:
Updated but the game won't even launch after updating BLT
Same here. Infinite 'running' state.
Same here too :\
Bassyoi[JP] Aug 31, 2017 @ 10:58am 
Originally posted by NewPJzuza:
Originally posted by andole:
Same here. Infinite 'running' state.
Same here too :\

Same here.
Rean Schwarzer Aug 31, 2017 @ 10:59am 
seconded that
Mother_Flowers Aug 31, 2017 @ 10:59am 
Oh, well I haven't even launched the game yet - I'm going to be raping the hell out of the beta - I'm just announcing that BLT has been updated because I believe the previous versions don't work with luaJIT?

Ofc, according to you guys this new version doesn't work with it either...
Last edited by Mother_Flowers; Aug 31, 2017 @ 10:59am
BeZzzi Aug 31, 2017 @ 11:05am 
Game doesn't launch, but steams says that i'm in the game. Have to manually exit the process in manager
eXasTaR.- Aug 31, 2017 @ 11:11am 
For me the game launches, but intro has no audio at all, it gets me to the title screen and after pressing any key the game crashes...halp ;-;
Pippa Aug 31, 2017 @ 11:12am 
Originally posted by ZohanV13:
Game doesn't launch, but steams says that i'm in the game. Have to manually exit the process in manager

Probably one of the mods thats incompatible.

I just replaced my old BLT with the new one thanks to the OP, game launching fine (except for a little error in the back of my running processes, but I can play properly).
I can't even get to the site. I guess it is being flooded with traffic.
BeZzzi Aug 31, 2017 @ 11:16am 
Originally posted by Tamirlank:
ignore this reply, im sort of "bookmarking" this discussion
You can subscribe to this topic in top right corner
I had an issue where because I was using custom music as a menu track and since that depends on BeardLib and BeardLib wasn't quite working just then, the game froze up completely on the main menu. Worked around by quietly moving those modules out of reach long enough to change the track.

Also, Wilko left the console showing.

Other than that, I haven't encountered any serious problems... yet.

Edit: I forgot about the mod options menus. They're gone.

Fake Edit: Heists seem to crash when you play custom tracks. (Someone handed me a little band-aid for BeardLib)
Last edited by Meredith K Pseudonym; Aug 31, 2017 @ 11:25am
NewPJzuza Aug 31, 2017 @ 11:19am 
I've tried with pure new BLT. the game is running but it's like others got.
Copy & Cat Aug 31, 2017 @ 11:22am 
well couldn't make it work even when removing all other mods
< >
Showing 1-15 of 747 comments
Per page: 1530 50