Unity of Command

Unity of Command

Unity of Command > 一般討論 > 主題細節
tomislav.uzelac  [開發人員] 2013 年 1 月 27 日 上午 10:20
Linux Font Issue
Hi all,

we've had a look at the font issue with Linux and re-compiled Pango (font library) to work correctly on all Linux systems. We've tested this successfully on Fedora 16 x86, but would appreciate your help in testing on your own operating systems if you have had font problems with the game. The faster we get feedback on this, the faster we can push a fixed version. Thank you for your help!


Included are some re-compiled versions of the Pango libraries shipped with Unity of Command, switching to these should hopefully solve this issue.


Copy these files over the original versions in 'Unity Of Command/bin'.

For the Steam beta installation, this will be:
'~/.steam/steam/SteamApps/common/Unity Of Command/bin'
< >
目前顯示第 1-15 則留言,共 46
Taurus 2013 年 1 月 28 日 上午 4:13 
Works perfectly on Fedora 18 x86_64, Thanks!
ricky 2013 年 1 月 29 日 下午 1:55 
The font-fix works on Fedora 17 x86_64 as well.
wdna 2013 年 2 月 1 日 下午 1:55 
works Fedora 18 x86_64 as well. thanks a lot.
[CAG].:Henne:. 2013 年 2 月 10 日 下午 12:22 
Did not work under openSUSE 12.3 RC1 64bit
kozec 2013 年 2 月 11 日 上午 4:06 
Hello. This does not work on Archlinux x86_64, but removing bin/libpangoft2-1.0.so.0 (as suggested in your forum) worked for me.
KusoSamurai 2013 年 2 月 11 日 上午 11:12 
Did not work on Linux Mint 13 x86_64.
Ralgo 2013 年 2 月 11 日 下午 2:22 
ArchLinux x86_64, the game won't start.
[95th]Headwound Harry 2013 年 2 月 11 日 下午 2:32 
Made it worse for me on Archlinuxx86_64. It used to load with screwed up fonts, now it won't even load. If I ldd on libpango:

linux-gate.so.1 (0xf76f5000)
libgobject-2.0.so.0 (0xf765a000)
libgmodule-2.0.so.0 (0xf7655000)
libglib-2.0.so.0 (0xf755c000)
libm.so.6 => /usr/lib32/libm.so.6 (0xf74ce000)
libthai.so.0 => not found
libpthread.so.0 => /usr/lib32/libpthread.so.0 (0xf74b2000)
libc.so.6 => /usr/lib32/libc.so.6 (0xf7301000)
libffi.so.6 (0xf72fa000)
libdl.so.2 => /usr/lib32/libdl.so.2 (0xf72f5000)
libpcre.so.3 (0xf72b8000)
librt.so.1 => /usr/lib32/librt.so.1 (0xf72af000)
/usr/lib/ld-linux.so.2 (0xf76f6000)

Note the "not found" for libthai of all things.

Removing libpangoft2 didn't help.
Spooner 2013 年 2 月 11 日 下午 3:35 
For those people who found this fix didn't work, could you please try just replacing libpangoft2-1.0.so.0 (but not replacing the original libpango and libpangocairo files). Someone reported that that worked on Archlinux and I have to be hopeful that it will work for everyone.

I only managed to test the fix on Fedora and Ubuntu (Ubuntu, of course, worked out of the box as well) before asking people to test it, so thanks for the feedback!
Ralgo 2013 年 2 月 11 日 下午 6:19 
Spooner 發表:
For those people who found this fix didn't work, could you please try just replacing libpangoft2-1.0.so.0 ...

Yay!!!, works great. Archlinux x86_64
[95th]Headwound Harry 2013 年 2 月 12 日 上午 7:22 
Yup, that worked for me on Archlinux x86_64
Spooner 2013 年 2 月 12 日 上午 8:08 
Ralgo & Headwound Harry: Thanks for testing again. Glad it worked this time ;)
grichner 2013 年 2 月 16 日 上午 12:51 
What an excellent installation bug…
Steam aka Developers should use the native libraries of the linux distribution (if they insist in a lib in the game dir via symlink) or should build a fork of these libs working with all distributions…
like firefox with e.g. xulrunner

at least there should be a listing what libs are used …
without ldd

You are lost

besides _Not_ all Tunixers know about ldd and how to do fixes on their Installation

Yours humble
GentlemanTech 2013 年 2 月 16 日 上午 3:04 
Kubuntu (updated to 12.10)
pre-fix game CTD with no error after the font-bugged splash screen (assume it's the CD-key screen).
Post-fix game CTD immediately with no error.
[HS]=>Brice 2013 年 2 月 16 日 上午 6:59 
Just replacing libpangoft2-1.0.so.0 solved the issue on Mageia 3 as well...
< >
目前顯示第 1-15 則留言,共 46
每頁: 15 30 50

Unity of Command > 一般討論 > 主題細節
張貼日期: 2013 年 1 月 27 日 上午 10:20
回覆: 46