The Incredible Adventures of Van Helsing

The Incredible Adventures of Van Helsing

soldojo May 23, 2013 @ 11:12am
d3dx9_43.dll missing ... (FIXED)
I get a missing DLL error when I try to play. FIXED

EDIT: Extract the d3dx9_43.dll RAR file from the DirectX folder in the game folder, into the Van Helsing install location, begin playing.
Last edited by soldojo; May 24, 2013 @ 12:00am
< >
Showing 1-15 of 19 comments
✪ megapull  [developer] May 23, 2013 @ 11:16am 
That is if that is d3*something*_49.dll then it is not the game's fault. Try this:

http://www.microsoft.com/en-us/download/details.aspx?id=35

Megapull, NeoCore Games Moderator
More info: forum.neocoregames.com
soldojo May 23, 2013 @ 11:23am 
It's d3dx9_43 that's missing. Furthermore, I've ALREADY been to that exact page, and downloaded that exact thing, and had it have 0 effect. Notice I say I updated DirectX in the OP.

Thank you for the reply though, I do appreciate the effort, really.

I'm just really bummed because I decided to buy this instead of Fallen Enchantress, and now I can't play either until first of month when more money comes or this gets fixed, whichever is first.
Steam\SteamApps\common\The Incredible Adventures of Van Helsing\InstallUtils
install : DirectX /PhysX/ vcredist_x86-1 , do not just go and copy a .dll install direct x

after that run VanHelsing_x86 in administrator mode

did you install physx and vcredist_x86-1?( Microsoft Visual C++ 2010)

Last edited by Dimitrii Anghelov LOUD; May 23, 2013 @ 11:42am
✪ megapull  [developer] May 23, 2013 @ 11:35am 
What Dimitri said is a good solution. I had the same problem yesterday on a laptop and the link that I've posted solved my problem, that's why I suggested that.

Megapull, NeoCore Games Moderator
More info: forum.neocoregames.com
soldojo May 23, 2013 @ 11:35am 
I did re-install DirectX completely. Did you read the whole OP? Every solution in this thread so far was listed as tried in the OP.

Beleive me, dropping the DLL file into the folder was my extreme last resort.
oRyza Rushmore May 23, 2013 @ 11:44am 
Could you please copy-paste the exact error message?

You could also try to verify the integrity of game cache.
Right Click / Properties / Local Files
soldojo May 23, 2013 @ 6:23pm 
Yeah I did verify the game cache, and I also tried updating DirectX from the game utilities as per previous advice. Neither of those things worked. I will copy the exact two error messages, if re-installing and then running rhe game utility based DX installer doesn't work. I want to try from scratch though, for completions sake. I will als verify game caches before and after the DX install. Thank you for your help so far. I really appreciate it.
soldojo May 23, 2013 @ 6:24pm 
I've been using full admin permissions on all attempts, too.
soldojo May 23, 2013 @ 6:29pm 
While I'm re-installing I will say, I really appreciate the community and developer support with this. Sorry for the Grumpy Cat responses, hopefully we can get this worked out, and if not, we can surely agree we have given it the "old college try", so thanks.
soldojo May 23, 2013 @ 7:14pm 
Re-installed, verified cache, ran DX utility from game folder. Same error.

"VanHelsing_x64.exe - System Error
The program can't start because d3dx9_43.dll is missing from your computer. Try reinstalling the program to fix this issue."

Only button is "OK".
Last edited by soldojo; May 23, 2013 @ 7:14pm
Ravenspike May 23, 2013 @ 9:11pm 
Hi there!

It seems like that you are missing some DirectX files needed to play the game. You can download it from it's official page and hopefully it will solve the issues!

edit: by official page I mean the directx webpage, maybe there is a common dll missing from your game that our directx installer doesn't include

Ravenspike, NeocoreGames Moderator
Last edited by Ravenspike; May 23, 2013 @ 9:42pm
soldojo May 23, 2013 @ 10:17pm 
Win7 Ultimate 64
Kiados May 23, 2013 @ 10:25pm 
I got this error its because none of the files extracted in that Direct X folder you will find them all nicely packed up but there should be a Direct X set up .exe file of some sort in there if you look around. I ran that and the game worked perfectly after. Good luck.
soldojo May 23, 2013 @ 10:59pm 
I extracted the RAR file titled the same as the one I was missing into the games file folder and it works now. Yay !

If someone is having this issue, direct them to navigate to the directx folder in the game files, and extract the corresponding dx file into thier Van Helsing folder.

At least, that worked for me.
Ravenspike May 23, 2013 @ 11:02pm 
I am glad that it is finally working, enjoy the game!
My private advice is to play single player and not with an online character until our major update is out as we are constantly working on coop fixes.

Ravenspike, NeocoreGames Moderator
< >
Showing 1-15 of 19 comments
Per page: 15 30 50