Total War: ROME II - Emperor Edition

Total War: ROME II - Emperor Edition

View Stats:
Game ran like ♥♥♥♥ before I did this, now it's smooth as butter
Hey guys so my system is nothing to write home about: Intel core i7 2.9 ghz, 8 gigs of ram, nvidia gtx 470.

Before i had all the in-game settings on high and extreme except shadows and SSAO, and the game ran decently until i zoomed in on the units, which caused the fps to slow to almost nothing.

My friend recommended i follow these steps:

Go to: C/users/USERNAME/appdata/roaming/thecreativeassembly/rome2/scripts

If you cant find that, click on the windows button and in the search bar type in RUN, click on that and then enter %appdata%.

When you finally get to the scripts file, delete it (these are the games settings)

After the scripts files are deleted go into your steam game library, right click on the game and go to properties, local files, then verify game files.

Once that is completed find the game files, which would be wherever you have steam located, and follow this: Steam/Steamapps/Common/TotalwarRomeII/redist/directx

In the directx folder, find the DXSETUP application and install directx through that.

Then you are good to go. I highly recommend turning shadows down to at least medium, as well as unit detail to high, and completely turning off SSAO and distortion effects.

Hope this helps you as much as it did me.

*Special regards to Spec Man, he told me about this fix*
Last edited by Greyjoy's Anatomy; Sep 4, 2013 @ 9:19pm
< >
Showing 1-15 of 159 comments
Reltor Sep 4, 2013 @ 6:56pm 
You are amazing! Thank you so much!
luckythirdbirdDK Sep 4, 2013 @ 7:02pm 
Thanks ... I'll give that a try too..
David Sep 4, 2013 @ 7:06pm 
Bump for knowledge
your welcome guys, let everyone else know. It's a shame so many people with way better computers than mine cant run the game very well.
luckythirdbirdDK Sep 4, 2013 @ 7:22pm 
You're a genius, that solved alot of graphic issues for me to.. I'm on a i5 760, 12gb 1600mhz, and a radeon 5750. All the glitches, and weird tree effects are disapperead.. Looks great now. Thanks again for sharing! :)
your welcome lucky happy i could help
David Sep 4, 2013 @ 7:26pm 
im reinstalling dx atm ill chirp in a sec how it goes but yea.. im one of those people with the way better computer :/
haha good luck man leme know if u have any questions ill be here :)
Mechanical Lions Sep 4, 2013 @ 7:27pm 
This is the dumbest fix I've ever seen in a game but was able to turn a lot of stuff up and finally got a good benchmark.

Thanks.
your welcome, yeah the fix is dumb but at least it helps. First patch is coming in 2 days lets hope for the best.
Shepherd Sep 4, 2013 @ 7:37pm 
Dude ... I love you. I recommend everyone try this. Running on almost all extreme except for medium shadows and high unit detail. Game is so much smoother.

Thanks man.
Shotgun Sep 4, 2013 @ 7:39pm 
Not sure what this fixes, because the script file that verification will re-download is the exact same thing you get by default during the install. The game also goes through the DX initial setup procedure during first launch. What changes are being made, exactly?
Bearikade Sep 4, 2013 @ 7:43pm 
I don't know how, but it seems to work. Before I was getting an average of 30-40 FPS during battles after dropping to low presets. Now I'm getting the same, with everything on Extreme except for shadows dropped to Low because I don't like them, and unit detail at high. Thanks mate!

My rig for reference:

AMD Phenom II X4 965 BE @3.4
8GB RAM
GTX 660 Ti
Shotgun Sep 4, 2013 @ 7:47pm 
Then I think the issue might be in people not properly allowing the game to do its initial setup for whatever reason.

The game runs fine for me without this "fix," do I'm hesitant to see what it will do if I go through with it. I'm guessing nothing in my case, though.
Last edited by Shotgun; Sep 4, 2013 @ 7:47pm
David Sep 4, 2013 @ 7:50pm 
yea man its rocking like shogun 2 was thanks alot i have everything back to where it should
< >
Showing 1-15 of 159 comments
Per page: 15 30 50

Date Posted: Sep 4, 2013 @ 6:19pm
Posts: 159