LEGO® The Lord of the Rings™

LEGO® The Lord of the Rings™

View Stats:
Marine Jan 22, 2013 @ 8:09pm
Lego not starting up, missing dll files, no sound- SOLUTION HERE WITH DL LINKS!
Ok guys after hours of searching there is 3 DLL files you need here are the links:

After downloading these 3 things (make sure you download the ZIP file not the fixer) go to computer/programfiles/steam/steamapps/common/LEGO Lord of The Rings/
place all 3 DLL files in there,

You will probably know there will be no sound download directx to have sound the link is below:

Once you have installed that your game now works perfectly.
Last edited by Marine; Jan 23, 2013 @ 6:00am
< >
Showing 1-15 of 37 comments
Bassa Jan 22, 2013 @ 10:41pm 
What exactly does it fix?
CALVIN Jan 23, 2013 @ 3:37am 
downloading,,,, I will come here and kiss you once it works =p
doesn't work for me.... still seeing press any button when I'm pressing every button on my keyboard..
CALVIN Jan 23, 2013 @ 4:39am 
well, still black screen =[
sf Jan 23, 2013 @ 4:44am 
same problem. black screen after the first intro movie. Placed all 3 dlls in sme place as exe as well as install the directx sdk. no noticeable difference...
Sir Stiv Jan 23, 2013 @ 4:49am 
How about just right click the game >>> verify game integrity or just delete local game content and redownload it. Then look at replacing DLL files. Game works fine for me. Its awesome :D
Marine Jan 23, 2013 @ 5:59am 
this solution fixes the missing dll files and no sound, if you need help with any problems that doesnt have to do with this message me and ill see what I can do
sf Jan 23, 2013 @ 7:24am 
I managed to get the game started by deleting and reinstalling as suggested by stiv. Must have been corrupted download. For those having black screen, suggest that you try the same.
Marine Jan 23, 2013 @ 7:34am 
when you download the game it doesnt put the dll files in the right place they need to be in the games direct path to work so I just downloaded them and put them in the game path and reinstalled direct x and it works
Marine Jan 23, 2013 @ 7:35am 
this doesnt fix the blackscreens I havent seen that problem yet
CALVIN Jan 23, 2013 @ 7:51am 
i am a handicap in computer,,,, any step by step solution with printscreen? =]
sf Jan 23, 2013 @ 8:24am 
black screen happens after the first intro movie for me. If people encounter it in other places, I am guessing that it is due to corrupted downloads. I got mine working after deleting the local game and re-downloading it and installing again. I've also placed the 3 dlls and installed the directx sdk so that may solve some other problems than corrupted downloads as well.
Chabneruk Jan 26, 2013 @ 5:59am 
I had the same problem - Lego: LotR didn't start from Steam. I am using Windows 8 btw. So I installed your dll-Files and it worked, although without sound. Afterwards I installed DirectX from your link - and what can I say, it worked! Thank you so much for this :)

Still angry that they dare to sell a game in this state!
Rogue Spectre Jan 26, 2013 @ 2:49pm 
I've downloaded the soud file and it still doesnt work any ideas?
Krossy Jan 27, 2013 @ 8:44am 
Hey guys try downloading the razer game booster. once you download it defrag lego lord of the rings and run it works
< >
Showing 1-15 of 37 comments
Per page: 15 30 50