FTL: Faster Than Light

FTL: Faster Than Light

Nightwulf Oct 3, 2017 @ 3:36am
Fullscreen totally wrecked on Linux
Hey there,

I used to play FTL every now and then with my old computer (AMD FX8370 and Radeon R7 360) on ArchLinux with amdgpu driver. No problems whatsoever.
I then took a break of approx. 7-8 months without playing the game.
Now I own a new computer with an AMD Ryzen 7 1800x and a AMD Radeon RX580, still using the open source amdgpu driver.
Sorry to say but all fullscreen modes render useless for me now.
1. Mode "native"
Can't play at all. Mouse and keyboard are not working, have to kill FTL with "kill -9"
2. Mode "borders"
Can play the game but resolution is not switched back to normal when leaving the game -> have to rearrange all desktop stuff every time -> useless
3. Mode "stretch"
Same as with "borders"

Because I did not play for so long time, I can't really tell for sure, the game would run on my old rig any more. So much stuff changed, as e.g. the kernel.

Any hints what to try or how to debug what is wrong!?

Thx in advance,
Nightwulf
< >
Showing 1-3 of 3 comments
anarcher Oct 4, 2017 @ 4:16pm 
Run the game in window set to your screen's native reso, then move the window so it fills the whole screen. At least in KDE those settings can be stored and automatically applied when the game is run. You can even remove the window border and top bar.
Nightwulf Oct 10, 2017 @ 4:00pm 
Well, thx for the hint but that ain't fullscreen ;-)
anarcher Oct 10, 2017 @ 4:07pm 
It fulfills the purpose for the sake of playing.
< >
Showing 1-3 of 3 comments
Per page: 15 30 50

Date Posted: Oct 3, 2017 @ 3:36am
Posts: 3