Tom Clancy's Ghost Recon Future Soldier

Tom Clancy's Ghost Recon Future Soldier

Skeletus Dec 29, 2012 @ 8:29am
Ubisoft Game Launcher: Error Code 2
Says I have most up to date version. I assume the game installed it since if i try to reinstall it it says I already have newest. Help plz?
< >
Showing 1-4 of 4 comments
Evan803 Dec 29, 2012 @ 9:17am 
you have to go and download the new lancher off line
Skeletus Dec 29, 2012 @ 6:11pm 
I tried that, it says I have the newest version installed, but if I uninstall it it still says I have newest install and it wont install.
DizzyTastic Dec 30, 2012 @ 7:28pm 
try to "Uninstall" ubisoft launcher, then you must delete the ubisoft launcher folder. Don't skip this step and don't let anything left in ubisoft launcher folder. Reinstall the Game Launcher. Hope this will fix your problem :)
virgils Mar 1, 2020 @ 12:41pm 
patootes
< >
Showing 1-4 of 4 comments
Per page: 15 30 50