The Amazing Spider-Man

The Amazing Spider-Man

View Stats:
EragonGhost Sep 25, 2012 @ 5:38pm
LAG ATI AMD
Hello

The game gets much lag when running on AMD ATI cards.
I need an UPDATE, the game does not run smooth on AMD ATI video cards.

My configuration:
Intel Core2 Quad
4GB Corsair Dominator DDR3 RAM
ATI Radon HD 6950 2GB GDDR5

-----

Olá.

O jogo fica com muito lag quando executado em placas ATI AMD.
Preciso de um UPDATE, o jogo não roda liso em placas de vídeo ATI AMD.

Minha configuração:
Intel Core2 Quad
4GB RAM DDr3 Corsair Dominator
ATI Radon HD 6950 2Gb gDDr5
< >
Showing 1-15 of 38 comments
Rich™ Sep 26, 2012 @ 4:12am 
I'm glad this isn't just me.
davarod Sep 26, 2012 @ 5:33am 
I have an AMD processor too and the same problem. Waiting for updates.
Radical Russian Sep 26, 2012 @ 8:22am 
Wait for new GPU drivers from AMD and an update of the game. (Might even work to upgrade to latest beta of catalyst)
Photonboy Sep 26, 2012 @ 10:10am 
I can turn the quality up to the HIGHEST at the start (indoors) but when I start the outdoor swinging part the frame rate PLUMMETS sometimes below 30FPS.

That's with a GTX680!!

The game is not well coded despite the creatures looking good. Another unoptimized port. Sigh.
(I'd rather just play "Shattered Dimensions" again. Great game.)
Rich™ Sep 26, 2012 @ 1:21pm 
Originally posted by Danusko:
This solution works fine, i have a ATI card as well.

http://www.gamespot.com/the-amazing-spider-man-2012/forum/ati-gpu-users-poor-fps-fix-100-working-63820013/

I tried that and I get "ASMLauncher.exe has stopped working"
Last edited by Rich™; Sep 26, 2012 @ 1:21pm
danusko Sep 26, 2012 @ 1:27pm 
The launcher stop working: you have to launch from Steam, then copy the dll to where the Game.exe is located and then, from launcher (where you config) , start the game. You have to do this every time you boot the game, the .dll crash the launcher if you try to begin the game with it on the folder. It sucks but for now it's the best solution =/
Willy Sep 26, 2012 @ 1:42pm 
Didn`t work for me
danusko Sep 26, 2012 @ 1:55pm 
What i did: downloaded the file from the link. Double click D3D9Gen.jar inside the .rar (need Java), choose Nvidia GTx 460 from list (my VGA is ATI HD7970) and click generate dll. Launch the game from Steam, a config window appear, let it openned. Now you copy this generated .dll to the The Amazing Spiderman folder inside steamapps/common, and from the config window, start the game. Remove .dll from folder every time you restart the game or it willl crash, and do the same steps. I'm still waiting a oficial solution, but this fix made miracle here is my PC. If i can be of any help, add me and i'll gladly assist =)
Last edited by danusko; Sep 26, 2012 @ 1:56pm
Willy Sep 26, 2012 @ 1:57pm 
Danusko sou do Brasil, me add na Steam, te mandei o invite, com Nvidia nao funciona isso e ta lagado da mesma forma que na ATI
danusko Sep 26, 2012 @ 2:00pm 
Entendi, esse fix é pra ATI =/ . Eu aceitei seu convite, mais tarde estou em casa e entro online no chat. o/
Notter Sep 26, 2012 @ 4:31pm 
worked for me, games runs pretty smooth now
EragonGhost Sep 26, 2012 @ 5:27pm 
Vi na net que seria lançado um update no dia 12 deste mês, mas até o momento nada, aquela DLL para ATI Funciona bem, porem não acho justo pagar caro pelo jogo e te que ficar fazendo gambiarra para jogar.
Deathlok Sep 28, 2012 @ 2:45pm 
Download the latest Beta driver from ATI.
FJheals Sep 30, 2012 @ 7:56pm 
Yea, I'm having the same problem It's mostly 55-60 when standing still but When I'm jumping around it easily gets to 16-20
< >
Showing 1-15 of 38 comments
Per page: 15 30 50

Date Posted: Sep 25, 2012 @ 5:38pm
Posts: 38