The Lord of the Rings Online™

The Lord of the Rings Online™

View Stats:
Entity Nov 17, 2013 @ 8:43pm
8.1
How do you play with freaking Windows 8.1 update? Ive gone into the configs and chagned the 4 numbers for .NET Framework to 4.0 and now the launcher works. But than after a minute or 2 it crashes to desktop. I saw online a person said make another user account on the PC and I did that and it does the same thing. WTF IS UP WITH 8.1!! and why the ♥♥♥♥ did Turbine make the game require you to have .NET Framework 1.1 which came out how many years ago? I bought this PC back in February/ March of this year. I ran the game on Steam than just fine and I got the dlc off Humble Bundle and apparently everyone says its 8.1 because there are 2 new user agreements but I cant agree to them becasue the lauincher keeps crashing.
< >
Showing 1-15 of 26 comments
tekias Nov 17, 2013 @ 8:44pm 
Launcher keeps crashing because the servers are down. Give it a few, wait till the topics are all celebrating the game coming back, then try again. If the problem persists, we can give better answers.
Entity Nov 17, 2013 @ 8:45pm 
Well it was doing it yesterday too. were tehy down than as well?
tekias Nov 17, 2013 @ 8:46pm 
No they weren't. Sorry, just tired of all the posts in the last few hours ♥♥♥♥♥ing about how the launcher doesn't work, and your post didn't mention that you tried yesterday. Since I'm still on Vista, I can't personally help, sorry, but I'm sure someone can soon enough.
Entity Nov 17, 2013 @ 8:47pm 
thanks for the attempt at helping lol
Valamar Nov 18, 2013 @ 8:14am 
Windows 8.1 is apparently not compatible with LOTRO. There are MANY problems with it in the LOTRO tehcnical forums.

As for the Humble Bundle -- it is NOT POSSIBLE to get any DLC from anyplace but the Steam Download or the Turbine download at lotro.com. That is simply a fact of how the game is built.

You can download the LOTRO game-client from Steam or from lotro.com (using Pando).
Once the basic client is downloaded, and launched, it will begin patching to match the current patch level. THe Steam download is roughly 18 months and 6 patches out of date, and the download from LOTRO.com not much more current, if at all.

The game is designed so that the Launcher first verfies the versions on your system with those current, and downloads the patches accordingly.

Once you have patched the client, you have ALL DLC available -- access to it is controlled by "Keys" entered at myaccount.turbine.com. That "key" is the ONLY thing you get from the Humble Bundle. You get that Key and then enter it at myaccount.turbine.com to activate it.

LOTRO has ALWAYS used .NET -- it's been around since 2006, remember. The question to ask is "Why did Microsoft Drop .NET support from Windows 8.1?"

You can check the various threads at forums.lotro.com -- scroll down to "Customer Support" at the bottom and check out the "Windows PC Technical Support" forum.

.... or switch to a Mac and download the Mac Client :)
Entity Nov 18, 2013 @ 9:24am 
@KinDawn That doesnt work. This sucks♥♥♥♥♥ I wish I could uninstall 8.1
Thrane Nov 18, 2013 @ 9:30am 
you can to download the game form lotros webside. i have win 8.1 and have had lotro for a long time and i only have problems now when i try to do it with steam :/
Entity Nov 18, 2013 @ 9:32am 
@Thrane I am going to do that probalby. I just had a steam code from the Humble Bundle for a DLC that I wanted to use
Entity Nov 18, 2013 @ 9:44am 
Im installing hte game now via the LotRO launcher from their site NOT steam. I think that steam is the issue here for the most part.
Sagalxdichoiga Nov 18, 2013 @ 10:47am 
You dont have to follow the long instruction in that link. Take a look at page 2 from the link I posted, spark91's comment. Download the two files, using winrar to extract the dotnetfx.exe, then there should be a file named netfx.msi. Click on that file to install net framework 1.1 (you cant install without extracting the dotnetfx.exe file, it will tell you some stupid error). After that dont forget to install the service pack file. This file you dont have to extract.

Even if you use the lotro without steam,I think the problem will remain because it is all about the net.framework 4.0 of 8.1 is not compatible with the lotro launcher. After installing net.framework 1.1 everything will be resolved.
DigitalImpostor Nov 18, 2013 @ 10:53am 
Originally posted by thebat991:
why the ♥♥♥♥ did Turbine make the game require you to have .NET Framework 1.1 which came out how many years ago?
The game was released in 2007.
Thrane Nov 18, 2013 @ 11:10am 
Originally posted by thebat991:
@Thrane I am going to do that probalby. I just had a steam code from the Humble Bundle for a DLC that I wanted to use
´
the DLC do you need to youse at turbine so you can get DLC aslong as you have the CD key
Entity Nov 18, 2013 @ 11:40am 
@KinDawn I dont think it installed lol. I did the first one the .Net1.1 and I checked in Control Panel where you turn programs and features off and it lists 3.5 and 4.0 but not 1.1 ; and for the last 10 minutes the Happy Cloud thingy has said that its downloading LOTRO 100%. and I mean downloading not downloaded. I have no idea what is going on. Cant Turbine just change thier thingy to require 4.5. how hard would it be to do that? lol
DigitalImpostor Nov 18, 2013 @ 1:41pm 
Originally posted by thebat991:
Cant Turbine just change thier thingy to require 4.5. how hard would it be to do that? lol
It's possible it would require it to be completely reprogrammed from scratch, depending on how many elements it relies on that were in 1.1 which no longer exist in 4.5.
< >
Showing 1-15 of 26 comments
Per page: 15 30 50

Date Posted: Nov 17, 2013 @ 8:43pm
Posts: 26