Conquest of Elysium 3

Conquest of Elysium 3

Ismelly[?!?] Mar 10, 2013 @ 10:36pm
Cant play. Too blurry
I just bought CoE3. Im able to start the game no problem and it exits fine.
But all the words are SUPER blurry. The name CoE3 in the background is fine but the menu options are illegible.
Is there a fix to this or do i have to do something before running? Thanks
< >
Showing 1-15 of 21 comments
currymuncher Mar 11, 2013 @ 2:39pm 
try to change the res in the options or try in window mode .hope it works .
Ismelly[?!?] Mar 11, 2013 @ 2:52pm 
Can i do that another way? Not having to go through the game menu, as i cant read any of the options.
Unless would give me a walkthrough of the options to get to the res.
i.e. 1st option is new game
2nd option might be load game
3rd is options
LokiNog Mar 11, 2013 @ 4:22pm 
Yea I don't see this game being at all playable with blurry text. Do you have some sort of morphological filter set on your video card? AMD cards have that option. I remember it causing blurry text in a different game and had to turn it off. Worth a shot.
johan  [developer] Mar 11, 2013 @ 4:24pm 
Have you tried downloading graphics drivers from your graphics card manufacturer (amd, nvidia or intel)? That usually solves the graphics problems with CoE3.
Ismelly[?!?] Mar 11, 2013 @ 4:41pm 
im on a laptop and am running on an intel integrated graphics card
johan  [developer] Mar 12, 2013 @ 1:52am 
Ismelly[?!?] Mar 12, 2013 @ 10:13am 
I managed to get the driver updated but it changed nothing for CoE3.
This sucks

On a side note, thanks to updating my drivers, the icons in WarZ are now visible. They used to be red squares. Thanks alot :D
Last edited by Ismelly[?!?]; Mar 12, 2013 @ 10:21am
johan  [developer] Mar 13, 2013 @ 12:47am 
Glad it helped something at least.
You could try running coe3 in windowed mode (press alt+return to switch)
Can you take a screenshot? It would be nice to see what it looks like.
Ismelly[?!?] Mar 13, 2013 @ 12:13pm 
okay, i dont know how to post pictures here or if its even possible sooo....its on my profile :D

Last edited by Ismelly[?!?]; Mar 13, 2013 @ 12:17pm
johan  [developer] Mar 13, 2013 @ 3:27pm 
Thank you, that was indeed hard to read. Have you tried windowed mode?
Ismelly[?!?] Mar 13, 2013 @ 3:50pm 
yea. one of the pics was in windowed mode but steam obviously only screenies the game it self lol
Ismelly[?!?] Mar 13, 2013 @ 3:51pm 
which i only realized AFTER the pic was taken :)
i have never screenshotted on steam before lol
but now it makes sense
Last edited by Ismelly[?!?]; Mar 13, 2013 @ 3:51pm
Ismelly[?!?] Aug 8, 2013 @ 8:33pm 
I wrote this game off as a loss when I couldn't get it to work properly.
Just wanted to ask, did anyone else ever have this problem?
If so, were you able to fix it?
lessthanpwnage Aug 8, 2013 @ 9:20pm 
Getting the same problems here
One_Armed_Scissor Aug 11, 2013 @ 3:03pm 
Hey did a little searcing, and maybe this miiiight help?

You can go into Steam/steamapps/common/ConquestOfElysium3 and then right click on the CoE3 icon and select properties and then go into the Compatability tab and check the box that says "Disable display scaling..."

I hope that helps. I'm not a computer wiz or anything, so I'm not making any promises.
< >
Showing 1-15 of 21 comments
Per page: 15 30 50