Starbound

Starbound

View Stats:
Starbound > Bug Reports > Topic Details
Ochus Feb 21, 2015 @ 7:18am
Starbound Runtime Error Caued by an Item?
Everytime I run Starbound I get this error


[09:12:17.250] Error: Could not instantiate item '[alienstripedblock, 1, {}]'. (ItemException) No such item 'alienstripedblock'
[09:12:23.811] Error: Could not instantiate item '[humanvanguardpants, 1, {}]'. (ItemException) No such item 'humanvanguardpants'
[09:12:24.379] Error: Could not instantiate item '[humanvanguardchest, 1, {}]'. (ItemException) No such item 'humanvanguardchest'
[09:12:28.907] Error: Could not instantiate item '[humanvanguardhead, 1, {}]'. (ItemException) No such item 'humanvanguardhead'
[09:12:31.943] Error: Could not instantiate item '[slimcapeback, 1, {}]'. (ItemException) No such item 'slimcapeback'
[09:12:32.104] Error: Could not instantiate item '[alienstripedblock, 1, {}]'. (ItemException) No such item 'alienstripedblock'
[09:12:32.906] Error: Exception raised during Root finishLoad: (ItemException) Could not create blueprint item from recipe
StarException::StarException(string, exception)
StarException::StarException(char*, exception)
ItemDatabase::addBlueprints()
ItemDatabase::ItemDatabase()
Root::itemDatabase()
_Function_handler<void (), SwallowReturn<_Bind<_Mem_fn<shared_ptr<ItemDatabase> (Root::*)()> (Root*)> > >::(_Any_data)
_Function_handler<void (), WorkerPool::addWork(function<void ()>)::{lambda()#1}>::(_Any_data)
WorkerPool::WorkerThread::run()
ThreadImpl::runThread(void*)
BaseThreadInitThunk
RtlInitializeExceptionChain
RtlInitializeExceptionChain

Caused by: (ItemException) No such item 'alienstripedblock'
ItemException::ItemException(string)
ItemDatabase::itemData(String)
ItemDatabase::addBlueprints()
ItemDatabase::ItemDatabase()
Root::itemDatabase()
_Function_handler<void (), SwallowReturn<_Bind<_Mem_fn<shared_ptr<ItemDatabase> (Root::*)()> (Root*)> > >::(_Any_data)
_Function_handler<void (), WorkerPool::addWork(function<void ()>)::{lambda()#1}>::(_Any_data)
WorkerPool::WorkerThread::run()
ThreadImpl::runThread(void*)
BaseThreadInitThunk
RtlInitializeExceptionChain
RtlInitializeExceptionChain

[09:12:32.921] Info: Renderer destroyed
[09:12:32.980] Info: Shutting down Star::Root
[09:12:35.344] Error: Fatal Exception Caught: (StarException) An error occurred during loading: (ItemException) Could not create blueprint item from recipe
Caused by: (ItemException) No such item 'alienstripedblock'
ClientApplication::postSplashInitialization()
ClientApplication::update()
StarApplicationBase::run()
_SDL_main
_console_main

I don't even know what block or item it's talking about, anyone have any idea on how to fix this?
I have no mods installed that adds any new items(All I have is the Spawnable Item mod for vanity stuff) I wouldn't think this would cause the problem, would it?

EDIT: Searched in my mod's files. Apparently it has a recipe for "alienstripedblock" would this be the cause?
Last edited by Ochus; Feb 21, 2015 @ 7:21am
< >
Showing 1-2 of 2 comments
SillyMind69 Apr 23, 2015 @ 5:36am 
Just delete the mods folder. This helped me :)
Sorry for the late reply...
Ochus Apr 23, 2015 @ 5:13pm 
It's alright
< >
Showing 1-2 of 2 comments
Per page: 15 30 50

Starbound > Bug Reports > Topic Details
Date Posted: Feb 21, 2015 @ 7:18am
Posts: 2