Starbound

Starbound

View Stats:
Starbound > Bug Reports > Topic Details
Tim Stryker Jul 22, 2016 @ 2:07pm
FULLSCREEN & HIGHER RESOLUTION FIX
Thanks to a tip I found from CorpusDelicti on another post, figured Id post this for others as I was having the same probs & fixed it for me. Not only was my mouse curser only working on 2/3 of the screen at full screen but also couldnt use 2560x1440 res which pisses me off cus whats the point of having a nicer screen if you cant make full use of it.

Cant seem to make the changes under the 64/win folder but was able to under the 32. If you have the game installed to a different drive, just sub the letter C for w/e your other drive is under.

GO TO - C:\Program Files (x86)\Steam\steamapps\common\Starbound\win32

From CorpusDelicti post -

"Right click the game's .exe, click on Properties and under the Compatibility tab check the box next to "Disable Display Scaling On High DPI Settings". This always solves the problem for me!"

EDIT: - TO PLAY WIN/64 MODE T PLAY WITH FRIENDS. I dont know if this will help everyone with different OS then me.

So even tho the first fix works for single player purposes, I was NOT able to play with a friend since you have to launch the game from steam to do so & launching from steam forces win/64 exec to load instead of win/32 & for me, the options under win/64 were grayed out. after spending HOURS - YES FRICKEN HOURS trying to fix THAT ISSUE, idk why but it occured to me that maybe my text size settings could be causing the full screen issue under win/64 exec & sure enough IT WAS.

Since my monitor is native 2560x1440 I HAVE to have text size set to large in order to read any text on steam, web browser etc without having my nose to the screen.

From desktop, right clicked, went to resolution settings, from there was a link to change text size & I set it back to the default small/normal setting. Making this change required me to have to log off my user profile & log back in to take effect which I did. Upon doing so & relaunching the game via steam, everything was fine, full screen worked great & was able to set to full 2560x1440 resolution with no probs & spent a few hours with a friend in game. I have windows 7 so Im not sure if this will apply to other OS but I know for me it was a God send of a fix.

Only other probs which are unrelated & I wont even bother with atm is I couldnt use steam voice chat with push-to-talk. Had to change to non push constant voice stream & that worked...allthough on my first fix launching under win/32 I had no probs with voice & could use it like normal...go figure...
Last edited by Tim Stryker; Jul 22, 2016 @ 10:59pm
< >
Showing 1-10 of 10 comments
redledcat Jul 22, 2016 @ 2:32pm 
Thank you! What a relief
Tim Stryker Jul 22, 2016 @ 2:39pm 
yw lol...exactly how I felt. ( ;
HossPorkchops Jul 22, 2016 @ 3:26pm 
Praise Jesus... er, Praise Tim. Seriously, man, thank you. I've been dealing with this issue for ages, but anytime I tried asking about it on the Starbound reddit or forums the fanboys would descend on me like a flock of ♥♥♥♥♥♥♥♥ wombats.
Tim Stryker Jul 22, 2016 @ 4:35pm 
lol...yw ( : yeah fanboys can be too one-sided often times. The only problem Im having now is it wont let you join a friend doing it this way since its not launching directly from steam...& trying to launch thru steam forces the win64 bit version to launch instead bringing back all the old problems.
Tim Stryker Jul 22, 2016 @ 10:54pm 
BUMP...sure others can still benefit from this. And also maybe from the added info via edit.
Tim Stryker Jul 23, 2016 @ 6:01pm 
Last time Ill bump this for anyone else it might benefit.
OmegaRogue Apr 22, 2018 @ 10:48am 
the option "Disable Display Scaling On High DPI Settings" is not there on the lastest windows version heres a screenshot of the current properties window on the compatibility tab https://imgur.com/a/JgTatsw
Tim Stryker Apr 26, 2018 @ 4:39am 
Originally posted by OmegaRogue:
the option "Disable Display Scaling On High DPI Settings" is not there on the lastest windows version heres a screenshot of the current properties window on the compatibility tab https://imgur.com/a/JgTatsw

Ehhh, yeah... something about that & that EXACT same set of circumstances you mention, is ringing a rather large bell, in my memory there... Just really cant recall exactly what it was atm or the specific context it was in.

But Im almost sure it involved an actual work-around for that same issue. IDK if its cuz its been too long ago, or just cuz its waaay late for me here, atm... I find myself far too often having to TS crap here on steam, so it might have involved something else directly,.. or rather indirectly, concerning again, exactly what you point out above, WITH an actual solution, which as best I can recall, I kinda have the feeling that it wasnt anything too terribly hard to rectify that difference...

Something about achieving the same result, just by using a different pathway or alternative command, that at the end of it all, ended up making sense, accounting for the differences between OSs.

Just cant really recall more then that atm unfortunately... But again, Im almost sure that, thats a thing here... If it happens to come to me, Ill def come back & elaborate on it more. Otherwise, Id suggest a google search with the key words, - " Disable Display Scaling On High DPI Settings " for starters & be willing to invest a decent amount of time into finding the exact correlation specific to this situation here. Wouldnt think itd be too hard to find.
OmegaRogue Apr 27, 2018 @ 12:22pm 
i somehow fixed it

Originally posted by Tim Stryker:
Originally posted by OmegaRogue:
the option "Disable Display Scaling On High DPI Settings" is not there on the lastest windows version heres a screenshot of the current properties window on the compatibility tab https://imgur.com/a/JgTatsw

Ehhh, yeah... something about that & that EXACT same set of circumstances you mention, is ringing a rather large bell, in my memory there... Just really cant recall exactly what it was atm or the specific context it was in.

But Im almost sure it involved an actual work-around for that same issue. IDK if its cuz its been too long ago, or just cuz its waaay late for me here, atm... I find myself far too often having to TS crap here on steam, so it might have involved something else directly,.. or rather indirectly, concerning again, exactly what you point out above, WITH an actual solution, which as best I can recall, I kinda have the feeling that it wasnt anything too terribly hard to rectify that difference...

Something about achieving the same result, just by using a different pathway or alternative command, that at the end of it all, ended up making sense, accounting for the differences between OSs.

Just cant really recall more then that atm unfortunately... But again, Im almost sure that, thats a thing here... If it happens to come to me, Ill def come back & elaborate on it more. Otherwise, Id suggest a google search with the key words, - " Disable Display Scaling On High DPI Settings " for starters & be willing to invest a decent amount of time into finding the exact correlation specific to this situation here. Wouldnt think itd be too hard to find.
Tim Stryker Apr 30, 2018 @ 2:27am 
Yeah, thought it was still somehow possible. Cool.
< >
Showing 1-10 of 10 comments
Per page: 15 30 50

Starbound > Bug Reports > Topic Details
Date Posted: Jul 22, 2016 @ 2:07pm
Posts: 10