Magical Diary

Magical Diary

View Stats:
Miss Deliria Feb 25, 2013 @ 11:32am
I should have gotten 3 achievements but they arent listet. Does anyone have the same problem?
< >
Showing 1-15 of 22 comments
UkeYaoiCatboy Feb 26, 2013 @ 10:39am 
Yeah, I am pretty sure I have some achievements and steam doesn't list any. I don't really mind tough, I finished the game and it was great fun! :3
Hanako  [developer] Feb 26, 2013 @ 11:58am 
Check to be sure what you've officially earned by looking at the 'trophies' setting in the game. Sometimes there can be quirks about what gets recorded depending on when you earned it.

If they do show up in trophies but not in your steam account, what operating system are you using? I know there were problems with the steam overlay in some linux flavors, and I believe it now disables itself if it encounters problems, which would probably keep your achievements from being recorded.
Miss Deliria Feb 26, 2013 @ 12:24pm 
Thank you. My trophies are shown in game but not in my steam account. I use a Gentoo 64bit.
Miss Deliria Jul 24, 2013 @ 10:04am 
I am using a linux mint 14 now, and I still encounter the same problem. Is there any way to fix this?
Alex7Kom Jul 25, 2013 @ 9:05am 
I have exactly the same problem. I'm using Ubuntu 13.04 x64. Maybe it's because I was using a software renderer? I tried to launch it in 'normal' way, the game works (earlier it didn't) but still no achievements.
Spiky Caterpillar  [developer] Jul 27, 2013 @ 2:20am 
I'm not sure what exactly causes the bug, but on many Linux machines initializing the Steam API (required for achievements to be synced to your account) crashes with a segmentation fault. I'm guessing it's a library compatibility issue, but (irritatingly) my own computer (Debian stable, amd64) and many others don't show the bug. To workaround the crash, what I've been doing is using a semaphore file to detect if the crash occurred, and, if so, disabling the Steam API and restarting the game behind the scenes.

If you've changed something that might fix the bug (I'm particularly interested in whether the Gentoo->Mint move fixes it), try
deleting ~/.renpy/MagicalDiaryHorseHall/ and starting the game and see if that works. It should resync your trophies on start if it successfully loaded the Steam API. There's a chance that changing the renderer (and, again, removing and any other .fail files in your save dir) might work around the bug on some machines, but I haven't seen anyone actually report that succeeding so far.
Miss Deliria Jul 27, 2013 @ 3:32am 
I tried deleting as you suggested but everytime I start the game I get this message:

Fatal Python error: (pygame parachute) Segmentation Fault
Trying again, because Steam API init failed.
Debug: Achievement integration disabled due to previous crash.

I also tried changing the renderer but the same thing happens if I do so. There are no other .fail files in my save directory.

Is there another way to fix this problem? Thank you.
Miss Deliria Jul 27, 2013 @ 6:58am 
i have found a temporary solution. I just installed Magical Diary using wine and copied my save files.
DrMcCoy Nov 27, 2013 @ 6:22pm 
Have the same problem here, Debian unstable on amd64.

Hate Plus, which also uses Ren'Py, didn't have this problem, from what I remember.
ghostespeon Nov 27, 2013 @ 7:06pm 
I got most of them so far but not all of them
Last edited by ghostespeon; Nov 27, 2013 @ 7:06pm
Spiky Caterpillar  [developer] Nov 28, 2013 @ 10:29am 
@DrMcCoy: In the game's video settings, what renderer is it set to use and what renderer does it say it's actually using? What does your opengl.txt (in the game directory) file say?

Does setting it to use the software renderer and deleting fix achievement synchronization?

Hate Plus uses a different version of Ren'Py - do you know what renderer it's using on your system? (It should tell you in its log.txt file, also in the game directory.)
DrMcCoy Nov 28, 2013 @ 10:57am 
Nope, changing the renderer doesn't fix it.
Here's the opengl.txt:

Hate Plus says
Vendor: 'NVIDIA Corporation' Renderer: 'GeForce 8600 GTS/PCIe/SSE2' Version: '3.3.0 NVIDIA 325.15'
as well, so that'd be the hardware renderer, I guess.
DrMcCoy Nov 28, 2013 @ 11:09am 
If you can use it, I could give you the core it dumps.
Spiky Caterpillar  [developer] Nov 28, 2013 @ 12:20pm 
I don't think there's anything meaningful I can do with the core - I'm reasonably sure that the bug's some obscure interaction that I'd need the Steam API source to fix), but if you're up for more testing I can try making an alpha with the latest Steam API and see if that fixes the problem (I don't expect it to, since LLtQ has the same problem on some Linux systems) and see if Valve wants the cores and/or backtraces.
DrMcCoy Nov 28, 2013 @ 1:24pm 
Well, I seem to have fixed it.

I attached valgrind to the process (the log is here, in case you're interested: ), and saw that there's a in both my steam install and the Magical Diary lib/ directory. Crawling through them in IDA, it seems it somehow messes up the second parameter to ThreadSetDebugName() when daisy-chaining those libraries (the ThreadSetDebugName() in Magical Diary is a NOP, btw). That parameter is given to strncpy() as the src parameter, and there's the invalid read killing the process.

I just copied (and from my steam install over the files in the Magical Diary lib/ directory, and then it seems to work. Looks like a version mismatch between the Steam API in steam and what you're distributing. I am running a public beta version of Steam, in case that has something to do with it.

No idea what the proper fix it, though. Is it actually necessary to distribute Magical Diary with a copy of the steam library?

EDIT: Hate Plus doesn't come with any of those libraries. Sorry for harping a bit on that point, but Hate Plus is the closest thing I have for comparisons.
Last edited by DrMcCoy; Nov 28, 2013 @ 1:32pm
< >
Showing 1-15 of 22 comments
Per page: 15 30 50