Rune Classic

Rune Classic

View Stats:
Rune Classic > General Discussions > Topic Details
Turbo Nozomix Jun 15, 2017 @ 4:05am
Rune only 1024x768 res, crashes when changing 3D device
In the game settings menu, I tried changing the resolution from 1024x768 to my monitor's native resolution of 2560x1440, but the game froze and crashed when I selected the higher resolution.

After that, the game only shows the option of 1024x768 resolution in the game settings menu.

And when I launch the 3D device setup app, and click anything, the 3D device setup window freezes, and the app crashes. If I wait like 20 or so seconds, it eventually completes detecting my system's 3D devices (software rendered, Direct 3D), but choosing Direct 3D does nothing to make my monitor's native resolution display in the in-game settings.

Anyone have any ideas? I think the game needs a patch for Windows 10 CU.


My system:

Windows 10 CU
Asus P8P67 Pro Rev 3.1
i7 2600K
GTX 1070
16 GB RAM
Last edited by Turbo Nozomix; Jun 15, 2017 @ 4:13am
< >
Showing 1-7 of 7 comments
J-Rts Jun 15, 2017 @ 3:41pm 
Go to your Rune directory and open the System folder. Look for the Rune.ini file and open it with Notepad. Search for the [WinDrv.WindowsClient] section and change FullscreenViewportX to 2560 and FullscreenViewportY to 1440. Save the file and try it out. Hope this helps.
Turbo Nozomix Jun 15, 2017 @ 4:02pm 
Thanks for the tip, but when I alter the resolution in the text file, the game launches in window-mode. And if I alt+enter, the resolution stays in the window-mode resolution, moved into the upper-left corner of the screen. And if I change the window-mode resolution in the ini file, then the game doesn't properly load.

I hope that HHS are going to give the game a patch to fix this.
Last edited by Turbo Nozomix; Jun 15, 2017 @ 4:02pm
Furries Must Die! Jun 16, 2017 @ 6:18am 
Originally posted by Turbo Nozomix:
Thanks for the tip, but when I alter the resolution in the text file, the game launches in window-mode. And if I alt+enter, the resolution stays in the window-mode resolution, moved into the upper-left corner of the screen. And if I change the window-mode resolution in the ini file, then the game doesn't properly load.

I hope that HHS are going to give the game a patch to fix this.

Just wanted you to know that after trying the ini fix, I'm having the same issue as you, word for word. I tried the high resolution patch you can find on the WSGF website, but for me I still cannot select the "OpenGL" option I need to after following all instructions. Check that patch out, you may have more luck.
Last edited by Furries Must Die!; Jun 16, 2017 @ 6:18am
GiSWiG Jun 19, 2017 @ 8:09pm 
I bought this off of GOG.com because it was on sale but it is still the same 'Rune Classic'. Either way, I was bumbed out by the fact that I couldn't get more than 1024x768. What makes it worse is that I tried it on my son's PC and he can choose up to 1600x1050. He has an NVIDIA card and I have an AMD card. I also have a 21:9 monitor, 2560x1080.

I fixed it by pulling out my old copy of Rune Gold, installing it, and then patching to 1.08. Now I can choose OpenGL (had to choose show all devices cause it did not find it) and I set resolution to 2560x1080. I know it doesn't help this Steam/GOG version, which happens to be 1.10. 1.08 was the last of the original version.

My system has an AMD RX 480 and my son's has a GeForce GTX 465. Both are Windows 10 64-bit.

I hope it helps.
Turbo Nozomix Jun 21, 2017 @ 7:10pm 
Here's the support email for Rune Classic:
https://help.steampowered.com/en/wizard/HelpWithGameTechnicalIssue?appid=210950

runeclassicsupport@ninerealms.net

I recommend people email Human Head Studios to get a patch to fix this. It sucks that the game isn't playable on Windows 10 CU.

Originally posted by GiSWiG:
I bought this off of GOG.com because it was on sale but it is still the same 'Rune Classic'. Either way, I was bumbed out by the fact that I couldn't get more than 1024x768. What makes it worse is that I tried it on my son's PC and he can choose up to 1600x1050. He has an NVIDIA card and I have an AMD card. I also have a 21:9 monitor, 2560x1080.

Which Windows version does your son have on his PC?


I fixed it by pulling out my old copy of Rune Gold, installing it, and then patching to 1.08. Now I can choose OpenGL (had to choose show all devices cause it did not find it) and I set resolution to 2560x1080. I know it doesn't help this Steam/GOG version, which happens to be 1.10. 1.08 was the last of the original version.

My system has an AMD RX 480 and my son's has a GeForce GTX 465. Both are Windows 10 64-bit.

I hope it helps.

Basically transfuse the files from original Rune to the Steam directory. But this requires owning multiple copies of Rune. Interesting to know, anyway. Thanks.
xanasago Jun 23, 2017 @ 5:59am 
Hi, had the same problem today and found something that helped me to play in 1920x1080 in W10 pro with CU.
I changed the compatibility mode to xp service pack 3 AND "Override high DPI scaling behaviour" for this application only. The second setting is just a few pixels under the first. Hope it helps you too :)
Turbo Nozomix Jul 17, 2017 @ 12:43am 
Originally posted by xanasago:
Hi, had the same problem today and found something that helped me to play in 1920x1080 in W10 pro with CU.
I changed the compatibility mode to xp service pack 3 AND "Override high DPI scaling behaviour" for this application only. The second setting is just a few pixels under the first. Hope it helps you too :)

Thanks, but I just tried this and it doesn't work for me. If I try to fullscreen the game, it freezes, and I only get small resolution options in the video settings. There's nothing above 800x600 when I set the configuration as you mention. My monitor is 2560x1440.
< >
Showing 1-7 of 7 comments
Per page: 15 30 50

Rune Classic > General Discussions > Topic Details