Dark Messiah of Might & Magic Single Player

Dark Messiah of Might & Magic Single Player

View Stats:
Aasharu Jun 4, 2013 @ 9:44pm
Can't get a mod to work
I'm trying to install the Unholy Weapons mod, and it requires that I place it in the mm/models folder. Now, there is no such folder for my install, so I made it, and placed the mod files in there. I checked and double checked that the folder was correctly named, but it still won't work. Most infuriating thing is that I've managed to get this mod to work for me before, but I don't remember how - it's been a while, and I lost the info when I had to reformat. So yeah, any help/advice/assistance?
< >
Showing 1-12 of 12 comments
fista1 Jun 5, 2013 @ 8:19am 
I assume that you are using the Steam version. The Steam version was "uptaded", which means that the filesystem was changed, so the files can be on another places, or were replaced by another files.
Aasharu Aug 15, 2013 @ 12:10am 
I am indeed using the Steam version. I kind of suspected such a thing might be the case, but I'm still in the dark as to what to do about it. Any suggestions?
Scorp Sep 5, 2013 @ 6:24am 
Blame steam pipe for this
Ryan Sep 8, 2013 @ 1:10pm 
Create a new directory named "custom" in your "Steam\steamapps\common\Dark Messiah Might and Magic Single Player" directory.

Next, open the "mm" folder from the above path and edit "gameinfo.txt" so that its SearchPaths reads:
SearchPaths { Game custom // add this line Game mm Game |gameinfo_path|. }
Now you may add your mod files into the "custom" folder. Be sure to follow the same directory structure as found in the "mm" folder; Map files should be in a "maps" subdirectory, models in a "models" subdirectory, etc.

Edit: You may also need to copy the media folder from the mm directory into your custom folder. Thanks, Buzztr0n.
Last edited by Ryan; Apr 5, 2017 @ 1:51pm
Aasharu Sep 13, 2013 @ 4:33pm 
That did it, thanks! Took care of all my problems.
FinnishPenguin Sep 30, 2013 @ 12:00pm 
Adding the mods to the custom folder just made the game crash after the prologue. I had to copy the entire mm folder to the custom folder to be able to play. I don't know if my mods are enabled anymore, though.
Ryan Oct 3, 2013 @ 8:10pm 
Huh, that hasn't happened to me.

If your mod isn't enabled, try recopying the mod files into your custom folder to overwrite the default mm files.
FinnishPenguin Oct 4, 2013 @ 3:10pm 
Do you have the DVD version? Because the structure of the Steam version is different (the structure changed in May 2013, I believe). All the files have been packed into .vpk files.
Last edited by FinnishPenguin; Oct 4, 2013 @ 3:11pm
Ryan Oct 4, 2013 @ 4:34pm 
I am using the newest Steam version (the one that uses SteamPipe/VPK files).

If you are using the DVD version then you do not need to modify your gameinfo.txt. Assuming the DVD version uses the older GCF-files, your mods should simply be placed in the game's root mm folder, as you would do in any other pre-SteamPipe Source game.
FinnishPenguin Oct 5, 2013 @ 8:39am 
Ah, ok. Mods aren't working anyway because the game crashes and gives some Bink error after the prologue. After removing the mods, I could continue the game.
Ryan Oct 5, 2013 @ 6:55pm 
Bink is the system used to play cutscenes. A cutscene is supposed to play after the prologue: the one where Phenrig tells the player to go to Stonehelm. Maybe the mod you are using adds corrupt cutscene files?

You can find the game's cutscenes in the mm\media directory. I would check to see if the mod contains any of these BIK files, particularly the cutscene_phenrig_briefing.bik, and opt-against adding those.

This doesn't seem very likely, though. If you haven't already, try googling the Bink error message. You might find someone else who has experienced the problem but found a solution.
Buzztr0n Nov 8, 2013 @ 9:19am 
Originally posted by Ryan:
Create a new directory named "custom" in your "Steam\steamapps\common\Dark Messiah Might and Magic Single Player" directory.

Next, open the "mm" folder from the above path and edit "gameinfo.txt" so that its SearchPaths reads:
SearchPaths { Game custom // add this line Game mm Game |gameinfo_path|. }
Now you may add your mod files into the "custom" folder. Be sure to follow the same directory structure as found in the "mm" folder; Map files should be in a "maps" subdirectory, models in a "models" subdirectory, etc.

Woah, THANKS A LOT Ryan, that did the trick! And about the crash: yes, adding the "media" folder (with all the bink videos) fixed the crashes for me.
< >
Showing 1-12 of 12 comments
Per page: 15 30 50

Date Posted: Jun 4, 2013 @ 9:44pm
Posts: 12