Dark Messiah of Might & Magic Single Player

Dark Messiah of Might & Magic Single Player

View Stats:
Enmity NZ Feb 13, 2014 @ 11:50pm
Dark Messiah Of Might and Magic will not launch.
I was looking for a good game using archery so I purchased this game through steam - it quite simply does not launch for me. I go to launch it, it appears to be trying to launch but then nothing..nothing comes up. Upon checking task manager I cannot see the game in the "applications" tab, but I can see the mm.exe running in the processes (which I have to manually end task if I want to try and execute the game again.)

I posted in the below thread but apparently that was the wrong place, here's that thread for your reference :

The troubleshooting I have tried thus far is firstly disabling crossfire, no dice. Verifying Integrity, rebooting, then verifying again, which verifies fine every time anyway..no dice. I tried the windows/system 32 suggestion from Uisor..but I couldn't get that to work as when I move the bink32.dll into system 32...I can not find it again to copy it back to its original place..so it copies to system 32, says its successful...but I can't see it in there now to copy back. I've set it to "show all files" including system files but still cant see the bink32.dll when its in the system32 folder...then I verified integrity again which brought the bink file back to its original place...so tried to copy it again to system32 - this time It says it already exists, do I want to replace it?..yes...and again, can't find it..even using the search option in the top right corner...so I dunno.

Other things I have tried is launching with -autoconfig -condebug -heapsize etc, no dice.

Another suggestion was moving the bink32.dll from the Bin folder to just the main folder where the mm.exe is found, no dice.

After trying all of the above, I read a post from the earlier mentioned thread and followed these steps in the case of me messing my Dark Messiah Installation :

Right-click the game -> Delete local content.
Exit Steam.
In your steamapps\common\ folder find and delete Dark Messiah Might and Magic Single Player folder.
In your Steam directory, find and delete your ClientRegistry.blob file
Reboot the PC.
Launch Steam
Download Dark Messiah Might and Magic Single Player

Upon following these steps, and trying the game with and without crossfire..I am still unable to launch this game, and again, as far as steam is concerned it's launching - steam says I have played like 4 hours of this game..but it never launches. The only indication I get that the game has launched is that the mm.exe process is active in task manager - but usually a game is shown in the "applications" tab of task manager too, which has never happened. I am almost at my witts end with this and on the verge of asking for a refund - I'd just love to play this game again like I did years ago before I lost it.

I am running windows 7 ultimate x64
Catalyst 14.1 beta 1.6

System :
i5 3570k@4.4ghz
8GB DDR3 1600mhz
2 x Sapphire 7970Ghz Vapor-X's
Asus P8Z77-V Motherboard.
< >
Showing 1-15 of 57 comments
Suicide Machine Feb 14, 2014 @ 6:25am 
Did you try to disable your antivirus software, if you use one? That's a common issue as well, that prevents the game from running.

The other is - to disable Windows's UAC, which most often brakes games by virtualizing files in a "safe" directory or simply installing the game outside of Program Files.

I have Catalyst 14.1 beta 1.6 installed currently, so I'll check whatever this is really a drivers fault, that this buggy game doesn't work.

-- EDIT --
Nope - still working just fine, with Catalyst 14.1 beta 1.6. It "crashes" when trying to quit, but that's a problem with lack of heap emulation.
Last edited by Suicide Machine; Feb 14, 2014 @ 6:36am
Enmity NZ Feb 14, 2014 @ 10:40am 
Thanks for your reply man, I just use windows security essentials. WIll try disabling UAC and see if that helps next, but I install my games on a seperate hard drive which is dedicated to my software and games installs. Thanks for your help, will post back with my findings after UAC is disabled. Cheers.
Enmity NZ Feb 14, 2014 @ 10:43am 
ah, I already had UAC disabled lol..
Unbornchild Feb 14, 2014 @ 4:57pm 
Try Catalyst 13.12 WHQL.

Disabling UAC isn't very recommendable for system safety...

I use Security Essentials myself and it does not block mm.exe by default.

But you say the process is running invisibly on the background. Odd...

... You didn't disable the Paging File did you?

You do not use ObjectDock?

When you start the game what do you actually get to see? Did you ever pass the gamma calibration screen? Have you ever seen it? Because on first launch that is where the 'initialising settings' process takes the user. Always. You can skip it but then you have seen it. It might have been awaiting your input on the background?

Last edited by Unbornchild; Feb 14, 2014 @ 6:01pm
Enmity NZ Feb 14, 2014 @ 6:41pm 
I have my pagefile set at 8136MB and nah I don't use Object dock, and i've never had this game launch (or at least, i've never had a window open up after launching DM) I've turned UAC back on now :). When I launch the game (either by double clicking the desktop icon, or launching via steam I get the windows circle swirly thing that indicates that the computer is at least trying to do something - but that stops after a second or two and then nothing, no window pops up, nothing. Upon opening task manager and checking the "applications" tab, there is no sign of dark messiah in there.

If I go back to to try and launch the game again, it says it cannot because it is already running - so back to task manager and checking the "processes" tab I can see mm.exe is running and I have to end that task if I want to try and launch the game again. the mm.exe in task manager is the only thing I can find which indicates that this game has even launched.
Enmity NZ Feb 14, 2014 @ 6:44pm 
will roll back to 13.12WHQL just to test this, been using the beta for mantle in BF4 and starswarm demo.
Unbornchild Feb 14, 2014 @ 7:30pm 
So then you have an issue regarding the initalising of the game. Something on your PC is blocking that part.
Enmity NZ Feb 14, 2014 @ 7:51pm 
I guess so, just seems weird that every other game works, and I play dx9,10 and 11 games with no issue. Only this game behaves in this manner. Im pretty much stumped.
Unbornchild Feb 14, 2014 @ 8:04pm 
What's your monitor's resolution?
Which monitor exactly?
Does it have 1:1 pixel mapping or something similar?

Is it a 1366x768 (16:9)?

Is your Steam set to english language?
Last edited by Unbornchild; Feb 14, 2014 @ 8:08pm
Genesis Feb 14, 2014 @ 8:15pm 
Did you try running the game as administrator and in compatibility mode ? Also try the other settings available in the executable properties such as "Disable desktop composition" and so on.
Enmity NZ Feb 14, 2014 @ 8:35pm 
i have the Qnix QX2710LED running 2560x1440p theres no settings available on this monitor other than brightness but is running up to 110Hz. Steam is set to english. I've tried running as admin, tried xp compatibility mode and vista compatibility mode, tried disabling steam overlay but haven't tried disable desktop composition yet. will give that a whirl :)

Thanks guys I appreciate your help
Unbornchild Feb 14, 2014 @ 8:50pm 
That's a 120 Hz screen isn't it?
Try it @ 60 Hz with the game.

Btw, as far as i can see 2560x1440 is not in supported resolutions in the ingame menu(might look differently on your side). Because it is a 16:9 ratio, the Bink videos would play in the wrong (cramped) aspect ratio. But that is passed the calibration screen you haven't seen yet.
For the rest, the actual game should run fine at 16:9 resolution as it does on my laptop.
Last edited by Unbornchild; Feb 14, 2014 @ 8:59pm
Enmity NZ Feb 14, 2014 @ 9:07pm 
yeah my monitor is a 60hz screen, its just been overclocked to 110Hz and set via CRU. Default is 60hz but if the game supports it, 110hz is selectable in the game options. Perhaps I have to force dark messiah to launch at a lower resolution like 1080p? Im pretty sure u can do that in the launch options in steam actually - i'll try that out. BTW - the disable desktop composition didn't work either :(
Enmity NZ Feb 14, 2014 @ 9:10pm 
-w 1920 -h 1080 in launch options isn't working either. nor is -novid to try and skip the intro videos, no dice
Unbornchild Feb 14, 2014 @ 9:17pm 
You are using DVI-D output?

Compatibility of VGA : These monitors are using Bypass type board. This type has compatibility issue with Graphic cards and Mainboards. Please check the compatibility chart before make purchase.

These monitors do NOT compatible with Laptops and Mac computers. Internal GPU, APU and Low profile GPU and not compatible.
We do NOT recommend using with any macbooks or laptops.
Recommended Graphic cards : NVIDIA - GTX460 or more than 1GB memory, with Dual Linked Dvi-D port / ATI - HD6850 or more than 1GB memory, with Dual Linked DVI-D port.
Recommended Graphic cards : GTX580 or HD6970. The GPU should have 2 Dual linked DVI port Please use DVI-D port only. Cannot be used with DVI-I or DVI-S
*As P67 Chipset mainboard may show Booting skip error, and also the screen may not work out properly.
"Please use DVI-D port only."
(Source http://www.overclockmonitor.com/qnix/qnix-qx2710-led-evolution-2-oc-m-pf.html)
< >
Showing 1-15 of 57 comments
Per page: 15 30 50

Date Posted: Feb 13, 2014 @ 11:50pm
Posts: 57