The Witcher 2: Assassins of Kings Enhanced Edition

The Witcher 2: Assassins of Kings Enhanced Edition

pd12 May 24, 2014 @ 9:24am
[Linux] Fixes / Workarounds ONLY
The aim of this thread should purely be an index of workarounds/fixes.
There's a big thread to post your problems http://steamcommunity.com/app/20920/discussions/0/522728180993106963/ as well as github https://github.com/KillaW0lf04/The-Witcher-2-Issues/issues (they may also have fixes).
People have also been starting new discussions for individual problems they have had.

EACH post MUST contain a fix or workaround, so this thread doesn't get congested with problems and discussion regarding problems.
NO discussion (including thankyous or bumps) of bugs or unconfirmed workarounds. - While everyone appreciates it it'll only clutter the thread causing people to have to trawl through to find answers.

Only post bugs in this thread at the end of your post if your post also includes workarounds/fixes at the start.
I'll be including an incomplete list of known bugs without posted workarounds in this OP.

Anyone who trawls through threads and finds fixes/workarounds please post them here if they're not already posted. Anyone else with fixes/workarounds please also post them. Please include source (links).
Posting of confirmed variants of workarounds welcome.

=================
FIXES
=================
[My (pd12) personal notes will mostly be in these square brackets]

-------Missing SDL2 lib or ANY lib files (game fails to launch / start)----------------
http://steamcommunity.com/app/20920/discussions/0/522728181039691774/#c522728268702458584
run in terminal:
ldd /path/to/executable/witcher2 ldd /path/to/executable/witcher2 | grep not
and check for libraries linked or "not found"

Symbolic link required library files (run in terminal):
ln -s ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libSDL2_image-2.0.so.0 /lib/i386-linux-gnu/ ln -s ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libcurl-gnutls.so.4 /lib/i386-linux-gnu/

If more missing other libraries, just install locate using: "apt-get install locate", then run "updatedb" and use this command to show the library path: "locate missinglibrary.so" and create the link like before. It's probably advisable to link the Steam runtime library files (~/.local/share/Steam/...) to where your system finds library files (/lib/i386-... or /usr/lib/i386-...).

<<<Other Solutions>>>
or, on OpenSUSE: http://steamcommunity.com/app/20920/discussions/0/522728268848525694/
or, use LD_LIBRARY_PATH (not recommended globally)
or, use Steam runtime launcher http://steamcommunity.com/app/20920/discussions/0/522728180993106963/#c522728268935064480
Originally posted by GNU/cirk2:
~/.local/share/Steam/ubuntu12_32/steam-runtime/run.sh ./witcher2
this adds the relevant paths to ld.

[I also personally don't understand why the game doesn't automatically use the steam runtime when launched from steam, but hey, there are many things I don't understand like why this game runs better in wine for many people.]

-------Missing Gnome Keyring----------------
Either run from Steam launcher or (the below still wont' be able to verify your Steam key):
http://askubuntu.com/questions/127848/wine-cant-find-gnome-keyring-pkcs11-so
cd $(mktemp -d) ## create and go to a temporary temp dir apt-get download gnome-keyring:i386 ## download the i386 version of gnome-keyring ar x gnome-keyring*.deb ## Uncompress the package tar xf data.tar.gz ## Finally move the file you need to the desired location: sudo mv usr/lib/i386-linux-gnu/pkcs11 /usr/lib/i386-linux-gnu/

--------Black/Blank Screen------------
http://steamcommunity.com/app/20920/discussions/0/522728268811804386/#c522728268843370490
Originally posted by ShameCZ:
I got a blackscreen on startup as well. I think i solved it by switching sound output to Alsa. Then it started to work, got the cinematics, menu etc ...
[confirmed by pd12 on nVidia GT330M]

<<<AMD only:>>>
Either install latest Catalyst driver manually (http://www.phoronix.com/scan.php?page=news_item&px=MTY5ODY) or do this:
http://steamcommunity.com/app/20920/discussions/0/522728086957775869/#c522728268770446574
Originally posted by Moogly:
To fix black screen issue on ubuntu 14.04 with AMD (this worked for me) :

Base system : ubuntu 14.04 64b with amd driver from ubuntu repositoy
This standard package was installed "fglrx-amdcccle".
Resolution : installed "fglrx-amdcccle-updates' instead of the 'fglrx-amdcccle'

After reboot your computer, the game works well, even if you launch the game from stem launcher.

---------Movement or Keyboard; Remap Keyboard keys Input Config-------------------
http://steamcommunity.com/app/20920/discussions/0/522728086937828976/#c522728086953857443
Originally posted by vaR:
Step 1: Adjust your settings with the GUI Launcher Tool. DO NOT START THE GAME YET!
Step 2: Edit your User.ini (.local/cdprojektred/witcher2/..../User.ini) and remove the additional [input....] section completly. This is a bug and it's loaded twice, once from INPUT_XYZ.ini and from User.ini which makes it fail.

So every time you edit something in the GUI Launcher Tool adjust your User.ini by removing the [input section].
Example:
[InputQWERTZ] IK_0=(GameKey=GI_Holster,Value=1,000000) IK_1=(GameKey=GI_Steel,Value=1,000000) IK_2=(GameKey=GI_Silver,Value=1,000000) ....
I delete this when I have changed something in the GUI Tool. JUST THIS SECTION! :-)

<<<Solution to force output to (default/en_US.UTF-8) locale>>>
http://steamcommunity.com/app/20920/discussions/0/522728180993106963/#c522728268708998979
Originally posted by dubigrasu:
Originally posted by Double:
keyboard don't work ((
Try:
Originally posted by DerRidda:
Add these launch options to the game in Steam and see if it helps:
LC_ALL=en_US.UTF-8 %command%

They made the absolute amateur mistake of not sanitizing culture info which means there will be problems for everyone that has a locale that uses comma for decimal separation.
All of these countries for example: https://en.wikipedia.org/wiki/Decimal_separator#Countries_using_Arabic_numerals_with_decimal_comma
OR
http://steamcommunity.com/app/20920/discussions/0/522728181019551033/
Use LC_ALL=C %command% launch option
Try to run steam as
LC_ALL=C steam
too

--------XBox 360 Wireless Gamepad-----------------------
submitted by: legluondunet http://steamcommunity.com/app/20920/discussions/0/522728268796894424/
Originally posted by Anorak Man:
To get my wireless 360 controller working I had to use xboxdrv instead of Ubuntu's built in xpad. (I'm using elementaryos)

To do this in the terminal:
sudo rmmod xpad sudo xboxdrv

I then had to remap the button bindings in Steam Big Picture.
After this my wireless xbox controller worked in game and in menu fine.

Other workaround options:
http://steamcommunity.com/app/20920/discussions/0/522728268774417794/



----------Missing Dialogue Voices Sounds---------------------
http://steamcommunity.com/app/20920/discussions/0/522728180932320614/#c522728268932160985
Originally posted by Khnazile:
I managed to fix it!
It's actually not related to audio channels, it's due to case-sensitive filenames :)
Here is the command for english voices:
ln -s $HOME/.local/share/Steam/SteamApps/common/the\ witcher\ 2/CookedPC/en0.w2speech $HOME/.local/share/Steam/SteamApps/common/the\ witcher\ 2/CookedPC/EN0.w2speech



<==== More FIXES are posted by others in this thread, below ====>
Last edited by pd12; May 27, 2014 @ 8:55pm
< >
Showing 1-15 of 16 comments
pd12 May 24, 2014 @ 9:24am 
=============
BUGS w/o fixes
=============

Last edited by pd12; May 25, 2014 @ 7:09am
pd12 May 24, 2014 @ 9:25am 
===========
Other News
===========

As of 2014-05-26 I will stop updating the OPs as frequently.
So any fixes people find that are not already posted, please post them below.
To prevent people having to trawl through the thread with unrelated posts, please post ONLY if you have a FIX or WORKAROUND in your post.
Thank you for your co-operation. And thanks all who've posted fixes already!
Last edited by pd12; May 25, 2014 @ 7:21am
legluondunet May 24, 2014 @ 9:34am 
You could add: xbox 360 wireless gamepad recognized but does not work, workaround here: http://steamcommunity.com/app/20920/discussions/0/522728268774417794/
Last edited by legluondunet; May 24, 2014 @ 12:29pm
InnocentLunatic May 24, 2014 @ 9:55am 
Problem: Black Screen on start up, with no response, cannot quit, cannot force quit, cannot kill from processes
Solution(On how to force-kill it): in a terminal, type "killall witcher2 -s 9"
Reason: Skype has this same problem, where the program only responds to "SIGKILL" and not "SIGTERM", which is an incorrect behavior, as sigterm should kill it as well.

Solution(For Black Screen...That causes more problems): Updated AMD driver from the website, however, that caused system wide problems for me that resulted in me needing to reinstall my OS(Although it did allow me to play the game for one session at about 6 FPS and only responding to input 1/5 of the time...) Whoever says that fglrx-updates works, does not for me(I have Radeon HD 5450) :( So for now, I have determined that playing this game is a lost cause until patched as it isn't worth screwing up my whole system to be able to play it once at terrible fps :S
KlarkC May 24, 2014 @ 12:30pm 
Bump
mpmp May 24, 2014 @ 12:35pm 
I got a blackscreen on startup as well. I think i solved it by switching sound output to Alsa. Then it started to work, got the cinematics, menu etc ...
DiamondPugs May 24, 2014 @ 2:37pm 
Bump
crabel May 25, 2014 @ 2:14am 
Info for AMD card owners / Gallium/Mesa users:
I have a pretty old system with a Radeon 4870, not even supported by AMD anymore, so no Catalyst drivers. ...

I have installed Mesa 10.3-git now and its A LOT better e.g. Videos were stutering like cracy and play normally now.

PLEASE NOTE: 10.3-git is an ALPHA version, use at your own risk!! If you are unsure, DON't use it.

That said, for those who feel confident that they can manage problems:
For installing, follow this thread:
http://www.phoronix.com/forums/showthread.php?50038-Updated-and-Optimized-Ubuntu-Free-Graphics-Drivers

After installing these drivers, Steam will complain that direct rendering is disabled. The problem is that Steam uses an outdated version of a library. If it is removed, steam uses the OS version, which is newer and works.

More info and tipps how to fix it can be found here:
http://www.phoronix.com/forums/showthread.php?50038-Updated-and-Optimized-Ubuntu-Free-Graphics-Drivers&p=414813#post414813

If you moved the right file, steam shouldn't complain anymore. After doing that The Witcher worked for me (in a quick test, didn't really play for more than a couple of minutes). Before doing that it was impossible to play.
pd12 May 27, 2014 @ 9:04pm 
-------------Multimonitor Resolution Settings (in User.ini)----------------------
http://steamcommunity.com/app/20920/discussions/0/522728180993106963/#c522728269225532404
Originally posted by Licaon_Kter:
Originally posted by ClementL:
Multimonitor resolution detection is missing, so I turned one of my displays off. It would be nice if this was implemented.
you can edit ~/.local/cdprojektred/witcher2/GameDocuments/Witcher 2/config/User.ini and add whatever resolution you want in the [Viewport] section:
[Viewport]
Height=900
Width=1440

You might need to also edit the [Rendering] section with the aspect ratio:
AspectRatio=0 (for 16:9)
AspectRatio=3 (for 16:10)

Also, avoid using the Launcher->Options again since it can mess around the settings, see here for a different app to set up at least the graphics options: http://forums.cdprojektred.com/threads/29958-Linux-issues-and-user-solutions
Licaon_Kter May 27, 2014 @ 11:44pm 
<<<AMD only:>>>
Latest official Catalyst Beta 14.6 is available: http://support.amd.com/en-us/kb-articles/Pages/latest-linux-beta-driver.aspx

---------Movement or Keyboard; Remap Keyboard keys Input Config-------------------
Keyboard issue happens because the Configurator writes values using comma as a decimal separator (detects locale and adapts it's output?!).
Wrong with comma:
IK_0=(Gamekey=GI_Holster,Value=1,000000)
Right with period:
IK_0=(Gamekey=GI_Holster,Value=1.000000)
This can be fixed, open a terminal in ~/.local/cdprojektred/witcher2/GameDocuments/Witcher 2/config/ and run (this is one loong line so copy it whole):
sed -e 's/\,Value\=1\,000000)/\,Value\=1\.000000)/g' User.ini | sed -e 's/\,Value\=-1\,000000)/\,Value\=-1\.000000)/g' > User.ini-fix && rm -f User.ini && mv User.ini-fix User.ini
Last edited by Licaon_Kter; May 27, 2014 @ 11:45pm
blackout24 May 28, 2014 @ 1:08am 
This should be stickied. Thanks for the keyboard config bugfix. No one caught this during the testing?
tomtomme May 28, 2014 @ 1:24am 
If game does not launch on openSUSE uninstall those via konsole / terminal:

sudo zypper rm a52dec aaa_base-malloccheck acpid alsa-devel alsa-devel-32bit alsa-firmware alsa-tools ant crimson fxload gcc48-gij gcc48-java gcc-gij gcc java java-1_5_0-gcj-compat java-1_5_0-gcj-compat-devel javapackages-tools liba52-0 libxslt-tools xerces-j2-xml-apis xerces-j2-xml-resolver gcc-gij

and REBOOT

(they are however not part of the default install)
Last edited by tomtomme; May 28, 2014 @ 1:27am
NoXPhasma May 28, 2014 @ 1:37am 
There is a response from CDP because of some crashes:

Originally posted by grandmastermoth:
Got this reply from CDPR support regarging my crashing issues:

"Collecting too many saves may lead to crashes. Delete the unneeded saves. You can do it with the Delete option in Load Game menu or straight in the folder where the saves are by default stored in home/username/.local/share/cdprojektred/witcher2/GameDocuments/Witcher 2/gamesaves unless you enabled Steam cloud which makes it impossible to remove the saves from the folder unless you disable Steam cloud then you can do it in this location: home/.steam/steam/userdata/[user id]/20920/remote .Our saves and their thumbnails are unfortunately quite large and the higher the graphics settings the more space they'll take. This unfortunately happens across all non-console platforms (on xbox there's a save number limit). Removing unneeded saves may also help with the graphics issue in the cutscene.

Also, there is a known crash happening sometimes on some graphics drivers upon quitting The Witcher 2 on Linux. The crash is related to Steam overlay. Valve are aware of it and looking at a solution."

For me it does not work fully, I can play longer as before but it's still crashing after 20 minutes. I've deleted all saves, except the last 4 out of 41.
Last edited by NoXPhasma; May 28, 2014 @ 1:37am
I'm getting odd results. When doing a "ldd witcher | grep not" it tells me that libcurl-gnutls.so.4 is missing. However when i go to the steam dir ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libcurl-gnutls.so.4 is there. I also have the libcurl-gnutls.so.4 package installed from the aur and confirm it is located in /usr/lib.

I also get an error when trying to run witcher2 from the directory:

Gtk-Message: Failed to load module "canberra-gtk-module"
** Message: window size should be 487x713

It's odd that the steam runtime doesn't detect the libcurl-gnutls.so.4 file within it's own directory.

I also tried removing the AUR package and linking the file to /usr/lib. No difference.

I can however run the game from the steam launcher. I get great FPS until i reach the arena, where it will freeze at some point and eventually crash.
Last edited by s.plisskin [Linux Mint]; May 28, 2014 @ 12:18pm
MirrorWay May 28, 2014 @ 12:36pm 
About libcurl-gnutls.so.4
It can be "link to broken link", check all link way to correct file.
Also, if your system is 64bit - make sure that link was made from correct architecture path.
< >
Showing 1-15 of 16 comments
Per page: 15 30 50

Date Posted: May 24, 2014 @ 9:24am
Posts: 16