The Witcher 2: Assassins of Kings Enhanced Edition

The Witcher 2: Assassins of Kings Enhanced Edition

[VPLTD] peterm  [developer] Jul 30, 2014 @ 7:28am
[LINUX] Public Beta 2 - buildID 341339
We have just updated our public beta with the first beta of our new D3D9 engine. This now employs a technique similar to WINE's CSMT patches - all OpenGL work is now done by a single worker thread, which the D3D9 engine submits commands to. This means that there is only a single GL context, and this makes management a lot easier for the driver.

So far we've seen quite significant performance gains on nVidia hardware. AMD, with fglrx 14.4 rev 2 is not quite so dramatic -we're working with AMD on that.

We'd also like feedback about the MESA radeonsi driver - we've heard that this is getting good enough to run the game, and we'd like some wider news on it.

Please opt-in, and tell us how things are. You can head on over to the Github issue tracker for the game, and post there:

https://github.com/KillaW0lf04/The-Witcher-2-Issues
< >
Showing 1-15 of 64 comments
Anthas Jul 30, 2014 @ 7:47am 
Works much better now! Before I could barely run it on Low settings, but now it was playable even at Ultra ( Disabled Ubersampling). I have Nvidia Geforce 770 Gtx. It still crashed after couple of minutes :/. Anyways, good job!
[VPLTD] peterm  [developer] Jul 30, 2014 @ 8:08am 
OK, if youre getting crashes please head over to the Github and post there. A crash report saved and posted to Github will be easier than digging it out of our crash reporter server :)
CuriousTommy Jul 30, 2014 @ 8:20am 
I currently am using the open source drivers for my AMD Readon 7950. Everything in game is messed up.
http://steamcommunity.com/sharedfiles/filedetails/?id=293519645
http://steamcommunity.com/sharedfiles/filedetails/?id=293520006

Here is my info:
Processor Information: Vendor: GenuineIntel CPU Family: 0x6 CPU Model: 0x3c CPU Stepping: 0x3 CPU Type: 0x0 Speed: 3401 Mhz 4 logical processors 4 physical processors HyperThreading: Unsupported FCMOV: Supported SSE2: Supported SSE3: Supported SSSE3: Supported SSE4a: Unsupported SSE41: Supported SSE42: Supported Network Information: Network Speed: Operating System Version: Ubuntu 14.04.1 LTS (64 bit) Kernel Name: Linux Kernel Version: 3.13.0-32-generic X Server Vendor: The X.Org Foundation X Server Release: 11501000 X Window Manager: Compiz Steam Runtime Version: steam-runtime-release_2014-04-15 Video Card: Driver: X.Org Gallium 0.4 on AMD TAHITI Driver Version: 3.0 Mesa 10.1.3 OpenGL Version: 3.0 Desktop Color Depth: 24 bits per pixel Monitor Refresh Rate: 59 Hz VendorID: 0x1002 DeviceID: 0x679a Number of Monitors: 1 Number of Logical Video Cards: 1 Primary Display Resolution: 2560 x 1440 Desktop Resolution: 2560 x 1440 Primary Display Size: 23.50" x 13.23" (26.97" diag) 59.7cm x 33.6cm (68.5cm diag) Primary VRAM Not Detected Sound card: Audio device: Realtek ALC1150 Memory: RAM: 15987 Mb Miscellaneous: UI Language: English LANG: en_US.UTF-8 Microphone: Not set Total Hard Disk Space Available: 95695 Mb Largest Free Hard Disk Block: 79226 Mb Installed software: Recent Failure Reports: Mon Jul 28 17:51:54 2014 GMT: file ''/tmp/dumps/crash_20140728105151_15.dmp'', upload yes: ''CrashID=bp-443dcb85-216e-40c2-84e3-bd1ce2140728'' Tue Jul 29 03:50:36 2014 GMT: file ''/tmp/dumps/crash_20140728205034_14.dmp'', upload yes: ''CrashID=bp-f39c5166-4eea-4f79-8eaa-8168f2140728'' Tue Jul 29 16:59:01 2014 GMT: file ''/tmp/dumps/assert_20140729095854_14.dmp'', upload yes: ''CrashID=bp-b57129a7-1b4a-41ca-8074-e3cc62140729'' Wed Jul 30 05:52:13 2014 GMT: file ''/tmp/dumps/assert_20140729225213_15.dmp'', upload no: ''HTTP response code said error'' Wed Jul 30 10:52:18 2014 GMT: file ''/tmp/dumps/assert_20140729225206_1.dmp'', upload yes: ''CrashID=bp-62e1a47c-777a-4c25-be66-1fd0e2140730'' Wed Jul 30 15:06:44 2014 GMT: file ''/tmp/dumps/assert_20140730080624_18.dmp'', upload yes: ''CrashID=bp-0b914472-e5db-44d9-931e-66b8e2140730''
Last edited by CuriousTommy; Jul 30, 2014 @ 8:21am
N3G4TR0N Jul 30, 2014 @ 8:34am 
@curioustommy Doesn't look like you're using the latest driver. Have you tried the oibaf repository?
[VPLTD] peterm  [developer] Jul 30, 2014 @ 8:36am 
Originally posted by CuriousTommy:
I currently am using the open source drivers for my AMD Readon 7950. Everything in game is messed up.

Is that new for the beta? Did it work on the release version?

edit: To clarify, yes, from reports I have read you need a very current version of the radeonsi driver for the game to work. Older versions are simply not feature complete enough to work correctly.
Last edited by [VPLTD] peterm; Jul 30, 2014 @ 8:37am
CuriousTommy Jul 30, 2014 @ 8:41am 
Originally posted by N3G4TR0N:
@curioustommy Doesn't look like you're using the latest driver. Have you tried the oibaf repository?
No, I haven't. I'll try later (hopefully not messing up my OS in the process)

Originally posted by VPLTD Peter Mulholland:
Originally posted by CuriousTommy:
I currently am using the open source drivers for my AMD Readon 7950. Everything in game is messed up.

Is that new for the beta? Did it work on the release version?

edit: To clarify, yes, from reports I have read you need a very current version of the radeonsi driver for the game to work. Older versions are simply not feature complete enough to work correctly.

Sorry, I forgot to say that I opt-in the linux beta.





Renderwut Jul 30, 2014 @ 8:43am 
With the updated linux beta I now just get a black screen. Could be my out of date Nvidia drivers though so I'll try updating them.

Edit: just updated to 340.24 and now it works. Not sure though if it runs smother. Still feels a bit choppy.

Processor Information: Vendor: AuthenticAMD CPU Family: 0x15 CPU Model: 0x2 CPU Stepping: 0x0 CPU Type: 0x0 Speed: 4000 Mhz ... Operating System Version: Linux Mint 16 Petra (64 bit) Kernel Name: Linux Kernel Version: 3.11.0-17-generic X Server Vendor: The X.Org Foundation X Server Release: 11405000 X Window Manager: Mutter (Muffin) Steam Runtime Version: steam-runtime-release_2014-04-15 Video Card: Driver: NVIDIA Corporation GeForce GTX 780/PCIe/SSE2 Driver Version: 4.4.0 NVIDIA 331.20 OpenGL Version: 4.4 Desktop Color Depth: 24 bits per pixel Monitor Refresh Rate: 59 Hz VendorID: 0x10de DeviceID: 0x1004 Number of Monitors: 2 Number of Logical Video Cards: 1 Primary Display Resolution: 2560 x 1440 Desktop Resolution: 4480 x 1440 Primary Display Size: 23,50" x 13,23" (26,97" diag) 59,7cm x 33,6cm (68,5cm diag) Primary Bus: PCI Express 16x Primary VRAM: 3072 MB Supported MSAA Modes: 2x 4x 8x 16x Sound card: Audio device: Realtek ALC887-VD Memory: RAM: 16013 Mb Miscellaneous: UI Language: English LANG: en_US.UTF-8
Last edited by Renderwut; Jul 30, 2014 @ 8:58am
wh1sper_123 Jul 30, 2014 @ 9:00am 
fedora 19. sadly, i was running it @720pon 9800GT before, so it might not provide any useful feedback. nvidia 750Ti 1080p, smooth framerate cca40. only small deterent is if you slowly continously rotate camera, rotation stutters once or twice per circle.
przemo_li Jul 30, 2014 @ 9:17am 
Steam Info show incorrectly OpenGL version

glxinfo | grep OpenGL

should find correct numbers.

(Its Compatibility vs Core profiles, as those numbers are different for Intel, radeon, and nouveau, as Compatibility is not supported for 3.1 and up)

""
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.3.0-devel (git-54a84d9 pontostroy:X11)
[...]
OpenGL version string: 3.0 Mesa 10.3.0-devel (git-54a84d9 pontostroy:X11)
[...]
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 10.3.0-devel (git-54a84d9 pontostroy:X11)
""
przemo_li Jul 30, 2014 @ 9:27am 
Ok. My results:

http://steamcommunity.com/sharedfiles/filedetails/?id=293544360

BUT that occure on non-beta, and it started around the time You released first beta.

Shame cause r600g on 5720M was playable (on lowest possible, but still!)

Will revert to earlier driver version to see if that problem persist.
Slark Kent Jul 30, 2014 @ 9:33am 
It's now smoother with gtx760m with nvidia 340.24 but the lag is not gone. Gets even worse with vsync enabled.
[VPLTD] peterm  [developer] Jul 30, 2014 @ 9:33am 
Originally posted by przemo_li:
Ok. My results:

http://steamcommunity.com/sharedfiles/filedetails/?id=293544360

BUT that occure on non-beta, and it started around the time You released first beta.

Shame cause r600g on 5720M was playable (on lowest possible, but still!)

Will revert to earlier driver version to see if that problem persist.

Can you clarify what hardware and what driver this is with, please?
BiTs Jul 30, 2014 @ 9:46am 
Comon people the open source drivers is no ready for play heavy games 3d....
Use tha main driver nvidia e fglrx. Is the only best option for play well. I using linux for 2 years now and i never played games well with open source drivers...
Cheers & thanks for your efforts! Looking forward to trying this out
Shark Jul 30, 2014 @ 9:57am 
Originally posted by NightOsama:
Comon people the open source drivers is no ready for play heavy games 3d....
Fglrx isn't either, open source drivers are better for quite a few cards.
< >
Showing 1-15 of 64 comments
Per page: 15 30 50

Date Posted: Jul 30, 2014 @ 7:28am
Posts: 64