Apotheon

Apotheon

View Stats:
Apotheon > General Discussions > Topic Details
This topic has been locked
Vermeulen  [developer] Feb 5, 2015 @ 1:02pm
Mac / Linux Open Beta
To try out Apotheon on Linux and Mac, right click on the game and go to Properties. Then go to the 'BETAS' tab, and select the fna-beta branch.

Please let us know if any problems in this thread! No known bugs currently
Last edited by Vermeulen; Feb 5, 2015 @ 1:32pm
< >
Showing 1-15 of 20 comments
ChemBro Feb 5, 2015 @ 3:37pm 
I can play the game just fine, as long as I have the launch option "LC_ALL=C %command%". Otherwise, the game crashes. I use a German layout. This bug is common for Non-US-American Linux users, I guess.
flibitijibibo  [developer] Feb 5, 2015 @ 3:49pm 
Originally posted by ChemBro:
I can play the game just fine, as long as I have the launch option "LC_ALL=C %command%". Otherwise, the game crashes. I use a German layout. This bug is common for Non-US-American Linux users, I guess.
I recently found that certain locales will produce incorrect output in MojoShader if LC_NUMERIC uses ',' rather than '.' for decimal values. This function in particular is the culprit for the GLSL output...

https://hg.icculus.org/icculus/mojoshader/file/31337471b909/mojoshader_common.c#l790

... and the related man page:

http://linux.die.net/man/3/vsnprintf

Originally posted by "TFM":
For some numeric conversions a radix character ("decimal point") or thousands' grouping character is used. The actual character used depends on the LC_NUMERIC part of the locale. The POSIX locale uses '.' as radix character, and does not have a grouping character.

I'm hesitant to just force LC_ALL=en_US.UTF8, depending on how many languages certain titles support, but in this case it might be the better option unless new languages appear.
Last edited by flibitijibibo; Feb 5, 2015 @ 3:50pm
AK47San Feb 5, 2015 @ 3:58pm 
Don't have time for digging deeper now, but I'm getting this on start in Linux:


Originally posted by Log:
System.Exception: 0(4) : error C1068: too much data in type constructor

at Microsoft.Xna.Framework.Graphics.OpenGLDevice+&lt;CreateEffect&gt;c__AnonStorey18.&lt;&gt;m__34 () [0x00000] in &lt;filename unknown&gt;:0
at Microsoft.Xna.Framework.Threading.ForceToMainThread (System.Action action) [0x00000] in &lt;filename unknown&gt;:0
at Microsoft.Xna.Framework.Graphics.OpenGLDevice.CreateEffect (System.Byte[] effectCode) [0x00000] in &lt;filename unknown&gt;:0
at Microsoft.Xna.Framework.Graphics.Effect..ctor (Microsoft.Xna.Framework.Graphics.GraphicsDevice graphicsDevice, System.Byte[] effectCode) [0x00000] in &lt;filename unknown&gt;:0
at Microsoft.Xna.Framework.Graphics.BasicEffect..ctor (Microsoft.Xna.Framework.Graphics.GraphicsDevice device) [0x00000] in &lt;filename unknown&gt;:0
at Apotheon.LineBatch..ctor (Microsoft.Xna.Framework.Graphics.GraphicsDevice graphicsDevice, Int32 bufferSize) [0x00000] in &lt;filename unknown&gt;:0
at Apotheon.LineBatch..ctor (Microsoft.Xna.Framework.Graphics.GraphicsDevice graphicsDevice) [0x00000] in &lt;filename unknown&gt;:0
at Apotheon.ScreenManager.LoadContent () [0x00000] in &lt;filename unknown&gt;:0
at Microsoft.Xna.Framework.DrawableGameComponent.Initialize () [0x00000] in &lt;filename unknown&gt;:0
at Apotheon.ScreenManager.Initialize () [0x00000] in &lt;filename unknown&gt;:0
at Microsoft.Xna.Framework.Game.Initialize () [0x00000] in &lt;filename unknown&gt;:0
at Apotheon.Start.Initialize () [0x00000] in &lt;filename unknown&gt;:0
at Microsoft.Xna.Framework.Game.DoInitialize () [0x00000] in &lt;filename unknown&gt;:0
at Microsoft.Xna.Framework.Game.Run () [0x00000] in &lt;filename unknown&gt;:0
at Apotheon.Program.Main (System.String[] args) [0x00000] in &lt;filename unknown&gt;:0

Last edited by AK47San; Feb 5, 2015 @ 3:59pm
flibitijibibo  [developer] Feb 5, 2015 @ 4:01pm 
Originally posted by AK47San:
Don't have time for digging deeper now, but I'm getting this on start in Linux: *SNIP*

In the Steam launch options, set

LC_ALL=C %command%

And it should work. (Eek, twice that quickly. I may have to do this soon.)
Last edited by flibitijibibo; Feb 5, 2015 @ 4:02pm
flibitijibibo  [developer] Feb 5, 2015 @ 4:22pm 
To try and fix the problem while minimizing forced locale settings, I just added LC_NUMERIC=C to the launch script for both Linux and OSX. If everything updated correctly you'll see it in the latest build (BuildID 516907), and this _should_ let us launch without extra launch settings.

EDIT: Didn't even `export` in the script... should actually work now.
Last edited by flibitijibibo; Feb 5, 2015 @ 4:30pm
Can't launch the Mac version, still get the pop-up message "no Mac version." Yes, I've tried the LC_ALL=C %command% and that just threw a Steam error. Might be that I'm running Yosemite, and Steam seems to hate Macs.
ChemBro Feb 5, 2015 @ 5:00pm 
Fixed it for me, thanks.
flibitijibibo  [developer] Feb 5, 2015 @ 5:04pm 
Originally posted by ThatLauraChick:
Can't launch the Mac version, still get the pop-up message "no Mac version." Yes, I've tried the LC_ALL=C %command% and that just threw a Steam error. Might be that I'm running Yosemite, and Steam seems to hate Macs.
You may have to delete Apotheon altogether, then opt into `fna-beta` on Steam before it actually downloads properly. Steam betas are mysterious creatures like that.
Fuso Feb 5, 2015 @ 7:25pm 
I have tried each thing suggested, yet the message stating that the mac version is not out yet still appears when I try to play.
flibitijibibo  [developer] Feb 5, 2015 @ 7:30pm 
Hard to say what's up without having direct access to the beta branch functionality; SteamDB seems to think that the depots in upstream are the full size of the game, even though that's not the case for default...

https://steamdb.info/app/208750/depots/

I was fighting this same thing earlier today with the old `fna-dev` branch, but when trying to open it up it caused this issue. Making an entirely new beta branch seemed to fix it, but that probably won't be a good fix for every single player.

My best guess is to delete Apotheon and then delete any/all references to `208750` in SteamApps, and hope that opting into `fna-beta` will let you download the right branch when you install it.
Mimakos Feb 6, 2015 @ 3:39am 
aunching fine for me on OSX 10.9 2.4Ghz Inte Core 2 Duo 4GB DDR3
but as soon as it starts there are huge fps drops to the point of it being unwatchab;e. Are there any graphics options avai;ab;e?
adss.tiley Feb 6, 2015 @ 11:49am 
finally got the game working on mac. AMAZING, doesnt even feel like a beta. theres a few frame rate drops here and there going into new areas but other than that the game is flawless and i love it. if youre having trouble delete the files in your steamapps and redownload it with the beta already set in prefrences.
flibitijibibo  [developer] Feb 6, 2015 @ 12:40pm 
Originally posted by Mimakos:
aunching fine for me on OSX 10.9 2.4Ghz Inte Core 2 Duo 4GB DDR3
but as soon as it starts there are huge fps drops to the point of it being unwatchab;e. Are there any graphics options avai;ab;e?
Do you happen to know the graphics card? You can find the info in About This Mac (and I think 10.9 still has it after the More Info button, this changed in 10.10 and I only recently noticed!).
djwrig85 Feb 7, 2015 @ 7:28am 
The game works pretty well for me for the most part. It crashed once, but that's about it. The frame rate does slow down a little bit when there are a lot of characters on the screen, but that may just be the game itself or my computer (OSX 10.9.5, 1.3 GHz Intel Core i5, 4GB 16MHz DDR3). The one recurring issue is that the cursor won't appear in the when I try to use the "fast travel" feature. Other than that the, the beta version is working just fine. This is is a pretty great game!
que movida Feb 7, 2015 @ 10:46am 
awesome!

This game looks awesome!

downloading it as we speak..
< >
Showing 1-15 of 20 comments
Per page: 15 30 50

Apotheon > General Discussions > Topic Details
Date Posted: Feb 5, 2015 @ 1:02pm
Posts: 20