Game of Thrones

Game of Thrones

View Stats:
Rhazes Mar 14, 2013 @ 4:25pm
Skinchanger cant sneak up on Proddy
The game says run up on him and left click as fast as possible. I've tried like 70 times he kicks me every time. It seems pretty simple to do.
< >
Showing 1-8 of 8 comments
Steed Mar 14, 2013 @ 7:37pm 
He started to turn as I advanced, so I can see what might be happening to you - have you tried hitting 'A' (playing controller here) from the point at which the tutorial dialoge appears, to see if you 'snap on'?

If that, and mashing A as you advance haven't worked just try strafing to the side a bit to get closer and behind and hit the button. You should jump up, then start mashing.

I got it first time, but it did feel a little like it wanted to fail, or glitch...
Rhazes Mar 14, 2013 @ 10:12pm 
I had to switch to a xbox 360 controller to get him to attack. I prefer to play with mouse and keyboard so I'll just use it when I have to.
pogomaster Mar 15, 2013 @ 6:08pm 
try with enter it's work for me
super bomberman Mar 17, 2013 @ 4:29pm 
to jump on poddy you need to press enter running up on him then continuously left click, all command like normal attack or in skinchanger mode finding things you press enter to interact.
Gomer Mar 18, 2013 @ 1:01pm 
Are you sure you're trying to attack Proddy? Isn't he busy attacking some woman, making him unable to detect the dog? I think you are talking about the beginning of that mission, when you find a man across a bridge with a detection ring around him. Can you elaborate on where this man you call Proddy is located?
Lengray Mar 19, 2013 @ 3:32pm 
Edit: looking at the OP's profile and stats, he managed to do it and lots more as he's completed the game since his post.
Last edited by Lengray; Mar 19, 2013 @ 3:39pm
Rhazes Mar 19, 2013 @ 5:10pm 
Yes, I have finished the game since that post. I ended up switching to an Xbox 360 controller.
BrwN May 21, 2016 @ 1:34pm 
No, he was talking about what he said, attacking Poddy with the dog. the game is bugged, clicking with the mouse is not working for initiating attack with the dog. I've searched the internet and there is absolutely no support for this type of game breaking/ progression blocking bug, other than this thread.

I've noticed the mouse clicks being extremely buggy as if it was meant only for Xbox.

The only way I was able to even initiate an attack was with the enter button, Thanks to whomever suggested it.
< >
Showing 1-8 of 8 comments
Per page: 15 30 50