Batman™: Arkham Knight

Batman™: Arkham Knight

View Stats:
 This topic has been pinned, so it's probably important
MASTER FIXES FOR BATMAN ARKHAM KNIGHT
This thread contains some of the most common fixes for Batman Arkham Knight and information on how to achieve the best performance with your hardware. Please follow each step closely.

Make sure you meet the minimum requirements
Before going any further please make sure you meet the minimum requirements for this game

OS: Windows 7 SP1, Windows 8, Windows 8.1, Windows 10 - 64bit OS required
Processor: Intel Core i5-750 @ 2.67GHz or AMD Phenom II X4 965 @ 3.40GHz
Memory: 6GB of RAM
Graphics: NVIDIA GeForce GTX 660 or AMD Radeon HD 7870 - 2GB of VRAM Minimum
DirectX: Version 11
Network: Broadband Internet connection
Storage: 45GB of available space

Update your GPU drivers
One of the most common reasons why users experience issues with Batman Arkham Knight is because their GPU drivers are out of date; install the latest GPU drivers from the links below.

Laptop users should also force the game to use the dedicated NVIDIA/AMD GPU instead of the integrated GPU
Use the NVIDIA Control Panel or AMD Catalyst Control Center to force the game to use your dedicated GPU instead of the integrated one

This should help link[www.howtogeek.com]

Manually re-install redistributables
One of the most common issues people have with Batman Arkham Knight are redistributable related; such as MSVCP100.dll, MSVCR100.dll and any D3D errors are usually caused by missing and/or corrupt redistributables.

Go to your Batman Arkham Knight installation folder and locate the 'commonredist' folder.

\steamapps\common\Batman Arkham Knight\_CommonRedist
You should now see three folders;
DirectX
DotNet
vcredist
  • Open the DirectX folder and run "DXSETUP"
  • Open the DotNet folder and run "NDP451-KB2872776-x86-x64-AllOS-ENU"
  • Open the vcredist folder and within the 2010 and 2012 folder run both the x64 and x86 installers.

Getting worser performance than before/resetting graphical/config settings
Batman Arkham Knights' config files and graphics XML file can become corrupt over-time, if a new patch comes out or a tool/tweak was used before. Deleting the config/XML file will cause the game to make fresh new files which can improve performance and eliminate crashes and other issues.

Delete the
"GFXSettings.BatmanArkhamKnight.xml" file, located in
C:\Users\YOURNAME\Documents\WB Games\Batman Arkham Knight

Then delete the games' Binaries and Config folder, if you right click the game in your Library and select 'Properties', from here go to the 'Local Files' tab and select 'Browse Local Files'. From here delete the 'Binaries' folder, open up the 'BMGame' folder and delete the 'Config' folder.

Now while you still have the Batman Arkham Knight Properties windows open select 'Verify Integrity of Game Cache' -- this will vary depending on your PC speed.

Which brings me to the next part...

Verify the Integrity of the Game Cache
Another common issue people experience with Batman Arkham Knight are missing/corrupt files, to repair them verify the game cache

Video Link:
https://www.youtube.com/watch?v=4PZng5vj9ic

Random fps drops/stutter
So after a few months of absence I've returned to this game, however even though I have a much more powerful system I was encountering some pretty severe fps drops/freezes, granted they were occassional and only lasted for a few seconds, it still annoyed me; plus they didn't happen to this extent on my last system.

In the months passed there must've been a Windows Update or driver update that interferes how the in-game fps cap works, it seems to impair GPU usage and because of this causes the random drops/stutters.

I've spent some time testing and believe I have a solution, well, three....

Fix one

Disable in-game fps cap in the BmSystemSettings.ini file

- This will allow the game to run with the lowest latency possible, and eliminates most stuttering, however NPCs may fail to appear on-screen and animations may fail to execute. I'm also unsure as to how the overall stability will be, in the previous games disabling the fps cap/maxsmoothedframerate could lead to random game crashes -- mostly in challenge maps.

Anyway, navigate to your "BmSystemSettings.ini" which will be located in

\steamapps\common\Batman Arkham Knight\BmGame\Config

Remove the Remove the MaxFPS=x line completely, save and exit.

Here's an Imgur library[imgur.com] for help

Fix two

Disable in game fps cap in the BmSystemSettings.ini file, use Adaptive V-Sync (either in-game or through your GPU control panel)

- Minimises screen tearing while improving latency from the standard in-game fps cap.

Adaptive V-Sync can be enabled in Batman Arkham Knight's graphics menu or via your GPU control panel.

Fix three

Disable in-game fps cap in the BmSystemSettings.ini file, enable fps cap in NVIDIA inspector (NVIDIA only) or RTSS for AMD or NVIDIA

- Improves latencies compared to in-game fps cap or Fix two, minor screen tearing may occur.

Download NVIDIA Inspector: https://www.guru3d.com/files-details/nvidia-inspector-download.html

Download RTSS: https://www.guru3d.com/files-details/rtss-rivatuner-statistics-server-download.html

Capping the fps in NVIDIA inspector (NVIDIA only): http://imgur.com/a/S2dRB

Capping the fps in RTSS (AMD or NVIDIA): http://imgur.com/a/ukC1y

For this fix keep any form of V-Sync off.

Game takes a long time to load/hitches
If you're experiencing hitching in Batman Arkham Knight on Windows 8, 8.1 or 10 I suggest adding an exclusion in Windows Defender for the Batman Arkham Knight folder. This will prevent untimely scans of the game directory by Windows Defender during game play which will reduce hitching. This will have the biggest impact after installing the Season of Infamy DLC, but in some cases may also improve overall performance, especially on the first launch after the game data has been updated.

For information on adding exclusions to Windows Defender, please see the links below. The game folder can typically be found at

C:\Program Files (x86)\Steam\SteamApps\common\Batman Arkham Knight

Windows 8/8.1 tutorial[answers.microsoft.com]

Windows 10 tutorial[windows.microsoft.com]

Fullscreen flickering
If you’re playing on a gaming laptop, but the screen is still flickering when running in Fullscreen Mode, try switching to Borderless Mode from within the game. If you cannot do this from within the game you can edit the GSA file manually.

1. Navigate to and open your local GSA file. It can typically be found here:

C:\Users\YOURNAME\Documents\WB Games\Batman Arkham Knight\GFXSettings.BatmanArkhamKnight.xml

2. Find this entry:
<OPTION Name="Display_Mode" Registered="True" Type="Integer" Value="1"> Display_Mode
3.Set the Value to 1, then relaunch the game.

For reference:
0 - Windowed (with border)
1 - Windowed (no border) aka Borderless Window
2 - Fullscreen

Crashing with AMD GPUs
If you have an AMD GPU and you've tried other suggestions in this list such as updating drivers, verifying the game cache but you still find Batman: Arkham Knight is crashing you may want to try enabling Virtual Super Resolution (VSR).

More info can be found here: https://steamcommunity.com/sharedfiles/filedetails/?id=538039217 - izzy69

Misc fixes
If you are using any tools or tweaks that adjust the graphics/config settings of the game try disabling/reverting these changes. Also try disabling any game-overlay programs, such as FPS counters or recording software, to see whether these may be causing any issues with the game.

If you have made edits to config files for Batman Arkham Knight in the past to improve performance, through the use of 3rd party tools or guides, reset your graphics settings using the steps stated in this guide to revert them back to defaults - see "Getting worser performance than before/resetting graphical/config settings"

Managing VRAM
Batman Arkham Knight has to load in a lot of textures quite quickly; this can be quite VRAM intensive so you don't want to be overcommiting on VRAM.

Batman Arkham Knight has a built in VRAM monitor which tells you how much VRAM the game will require; it's recommended to keep this below the amount of VRAM you actually have, if the game requires xGB of VRAM, using a card with less than recommended or overcommitting can seriously affect performance. Keep the amount of VRAM required below what your GPU has.

Keep the VRAM monitor in the acceptable (green) area for best results

Managing RAM
Batman Arkham Knight requires at least 6GB of RAM, if you are getting Windows Out of Memory messages it's likely because you've disabled your Windows PageFile. To re-enable your Windows PageFile go to...
Control Panel\System and Security\System
and select 'System Protection', from here select the 'Advanced' tab and click 'Settings' under Performance.

Go over to the 'Advanced' tab again and under 'Virtual Memory' click 'Change' and from here select 'Automatically manage paging file size for all drives' and hit OK/Apply and restart your system for the changes to take affect.

Reducing Stutter/Hitching
If possible, I recommend disabling any form of V-Sync for Batman: Arkham Knight, both in-game and through GPU control panels/3rd party software, as these can severely increase the amount of stutter/hitching.

Adaptive V-sync shouldn't cause any problems.

It's also recommended to close down any background programs that could be consuming resources if you are limited on available RAM, such any browsers or media players.

If you've followed this guide and still have issues, please create your own thread with a detailed description of the issue.

or

If you have tried the steps above and the game is still not running well for you, please contact Customer Support using the following link[support.wbgames.com]

If you are still unsatisfied remember if you purchased the game on Steam you are entitled to a refund if you have under 2 hours playtime and purchased the game within 14 days.

More info on Steam refunds can be found here
Last edited by Pyrrhic Victory; May 10, 2017 @ 1:01pm
< >
Showing 1-15 of 541 comments
wb.elder.pliny  [developer] Feb 10, 2016 @ 3:43pm 
Thanks for posting this Ghost. Pinning this up for everyone.
JKeift Feb 10, 2016 @ 4:02pm 
Great post, this should address most of the technical support threads that are opened every day.
sidewinder_G Feb 11, 2016 @ 1:30am 
You should also find and include Kaldaien's fixes for RAM and performance in the post above.
rymon Feb 11, 2016 @ 1:38am 
thx for the help

Delete the
"GFXSettings.BatmanArkhamKnight.xml" file,

ive got fixed and better response for startup waiting time (it was 2min or longer) and now no need to waiting.
TopperHarley Feb 11, 2016 @ 4:46am 
I appreciate your time in putting this page together but after trying all those suggestions above I still get stutter/hitching at 60 gliding and driving.Gliding is the worse. I've played the ps4 version and Im told it runs at 30 but my word it runs smooth. 30 on my pc isnt very playable. The stutters are gone but it's laggy and slow . I've tried every fix in vain and Im very sad cause I can run every other game fine ( with adjstments to settings) and I love Batman . i5 3330 Gtx970 16gb Ram win 7. 1080p Normal,Low,Normal on,on,off,off,Trilinear and gameworks off
JKeift Feb 11, 2016 @ 5:24am 
Originally posted by TopperHarley:
I appreciate your time in putting this page together but after trying all those suggestions above I still get stutter/hitching at 60 gliding and driving.Gliding is the worse. I've played the ps4 version and Im told it runs at 30 but my word it runs smooth. 30 on my pc isnt very playable. The stutters are gone but it's laggy and slow . I've tried every fix in vain and Im very sad cause I can run every other game fine ( with adjstments to settings) and I love Batman . i5 3330 Gtx970 16gb Ram win 7. 1080p Normal,Low,Normal on,on,off,off,Trilinear and gameworks off

Have you tried forcing triple buffering? Use the Nvidia Control Panel to force v-sync and triple buffering on the game. That is likely to fix the FPS dips related to gliding and the Batmobile.
TopperHarley Feb 11, 2016 @ 7:27am 
Originally posted by JKeift:
Originally posted by TopperHarley:
I appreciate your time in putting this page together but after trying all those suggestions above I still get stutter/hitching at 60 gliding and driving.Gliding is the worse. I've played the ps4 version and Im told it runs at 30 but my word it runs smooth. 30 on my pc isnt very playable. The stutters are gone but it's laggy and slow . I've tried every fix in vain and Im very sad cause I can run every other game fine ( with adjstments to settings) and I love Batman . i5 3330 Gtx970 16gb Ram win 7. 1080p Normal,Low,Normal on,on,off,off,Trilinear and gameworks off

Have you tried forcing triple buffering? Use the Nvidia Control Panel to force v-sync and triple buffering on the game. That is likely to fix the FPS dips related to gliding and the Batmobile.
Yes and didnt help with issue. thanks
Pyrrhic Victory Feb 11, 2016 @ 7:54am 
Originally posted by sidewinder_G:
You should also find and include Kaldaien's fixes for RAM and performance in the post above.
His fix was designed to be used pre-patch; since then there have been multiple patches that alter how the game handles texture streaming - You can use his tool but you'd probably find it runs worse.
Pyrrhic Victory Feb 11, 2016 @ 7:55am 
Originally posted by TopperHarley:
I appreciate your time in putting this page together but after trying all those suggestions above I still get stutter/hitching at 60 gliding and driving.Gliding is the worse. I've played the ps4 version and Im told it runs at 30 but my word it runs smooth. 30 on my pc isnt very playable. The stutters are gone but it's laggy and slow . I've tried every fix in vain and Im very sad cause I can run every other game fine ( with adjstments to settings) and I love Batman . i5 3330 Gtx970 16gb Ram win 7. 1080p Normal,Low,Normal on,on,off,off,Trilinear and gameworks off
Have you tried moving the game to a faster drive/doing a defrag (if on a HDD) as it can help a lot with texture streaming performance.

Also check to make sure your PC isn't in any type of power saving mode; I left it in that once and you'd be surprised at how much more it stutters.
TopperHarley Feb 11, 2016 @ 8:00am 
Originally posted by GhostMotley:
Originally posted by TopperHarley:
I appreciate your time in putting this page together but after trying all those suggestions above I still get stutter/hitching at 60 gliding and driving.Gliding is the worse. I've played the ps4 version and Im told it runs at 30 but my word it runs smooth. 30 on my pc isnt very playable. The stutters are gone but it's laggy and slow . I've tried every fix in vain and Im very sad cause I can run every other game fine ( with adjstments to settings) and I love Batman . i5 3330 Gtx970 16gb Ram win 7. 1080p Normal,Low,Normal on,on,off,off,Trilinear and gameworks off
Have you tried moving the game to a faster drive/doing a defrag (if on a HDD) as it can help a lot with texture streaming performance.

Also check to make sure your PC isn't in any type of power saving mode; I left it in that once and you'd be surprised at how much more it stutters.
Ya I moved it from my 7200 hard drive to my ssd and the only difference was there was less texture pop ins but problem was still there. My pc is set at always on so no power saving options turned on.
Last edited by TopperHarley; Feb 11, 2016 @ 8:02am
LookWhatICanDo Feb 11, 2016 @ 8:14am 
i got the premium edition yesterday and today i started playing the game but after 5-10 min of playing the game crashed to the desktop with a message!!
Last edited by LookWhatICanDo; Feb 11, 2016 @ 8:54am
TopperHarley Feb 11, 2016 @ 8:41am 
Originally posted by Jacqueline:
i got the premium edition yesterday and today i started playing the game but after 5-10 min of playing the game crashed to the desktop with a message!!
http://imgur.com/4uIKLkN
I wouldn't click on this , user is private. I got hacked before on Steam. Not nice. Why cant you just type your error msg?
Last edited by TopperHarley; Feb 11, 2016 @ 8:42am
Pyrrhic Victory Feb 11, 2016 @ 8:57am 
Originally posted by Jacqueline:
i got the premium edition yesterday and today i started playing the game but after 5-10 min of playing the game crashed to the desktop with a message!!
http://imgur.com/4uIKLkN
MSVCR100.dll is corrupt; reinstall vcredist 2010 located in
\steamapps\common\Batman Arkham Knight\_CommonRedist\vcredist\2010
Install both files
LookWhatICanDo Feb 11, 2016 @ 9:16am 
TopperHarley,i put my profile just for friends only but noth that i;m a hacker or somekind.I've lost an account 7 years ago and that made me take some decisions about my profile.i've taken a picture of the error to show it on the WB forums and posted it here to,in hope that enyone can help me.
the error message is

Rendering thread exception:
Fatal error!
BUILD_JULY_2012 1131609 07-01-2015 16:36.11 Game
Address=0x2ea58a5c(filename not found) [in C:\Windows\system32\KERNELBASE.dll]
Address=0x6c3b14f1(filename not found ) [inC:\Windows\SYSTEM32\MSVCR100.dll]
Address = 0x45361514(filename not found)[in D:\STEAM\\steamapps\common\Batman Arkham knight\Binaries\Win64\BatmanAK.exe(this message here x9 times)
Address=0x312313d2(filename not found) [in C:\Windows\system32\KERNEL32.dll]
Address=0x317954e4(filename not found) [in C:\Windows\SYSTEM32\ntdll.dll]
Address=0x317954e4(filename not found) [in C:\Windows\SYSTEM32\ntdll.dll]........







damn man i've had to right it down manualy...this is the error,it apears in a window.if u whant i will put the post i did to WB comunity
Last edited by LookWhatICanDo; Feb 11, 2016 @ 9:16am
TopperHarley Feb 11, 2016 @ 12:13pm 
The thing I've noticed about this game is the high cpu usage when capped to 60 ingame. I have an i5 3330 3.00Ghz which is above min and it runs at around 70-90 % and when game hitches then it hits close to 100%. When I run game on 30 cap my cpu never goes above 70 and there are no hitches. When I change my resolution to the lowest settings the cpu still hits close to 100% (60 Cap) during hitching!! What gives?? Am I doomed not to play this game at 60 with my cpu??? Time to move on me thinks...
< >
Showing 1-15 of 541 comments
Per page: 15 30 50