F1 2012
F1 2012 > General Discussion > รายละเอียดกระทู้
Fanatec Steering Wheel disconnection issues!
Hello everyone and a happy new 2013! :)

I recently bought F1 2012 on Steam and I'm experiencing a very annoying problem...
During a race or any other quick event my steering wheel will stop responding after a varied period of time driving/playing.
When this happens you can't turn the wheel, use the pedals or any other button on the wheel...
Only way to recover is to power off the wheel and power on again.
Another problem is that when you power on again, you loose forcefeedback as well.

I use the Fantec Porsche 911 GT2 wheel with Fanatec Clubsport pedals (V1).
In-game wheel settings are default, I change my settings directly on the wheel.
I am running the latest firmware and drivers for wheel/pedals on Win7 Ultimate, 32bit.
I got the wheel connected to my PC via usb cable so no wireless connection here.
If you need more info, please ask and I will provide it.

Has anyone else encountered this issue?
Any help would be greatly apreciated, thanks in advance!
< >
กำลังแสดง 1-13 จาก 13 ความเห็น
hmm, fwiw I used the Fanatec Porsche 911 Turbo S with Clubsport pedals on F1 2010 and F1 2011 - I understand F1 2012 to be an incremental update on the same engine so can't see why they would be fundamentally different device wise. I had no problems at all (aside from the game forgetting I had a wheel at all on startup but that's different altogether...)

From your symptoms, I'm inclined to blame the wheel/drivers more than F1 2012. In particular the Fanatec wheels, while excellent, are a little....small-company and aren't flawless. Its quite possible the wheel is crashing or overheating, or has a compatibility issue.

I'd recommend:
- updating the firmware in the wheel
- updating the drives
- turning down the FF effects (to reduce power/heat usage)

(sorry if the above is just sucking eggs)

Otherwise you might have more luck on the Fanatec forums - they tend to be a good bunch as I recall (particularly the CEO...Thomas?)

How are your pedals connected? I guess this would be the decider; if they're connected via the wheel and they go dead too then thats one thing - if they're connected direct to the PC and they still go dead at the same time that's different.

Btw - you have the Clubsports (excellent pedals!) - but please do connect tthem directly to the PC; as I understand it there are USB bandwidth limitations meaning that the sample rate and/or precision is reduced when sharing the connection with the wheel - connect them directly to get full resolution. (correct me if I'm wrong - but that's what I've been understood from a lot of forum trawling over the years. not for all devices, but for these at least).

Good luck :)


Thank you Shivars for the detailed reply! ;)

I've been doing a little troubleshooting of my own since I read your post...
The problem seems to be in the latest Fanatec drivers. Version 144.

The reasoning for this conclusion being that I connected my Clubsport pedals separate from the wheel this time via usb cable and they stop responding along with the wheel.

The wheel does work again if you power it off and on again, but without FFB.
The pedals on the other hand dont have a power off button...you have to unplug the usb cable from the pc and back again to get them working again.

What do you think?
Could it be the drivers rather than firmware or overheating problems?
I should also mention that the wheel is surprisingly cool when this happens.
It usually gets hotter in other games but without any overheating problems.
mmm if the pedals are connected separately from the wheel, and they stop responding too, then its a driver issue - or your PC is otherwise borked.

I assume you don't have the same problem at all in other games - even after long periods of driving?

(I found iRacing a good benchmark of this; it has good FF all over the place because of the track detail, and circuits like Infineon in Star Mazda are a rapid-but-smooth workout of pedals and wheel movements. calibration or other problems always seemed much more obvious in iracing than other games/sims).
I mainly race on consoles for longer periods of time, not much driving time with the Fanatec on the PC unfortunately.
I have tried Project CARS for an extended period of time without any of the above symptoms.
I've been curious to try out iRacing, scared away though by the pricing...
I have also posted the details on the Codemasters F1 2012 forum, curious to see if someone else has encountered this problem...

I have also tried reverting back to older versions of drivers, doesn't fix the problem.
Maybe it is a combination of firmware & drivers or maybe just firmware?
I'm not too happy to revert back to the old firmware but I might just do it to see if that solves the problem.
The new firmware seems much better overall.
แก้ไขล่าสุดโดย Rolle; 2 ม.ค. 2013 @ 5:35pm
I have now tried both F1 2011 & 2012 with the stock (older) firmware and drivers, unfortunately that still didn't solve the problem.
I've done everything that I can think of without any results, I hope that any future F1 titles will work with my GT2 wheel.
It's a shame really, I was really looking forward to play this game... :(
Hello, does the problem show up in other games, too? Sometimes clean Windows installation could solve these weird issues, or eventually Id try the wheel on different pc/laptop to make sure if the problem really is with OS/Drivers/PC you used to play F1 or wheel itself. I just did get T500RS with F1 Addon as well and its fantastic on F1 2011. Hope you get your problem fixe soon, as it would be shame not using another fantastic wheel from Fanatec!

Hello Tom,

Thank you for the reply!
This issue has not shown up in other PC games.
Not even on Gran Turismo 5 (PS3) or Forza 4 (Xbox360)...
The idea of trying the wheel on another PC is not a bad one, I will ask a friend.
If the wheel doesn't work with another PC, it's GAME OVER formula 1! :(

I've heard good things about the T500RS, have fun with it! ;)
I've looked around a bit, and maybe there's one more thing to try, as F1 Game uses profiles to identify the wheel...in the settings should be some sort of switch between keyboard / wheel controller - isnt there an option to select "custom" as well? Since I got it there maybe Id try to select custom if I were you and try set up the wheel controls manually...dunno just guessing but who knows.

Good luck!

แก้ไขล่าสุดโดย kemo; 8 ม.ค. 2013 @ 11:54pm
Thank you for the suggestion Tom, it is much appreciated!
Unfortunately I have tried that option without any success. :(

I believe I've found the solution...

Too long USB cable!

I was using a good quality 5 meter long USB A-type to B-type cable (printer type) without giving any thought to signal loss due to length issues.

I even tried that cable with an active USB hub thinking that it might boost the signal a bit, still didn't work...

I then tried the 1,75 meter long cable supplied with the wheel coupled with a ~1,10m long extension cable directly to the USB port on the PC, that didn't work either!

Maybe due to poor quality cables?

The winning and working combination for me was a 1,40m long USB A-type to Mini B-type from the PC USB port to the active USB hub...
Then the supplied 1,75m wheel cable going to one of the four ports on the active USB hub.
I haven't experienced a single disconnection since using this setup!

The active USB hub that i'm using is a D-Link DUB-H4 if anybody is wondering.
I can't say for certain if you actually need to use an active USB hub, some experimenting is required!
You may want to look for a USB extension cable with a built-in amplifier/signal repeater if you really need to use a longer cable.

I hope this thread will help anyone with a similar problem, good luck and happy racing! :)

That's a great news dude! So it's finally solved and you can fully enjoy ur wheel! Great!
Hi Rolle,

Thanks man for doing the research. I had this problem on PS3 and PC, but xbox360 worked just fine, now I figure out that's due to being a wireless connection probably. I also have an extended usb cable of good quality and at random intervals it's disconnecting.

I'am very happy with your solution.

Rolle: thank you very much for your help. I got disconnection problems with the fanatec wheel (forza csr) in all games. As the wheel worked perfectly in xbox mode, i suspected the usb on the computer or the usb connector on the fanatec wheel. Your suggestion solved it for me (so far)! I use my monitor's usb hub, /hp2475w.

Once again many thanks!
< >
กำลังแสดง 1-13 จาก 13 ความเห็น
ต่อหน้า: 15 30 50

F1 2012 > General Discussion > รายละเอียดกระทู้