Assassin's Creed® III

Assassin's Creed® III

View Stats:
Fear2288 Nov 27, 2012 @ 5:17am
MP: Red NAT and No Sessions
This has been really getting under my skin for the last couple of days.

Are the issues with AC3's multiplayer universal? Like it's something only Ubisoft can, and hopefully will, fix?

Every time I load up the MP I have a red NAT and a Bad "Upload" and when I try and join a session I get stuck in that searching-trying to connect-creating-searching loop. I've had the game for four days now and have yet to play an online match.

All other programs on my PC are closed, I have a good internet connection, and even went through and opened those specific ports that Ubi tells you to on their support page. Yet still it's the same thing over and over.

Out of curiosity I borrowed my friend's Xbox 360 copy and popped in the MP - green NAT, green connectivity, and I got into a match within seconds.....what the hell?

So does anyone have any info regarding possible fixes, whether Ubi has acknowledged the issue, or if this is/isn't a universal problem?
< >
Showing 1-10 of 10 comments
Stra2M Nov 27, 2012 @ 6:03am 
stupid kids dont know what is that nat at all... go ask your parents for "better" internet, or ask some professionals to open those ports for you, stupid...
Nova Nov 27, 2012 @ 10:03am 
actually, i have the same problem. i know what NAT is too, and i've delt with it in plenty of other games.

tried forwarding ports, tried opening all ports/dropping firewalls/DMZing. it always results with the same thing - green NAT in the top right corner, but strict red NAT on the online status page. it tells me two different things...

i believe its a bug. something is definitely not working right.

also, i have a solid 8mb upload. says i have red "bad" upload. awesome.
Heffebaycay Nov 27, 2012 @ 10:43am 
Originally posted by Stra2M:
stupid kids dont know what is that nat at all... go ask your parents for "better" internet, or ask some professionals to open those ports for you, stupid...
If you have nothing constructive to post, simply don't post.

Thanks.
Fear2288 Nov 27, 2012 @ 1:02pm 
Originally posted by Stra2M:
stupid kids dont know what is that nat at all... go ask your parents for "better" internet, or ask some professionals to open those ports for you, stupid...
Don't quite understand the need for hostility. I'm well aware of what NAT is and what it means in this game. I also do in fact have "good internet" and as I already mentioned I have opened those ports.
Saninsince992 Nov 27, 2012 @ 4:34pm 
Okay listen. I had the same problem with AC: Brotherhood and Revelations, and the AC3 multipalyer works great after I fixed the stuff there.

The first thing you should try is looking online for ports to open. Open them over your router (write ipconfig in your search bar in Windows and look for your gateway IP I believe, then paste that in your browser. Alternatively look online for a more detailed guide how to open ports over your router, and look online for the exact ports you need.)

Now, for some people, including me, that won't help either. So if it won't work for you after opening the ports (and please try that first) try this solution that worked for me (for whatever reason - I am no PC expert.)

-Go to Control Panel -> Network and Internet -> Internet Options. A new window should open. Since my Windows is german it's a little difficult to tell you the next step, but there should be a tab called "Connection" or something similar. And in it should be a button at the top called "Create" or "Set up" or similar. You press that and select the second option "Make a new connection anyway" <- or something like that. You should then select brandwidth connection and write in your username and passwort of your router. Then that connection is made (and is easily turned off again at any point.) Restart steam and try again. Alternatively try disconnecting from wifi and plugging in a ethernet cable and only connecting through the brandwidth connection. That's what fixed it for me. The brandwidth connection in general is easily turned off and on again, and shouldn't be a problem otherwise.

Hopefully one of those 2 solutions will work for you. Sorry for the confusement! If you need clearer help just look for the issue online, or look for what people did in the last 2 AC games.

Cheers.
glock o'clock Nov 27, 2012 @ 5:44pm 
Well I didn't need to do this but I this the "Bad Upload" or whatever is just a bug because I have fully functioning internet and a good connection and I'm able to connect to multiplayer in a few seconds. Maybe try restarting your router.
Fear2288 Nov 27, 2012 @ 7:16pm 
Ok so here's an interesting update.

I went through and disabled both my "Home" and "Public" firewalls and tried the MP again. In the past I tried disabling "Home" with no positive result however this time when MP opened I was treated to a Red NAT and Red Connectivity again yet when I tried to join a game I actually got into one and it seemingly ran flawlessly (no noticeable lag). The only issue is that for some reason it would disconnect after every match. Also this was at 4:30 PM EST.

Don't know if it was disabling that "Public" firewall or all the other stuff I've done before along with that but it did finally work today for a couple of matches. I'll try it again sometime to see if it still works.
Nova Nov 28, 2012 @ 8:13am 
i've had no luck so far. pretty sure jakalopeman is right though - the bad upload has GOT to be a bug.
Kenny- Nov 28, 2012 @ 9:04am 
I have a 10 meg upload and still get BAD UPLOAD. Definitely a bug
Saninsince992 Nov 30, 2012 @ 1:41pm 
Guys, I've been playing the every AC multiplayer, and it always stayed on BAD UPLOAD for me, before I fixed it and before I didn't. Red NAT or Green, bad upload seems to always stick. It still works even if it's saying that if you manage to fix it like I have.
< >
Showing 1-10 of 10 comments
Per page: 15 30 50

Date Posted: Nov 27, 2012 @ 5:17am
Posts: 10