Saints Row IV

Saints Row IV

View Stats:
Const!pator Aug 25, 2013 @ 7:28pm
What exactly IS "Failed to Create Graphics Device" Crash Error?
Hello,

I played SR4 a bit recently, and it worked successfully. I went to play it again, today, however, and now it crashes on startup saying what is in the title, "failed to create graphics device." Now, I have gone through and tried the most obvious things already. YES, I have updated my drivers, my specs more than meet minimum requirements, I tried disabling SLI, I tried reinstalling the game, I tried different versions of my gfx drivers, I tried messing with launch options and display settings on SR4.exe, etc. I've been mostly thorough.

My question is simple, however, WHAT does this error mean? I've Googled extensively, and I found NO ONE who could say what exactly this error means. All my other games work except SR4, so I must assume that this is an issue within the game itself. Any assistance is greatly appreciated.

The only thing I could think of that has changed is that I did a Windows Update (♥♥♥♥ if I know why i did that) so maybe that broke some stuff. I'll have to go through and manually delete a whole bunch of updates to see if that's the case.

Regardless, does anyone know what this error is?

Specs:
Geforce GTX 460 SLI (768MB versions) I tried Drivers 320.49 and 326.80 beta (it worked on 320.49 originally)
Core i5-3570k @ stock clock
6GB DDR3-1600 memory
ASUS P8Z77-V LK Mobo
WD Caviar Black 1TB HDD
Windows 7 Ultimate x64

Last edited by Const!pator; Aug 25, 2013 @ 7:30pm
< >
Showing 1-14 of 14 comments
john1231 Aug 25, 2013 @ 7:50pm 
i think its a directx error saying it cant create the image or something like that.
i had that once with another game (think it was resi6) it turned out my graphicscard was faulty

you could try to remove one of your graphicscards and test if it starts up, if it doesnt you could try it with the other one.
not sure thats the problem but if you run out of alternatives it could be worth a try

also rolling back to an older driver 310.9 helped me once (again with this faulty card i had)
Last edited by john1231; Aug 25, 2013 @ 7:53pm
Const!pator Aug 25, 2013 @ 7:51pm 
WHELP, I figured out how to get the game to run (at least for myself.) Although I am still unsure as to what this error exactly means.

I had to remove d3d11.dll from my SR4 folder. This makes no sense to me, because I played the game just fine before with that file. I also don't know if this disabled DX11 for me in doing so, but I don't really care. I will see if replacing with a newer d3d11 dll if it will still run or cause the same problem.
Komarimaru Aug 25, 2013 @ 7:55pm 
I've fixed this before, so may work for you.

Go to:
C:\Program Files (x86)\Steam\steamapps\common\Saints Row IV\_CommonRedist\DirectX\Jun2010

Run the DXSETUP.exe, let it run its course. Once done, verify the games cache through Properties in Steam Library.

I know people see the date in DirectX, go omg it's old. But whatever it adds will not overwrite anything new, sometimes companies add DX tweaks and just use a package to get them installed.

I should add, this is if you already have the most updated DX from Microsoft already.
Last edited by Komarimaru; Aug 25, 2013 @ 8:01pm
Const!pator Aug 26, 2013 @ 6:04pm 
Ahh, I forgot to mention that I did that in my original post. It did not work. I didn't verify the game cache afterwards, but I doubt that would have changed anything. Considering the problem was fixed by removing d3d11.dll from the saints row IV game folder, I at least now know that this is a problem with DirectX. I bet if I had completely uninstalled DirectX and then reinstalled, it would have fixed it.
Racic Aug 28, 2013 @ 9:09am 
I'm having the same problems. My SR4 folder didn't have the DLL there. I'm trying Komarimaru's suggestion now.
Racic Aug 28, 2013 @ 9:22am 
Yeah it didn't work for me. ♥♥♥♥ this piece of♥♥♥♥♥♥game.
Const!pator Aug 30, 2013 @ 6:38pm 
I take it you have tried updating AND also downgrading graphics drivers, Racic? You could perhaps try downloading d3d11.dll and put it in your SR4 folder. If that doesn't work, delete it from there and then try replacing the one in your C:\Windows\system32 folder.

As a last resort, I try reinstalling the game. In my case, it did not help me, but it could help you.
Racic Sep 2, 2013 @ 11:02pm 
I *think* I figured it out. I have 3 monitors, and if I had my desktop duplicated on two of them, the game wouldn't load. If I loaded the game first, then duped it to my main/"TV", then it was fine. I just couldn't have the desktop duped BEFORE I loaded the game.
bestcodename May 6, 2015 @ 10:55am 
I uninstalled the graphics driver and reinstalled it after. This was the only solotion working with me!
killer thriller Nov 18, 2015 @ 4:56pm 
i dont even have the mother ♥♥♥♥ing FOLDER why dont i have it?!
This error is when DX10/11 Context isn't available to your machine. Either that or some other problem
rmebfox1 Dec 22, 2015 @ 3:15pm 
I have Hearts of Iron 3 with the same problem. Any solution/ Why are Steam and Paradox so bad at customer service?
Had a dad Jan 10, 2016 @ 6:35pm 
@rmebfox1
The issue is with your system, not the game.
TyberZhan.33 Jun 4, 2017 @ 5:53pm 
Originally posted by Had a dad:
@rmebfox1
The issue is with your system, not the game.
Whats the Fix than ? Cuse im having the Same Garbage with MC,HOI3 and Factorio.
< >
Showing 1-14 of 14 comments
Per page: 15 30 50

Date Posted: Aug 25, 2013 @ 7:28pm
Posts: 14