Jet Set Radio

Jet Set Radio

Ver estatísticas:
Jet Set Radio > Discussões gerais > Detalhes do tópico
 Este tópico foi afixado, então deve ser importante
jeffc1881 20/set/2012 às 18:02
USB Controller Problems? SOLUTION FOUND!
You have to Emulate an Xbox 360 Controller
1. Download this:

2. Unzip and place file in JSR folder

Program Files\Steam\steamapps\common\Jet Set Radio

3. Run program and plug in your USB gamepad. If it's a common enough gamepad the setup
assistant should set everything up for you. And that's it.

Jeez that was a pain. Hope this post makes it easier for you. Time to finally play the game now.
< >
Exibindo comentários 115 de 52
Tahubob 20/set/2012 às 18:20 
I used yours and another Xbox 360 Controller emulator but neither seems to work with my controller. For some reason no matter what my configuration the game maps the A button to what would be the X button on a Xbox 360 controller, the left analog works, the Start button is mapped to my right trigger and no other button does anything, I can't even spray graffiti! Mine might be a special case (I use a Saitek controller), but if anyone else is getting their controller to work I'd love to hear a solution!
Oh thank god
jeffc1881 20/set/2012 às 22:00 
Just make sure you open the x360ce file within JSR's steam folder. When you open the file for the first time it asks to create certain files, click yes to them. So when I have the program open and then start JSR, it makes a little ding noise. I think that means it's working Other than that I don't really know what else the problem can be
Tetsuo3K 21/set/2012 às 6:44 
I'm having the same problem. I use x360ce with Sonic CD, and it works fine. No such luck with JSR of course. Using Process Explorer I can see the x360ce DLL is loaded, but the ridiculous control mappings suggest directinput is being used. Not sure if there's any way I can work around that.
SYSS Mouse 21/set/2012 às 20:39 
You have to copy the file to the game directory i.e. Program Files\Steam\steamapps\common\Jet Set Radio. You have to copy to every directory that the game use.
zpact 21/set/2012 às 21:15 
I heard that ding noise. But it just doesn't work. Holy!!!! who can help me
Bob_Vila 22/set/2012 às 7:21 
oh thank ♥♥♥♥ for the internet
rebeccajeanine71 23/set/2012 às 12:21 
I haven't tried it out yet..but assuming i installed it correctly I'm hoping it works looks legit enough :P plus most here are saying it works so YAAAAY I hope it works for MEEE :D...I'll be happy just to be able to use the trigger button for graffitti :)!! Thanx for this!!!
Houdini 25/set/2012 às 23:55 
does this resolve the forever turning left issue/down only in menu's?
Tetsuo3K 27/set/2012 às 9:18 
Finally got this sorted out. Turns out x360ce wasn't enabling my gamepad in the settings. If the LED icon in the controller tab won't change from red to green, just load one of the presets. That's the problem I was running into. Doesn't matter if it's for your gamepad or not, just load one of them. The icon should turn green. At that point, just change your mappings as needed.

Apparently this is a known bug, and somehow I had just never encountered it before.
Nuckrieg 28/set/2012 às 4:07 
This emulator didn't solve my problem, i have a cheap ♥♥♥♥♥♥ controller and couldn't configure it with this. However i dowloaded this one and it worked and still is working like a charm. Try it for yourselves. The XInputTest is just for you to check if the controls are OK. You don't have to open it while running the game. The only thing you need is to put the DLLs in Jetsetradio.exe folder.
If some controls aren't how you like them just open the .ini and change them

Tutorial on how to configure (if needed):

Download link (also on the youtube vid description):

Protagonist 1/out/2012 às 10:07 
This worked wonderfully for me. If your having issues with a Gigaware controller, use the Logitech Rumble Gamepad set-up. The trick to fixing your issue if you can not map correctly is to match your controller to something similar. JSR now runs perfectly for me. :D
wiregrind 14/out/2012 às 20:39 
yeah but it makes my game lag for some weird reason you know.
I'll try using motionjoy drivers since my pad is a PS2 one.
DAnNyDiStRaUghT 20/out/2012 às 23:06 
Wait, just to clarify: this is to emulate an Xbox 360 controller if someone doesn't have one already, but instead for someone who uses a third-party controller (Logitech, Saitek, etc.) correct? I haven't installed the game yet but I do use a Xbox 360 wireless controller for some games on my PC so should I be OK?
Pod 27/out/2012 às 8:47 
Works for me (Like it did for Dark Souls). Using a PS2 pad I've had for yearrrrs.
< >
Exibindo comentários 115 de 52
Por página: 15 30 50

Jet Set Radio > Discussões gerais > Detalhes do tópico