Sins of a Solar Empire: Rebellion

Sins of a Solar Empire: Rebellion

View Stats:
Broco Jan 4, 2019 @ 12:14am
Game not starting
I cannot start the game any more, on Windows 7 it worked fine but now that I moved to Windows 10 I cannot start it any more.

I moved my entire Steam folder. Tried running the dev exe but it just gives multiple errors, e.g.:

Assert @ d:\dev\projects\perforce\ec2\sins1\dlc4\codesource\engine\file\filesystem.cpp(408) !FAILED(hr)

Failed to Open File: 'MyȀam䓦ꈀ\My Games\Ironclad Games\Sins of a Solar Empire Rebellion\Setting\rebellion.user.dev.setting'

What I tried so far:
1) Verifying game files multiple times
2) Reinstalling the entire game (Uninstall in Steam and Reinstall)
3) Driver updates etc. as suggested in other forum posts etc. (aka used Google)

Any hints?
Last edited by Broco; Jan 4, 2019 @ 3:58am
< >
Showing 1-6 of 6 comments
Schweigy Jan 4, 2019 @ 9:03pm 
i got windows 10 and the same issue man.
MFD Suraj Jan 5, 2019 @ 3:14am 
i use w 10 since long and any trouble with it, maybe check the update of w10 !
Broco Jan 5, 2019 @ 3:15am 
Just to add: When I reinstalled my PC with Windows 10 I changed the Steam folder but this hasn't been a problem for any other game. I also completely reinstalled Sins multiple times now, manually deleting any files in My Games and in the Steam folder.

Seems to be an encoding / permission issue but I just cannot figure out what it is.

EDIT:
FOUND THE SOLUTION

It's actually Windows Defender blocking access to the files.

Fix:
Windows Defender Security Center >> Virus and threat Protection >> Virus and threat Protection settings >> Turn off "Controlled Folder Access"

Then verify game files again and start.
Last edited by Broco; Jan 5, 2019 @ 3:49am
Esmarix Jan 14, 2019 @ 5:43pm 
also remember that if you cant start the game after that fix check your settings file and see if the line
"VideoIsWindowed TRUE" is set to true or false. Windows 10 has issues launching some games in fullscreen mode. When the game launches then just use alt+enter to get fullscreen. Just remember that if it doesnt launch the next time then check the settings again if you forgot to go into windowed mode again before shutting the game down.
Evistarator Feb 18, 2019 @ 3:26pm 
Hey Broco, instead of outright disabling Controlled Folder Access, Add the .exe for sins and steam to the allowed apps and that will work as well.
Broco Feb 19, 2019 @ 10:47am 
Ah cool, thanks. I'm still getting used to the new windows permission system, I'm more a Linux kind of guy, my applications usually just do exactly what they are supposed to :D
< >
Showing 1-6 of 6 comments
Per page: 15 30 50

Date Posted: Jan 4, 2019 @ 12:14am
Posts: 6