Retro City Rampage™ DX

Retro City Rampage™ DX

Shard Nov 10, 2013 @ 4:15pm
Game suddenly closes within a minute of launching
I've tried several times to start playing the game, but every time it just closes out randomly. It's not even a clear crash with a message or anything, the program just closes. It's not at a particular point either, as far as I can tell, the furthest I've gotten is the title screen. I have an ASUS laptop, but I'm fairly certain it doesn't have Xonar. I have tried
-Big picture mode, dedicated graphics, controller
-Normal Steam, dedicated graphics, controller
-Normal Steam, dedicated graphics, no controller
-Normal Steam, integrated graphics, no controller.

Has anyone else had any problems like this?
< >
Showing 1-3 of 3 comments
Behemoth Nov 17, 2013 @ 9:44am 
That's the same for me. The game crash after few minutes without any error message. I can not play this game since I bought it.

You talk about Xonar card, why ? I have a Xonar soundcard, that's a problem ?
Shard Nov 17, 2013 @ 1:30pm 
When I tried to research the problem, ASUS Xonar cards were mentioned several times as causing the game to crash.

EDIT: I should also mention that I tried running the DRM-free version of RCR, and I didn't encounter any problems. Whatever this is, it's definitely just the Steam version for me.
Last edited by Shard; Nov 17, 2013 @ 6:00pm
BullGod Nov 25, 2013 @ 8:48am 
Interesting, I use a Xonar D1 and RCR seems to freeze about half a minute into the game including sound stutters, sometimes followed by an unfreezing, only to freeze again in ~10 sec. intervals.
< >
Showing 1-3 of 3 comments
Per page: 15 30 50

Date Posted: Nov 10, 2013 @ 4:15pm
Posts: 3