Superbrothers: Sword & Sworcery EP

Superbrothers: Sword & Sworcery EP

View Stats:
Kitkoan Dec 17, 2012 @ 4:08pm
Doesn't work on Linux
I've downloaded this for Linux and so far, when ever I try to launch it, nothing happens.

Has anyone been able to get this to work? I've tried to delete and re-download the game to no hope
< >
Showing 1-15 of 33 comments
Ozymandias Dec 17, 2012 @ 7:56pm 
Yes, the problem is is that the file in its lib folder is mislabeled.

mv ~/.local/share/Steam/SteamApps/common/Superbrothers\ Sword\ \&\ Sworcery\ EP/lib/ ~/.local/share/Steam/SteamApps/common/Superbrothers\ Sword\ \&\ Sworcery\ EP/lib/

in a terminal should fix it.
Last edited by Ozymandias; Dec 17, 2012 @ 7:57pm
Ozymandias Dec 17, 2012 @ 7:57pm 
I realized after posting that, that it is REALLY hard to read that command.... What you need to do is move the file to inside of the lib subdirectory of the games install path.
Kitkoan Dec 17, 2012 @ 8:56pm 
Its ok that it might be hard to read, but it was a nice cut and paste command. Thank you so much, it worked
[Bad]Karma! Dec 18, 2012 @ 5:03am 
Strange things, the game works for me without lib solution.
Debian Sid
jpakkane Dec 18, 2012 @ 6:06am 
Does not work for me. However my game data is not in .local/share but in ~/Steam/SteamApps/etc.

The binary itself is 32 bit, whereas I run 64 bit. Maybe that could cause some issues.
Ozymandias Dec 18, 2012 @ 9:41pm 
It could be that if you run a 32-bit system it is fine with using the system lib, but those of us using a 64-bit system need to rename the file correctly for it to be able to work.
crystal radio Dec 19, 2012 @ 12:50pm 
I'm having the same issue on a 64 bit system, but renaming that file hasn't fixed it.
KesT Dec 20, 2012 @ 4:22am 
Same problem here on Ubuntu 12.10 64 bits.

Like jpakkane my steam folder is on my user's directory (/home/user/Steam/ ) not on /.local/

saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 150 (XFree86-VidModeExtension)
Minor opcode of failed request: 10 (XF86VidModeSwitchToMode)
Value in failed request: 0x29f
Serial number of failed request: 141
Current serial number in output stream: 143

That's the error that I see when I launched steam from terminal
Last edited by KesT; Dec 20, 2012 @ 5:33am
AlphaPlus Dec 20, 2012 @ 7:33am 
you can get more meaningful error messages if you run ../SteamApps/common/Superbrothers Sword & Sworcery EP/ from a terminal. After changing the name of to it now fails to run with error message

./swordandsworcery_pc: error while loading shared libraries: cannot open shared object file: No such file or directory

Does anyone know where to get this lib? I'm running Ubuntu 12.04 LTS x64.
Choobs Dec 20, 2012 @ 10:59am 
The problem seems to be that many (most, all?) games are 32bit, as is Steam itself. This isn't a problem, really, but it means that sometimes you'll be missing a library or two - you'll have the 64 bit stuff installed but not necessarily the 32bit ones. Many games will, no doubt, include their own versions but not all of them will.

To diagnose this problem, I went into the installdir of the game (right click on the game in steam, properties, etc) then tried to run Right enough, it complained about missing libraries which I then installed. Game now runs perfectly.

sudo apt-get install libcurl3:i386 libglu1-mesa:i386

should get you sorted. I imagine that over time this will stop being an issue as you'll gradually install all the compatibility libraries you're likely to need. Hope this helps :)

Choobs Dec 20, 2012 @ 11:02am 
Incidentally - top tip - sticking :i386 on the end of a package name gets you the 32 bit version :)
crystal radio Dec 20, 2012 @ 12:26pm 
That worked great! Thanks a lot. :)
ecma [Linux] Dec 20, 2012 @ 8:14pm 
Same issue here, got it working with the solutions posted above, thanks guys!
Stantron5000 Dec 21, 2012 @ 9:26am 
Great easy fix! Thank you!
Duke Dec 23, 2012 @ 12:35pm 
Strange, the game works flawless by me. I've just installed and played it.
< >
Showing 1-15 of 33 comments
Per page: 15 30 50