X3: Albion Prelude

X3: Albion Prelude

View Stats:
Steam won't launch game. Linux fun
But it does launch. Thanks steam support for not mentioning that at all, making me waste my time re-installing and verifying etc, then claiming it's not your problem when the game works fine except when trying to launch it through steam. Azhats.

Options (limited) are found in game, only view distance is available frrom start menu.
Originally posted by aiwendilh:
The "Launcher" X3AP_config crashes but running it manually through "X3AP_main" works? Had that problem (and I think steam starts the launcher). x3ap ships an own version of libz in <steam>/steamapps/common/X3 Terran Conflict/lib. The problem seem to be that for some reason it still uses the system libpng (even though it ships a 1.2 version...but maybe because of that..1,2 is not compatible with 1.6 so probably something uses 1.6 which is from your system. But on my system libpng needs a newer libz version than shipped by the game..so trying to use the bundled libz results in an error.

Okay..I talk too much...solution for me was renaming "<steam>/steamapps/common/X3 Terran Conflict/lib/libz.so.1 to libz.so.1.bak...now x3 uses my system libz and the launcher works..even if started from steam.
< >
Showing 1-10 of 10 comments
I just run it through Steam no problem.
Fedora01 Feb 3, 2018 @ 8:25pm 
The only reason I can think of off the top of my head you'd want to/need to run the game externally from steam is if you wanted to install Litcube's Universe.
Also: most options are either through the launcher or while in game.
PsychotropicDog Feb 4, 2018 @ 4:19am 
Ok just so it's clear, the game crashes as soona s I try to launch it through steam.

Most options.. as in 'Most genereal terms' i.e. 'post process on or off. Kind of would maybe like to check boxes here.
The author of this topic has marked a post as the answer to their question.
aiwendilh Feb 4, 2018 @ 8:35am 
The "Launcher" X3AP_config crashes but running it manually through "X3AP_main" works? Had that problem (and I think steam starts the launcher). x3ap ships an own version of libz in <steam>/steamapps/common/X3 Terran Conflict/lib. The problem seem to be that for some reason it still uses the system libpng (even though it ships a 1.2 version...but maybe because of that..1,2 is not compatible with 1.6 so probably something uses 1.6 which is from your system. But on my system libpng needs a newer libz version than shipped by the game..so trying to use the bundled libz results in an error.

Okay..I talk too much...solution for me was renaming "<steam>/steamapps/common/X3 Terran Conflict/lib/libz.so.1 to libz.so.1.bak...now x3 uses my system libz and the launcher works..even if started from steam.
PsychotropicDog Feb 5, 2018 @ 5:33am 
Ah great, now I can use the config tool as well. Thanks!
Thanks!
It was the solution for me, and I wouldn't have found it alone.:steamhappy:
coval Sep 30, 2018 @ 7:00pm 
thx aiwendilh,
works for me
welli18 Oct 1, 2018 @ 11:20am 
X3 Reunion auch das mit der libz.so.1
Ein guter Tip von aiwendilh

Originally posted by aiwendilh:
The "Launcher" X3AP_config crashes but running it manually through "X3AP_main" works? Had that problem (and I think steam starts the launcher). x3ap ships an own version of libz in <steam>/steamapps/common/X3 Terran Conflict/lib. The problem seem to be that for some reason it still uses the system libpng (even though it ships a 1.2 version...but maybe because of that..1,2 is not compatible with 1.6 so probably something uses 1.6 which is from your system. But on my system libpng needs a newer libz version than shipped by the game..so trying to use the bundled libz results in an error.

Okay..I talk too much...solution for me was renaming "<steam>/steamapps/common/X3 Terran Conflict/lib/libz.so.1 to libz.so.1.bak...now x3 uses my system libz and the launcher works..even if started from steam.
Poob Oct 3, 2018 @ 8:53am 
if you've got wine installed for other things, depending on your distribution its pretty likely that you've got dependencies used by wine that are in conflict with the game. If possible, try to localize any wine installation you have so that X3 tries to use it's own pre-packaged libs.
Originally posted by aiwendilh:
The "Launcher" X3AP_config crashes but running it manually through "X3AP_main" works? Had that problem (and I think steam starts the launcher). x3ap ships an own version of libz in <steam>/steamapps/common/X3 Terran Conflict/lib. The problem seem to be that for some reason it still uses the system libpng (even though it ships a 1.2 version...but maybe because of that..1,2 is not compatible with 1.6 so probably something uses 1.6 which is from your system. But on my system libpng needs a newer libz version than shipped by the game..so trying to use the bundled libz results in an error.

Okay..I talk too much...solution for me was renaming "<steam>/steamapps/common/X3 Terran Conflict/lib/libz.so.1 to libz.so.1.bak...now x3 uses my system libz and the launcher works..even if started from steam.

This helped me too, thanks.
< >
Showing 1-10 of 10 comments
Per page: 15 30 50